From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: MaintenanceVdsCommand sorting
......................................................................
core: MaintenanceVdsCommand sorting
Replaces the outdated Collections.sort(Collection, Comparator) and
Collections.reverseOrder(Comparator) syntax by the modern
List.sort(Comparator) and Comparator.reversed().
At the very least, calling these methods cleans up the code and makes it
easier to read while retaining the same performance. It may, however
improve performance in some list and/or comparator implementations, if
they choose to override these methods.
Change-Id: I6110eaca36da3980c99e039a9356d4bb0916d715
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MaintenanceVdsCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit
https://gerrit.ovirt.org/68583
To unsubscribe, visit
https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6110eaca36da3980c99e039a9356d4bb0916d715
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>