Omer Frenkel has submitted this change and it was merged.
Change subject: core: replace explicit field names with constants
......................................................................
core: replace explicit field names with constants
In VdsUpdateRunTimeInfo we used to have explicit strings for "appList"
and "status", representing the names of those fields in VmDynamic.
This patch changes that - new constants are declared in VmDynamic,
which hold those strings and VdsUpdateRunTimeInfo now uses them.
In addition, places where we used to check the size of collections just
to see if they are empty or not are replaced with calls to "isEmpty"
method - it is better in terms of readability and for some data
structures it is more efficient.
Change-Id: I614fecc4238cfffbf152b1b39e3c7995974188c2
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M
backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VmDynamic.java
M
backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsUpdateRunTimeInfo.java
2 files changed, 9 insertions(+), 6 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit
http://gerrit.ovirt.org/23101
To unsubscribe, visit
http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I614fecc4238cfffbf152b1b39e3c7995974188c2
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server