Change in ovirt-engine[master]: core: simplify MigrateVmCommand#getAuditLogTypeValue

Omer Frenkel has submitted this change and it was merged. Change subject: core: simplify MigrateVmCommand#getAuditLogTypeValue ...................................................................... core: simplify MigrateVmCommand#getAuditLogTypeValue This method used to contain a ternary-if statement with 3 and 4 levels which made it less readable. By extracting the those levels to separate methods, the highest level within that ternary-if statement was reduced to 2 and now it is more readable. Change-Id: I54f4e026199187212a872eaef27933a845194b55 Signed-off-by: Arik Hadas <ahadas@redhat.com> --- M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmCommand.java 1 file changed, 20 insertions(+), 7 deletions(-) Approvals: Omer Frenkel: Verified; Looks good to me, approved -- To view, visit http://gerrit.ovirt.org/21721 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: merged Gerrit-Change-Id: I54f4e026199187212a872eaef27933a845194b55 Gerrit-PatchSet: 2 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Arik Hadas <ahadas@redhat.com> Gerrit-Reviewer: Allon Mureinik <amureini@redhat.com> Gerrit-Reviewer: Arik Hadas <ahadas@redhat.com> Gerrit-Reviewer: Omer Frenkel <ofrenkel@redhat.com> Gerrit-Reviewer: oVirt Jenkins CI Server
participants (1)
-
ofrenkel@redhat.com