Change in ovirt-engine[master]: core: GlusterSnapshotScheduleJob maps

From Allon Mureinik <amureini@redhat.com>:
Allon Mureinik has submitted this change and it was merged. Change subject: core: GlusterSnapshotScheduleJob maps ...................................................................... core: GlusterSnapshotScheduleJob maps Anonymously implementing a HashMap just to place values in it is a bad practice which both "spams" up the classloader with useless anonymous classes and produces code that's hard to read. This patch removes the instances of that practice and replaces them with the better performing Collections.singletonMap where possible or with an old fashioned HashMap with a series of put calls where it isn't. Change-Id: I6b9bea8c05664d6eba8ef2693690f5a17c13e86c Signed-off-by: Allon Mureinik <amureini@redhat.com> --- M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSnapshotScheduleJob.java 1 file changed, 7 insertions(+), 11 deletions(-) Approvals: Denis Chaplygin: Looks good to me, but someone else must approve Tal Nisan: Looks good to me, approved Allon Mureinik: Verified; Passed CI tests -- To view, visit https://gerrit.ovirt.org/72592 To unsubscribe, visit https://gerrit.ovirt.org/settings Gerrit-MessageType: merged Gerrit-Change-Id: I6b9bea8c05664d6eba8ef2693690f5a17c13e86c Gerrit-PatchSet: 9 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Allon Mureinik <amureini@redhat.com> Gerrit-Reviewer: Ala Hino <ahino@redhat.com> Gerrit-Reviewer: Allon Mureinik <amureini@redhat.com> Gerrit-Reviewer: Denis Chaplygin <dchaplyg@redhat.com> Gerrit-Reviewer: Jenkins CI Gerrit-Reviewer: Sahina Bose <sabose@redhat.com> Gerrit-Reviewer: Tal Nisan <tnisan@redhat.com> Gerrit-Reviewer: gerrit-hooks <automation@ovirt.org>
participants (1)
-
Code Review