Change in ovirt-engine[master]: engine: Retain gluster task id on volume when task is stopped
by kmayilsa@redhat.com
Kanagaraj M has submitted this change and it was merged.
Change subject: engine: Retain gluster task id on volume when task is stopped
......................................................................
engine: Retain gluster task id on volume when task is stopped
Earlier, when a rebalance task completes, the taskid associated
with the rebalance operation that was stored in the volume
was cleared.
With this patch, we are retaining the task id as we need to
know the status of the last run task on a volume. In case of
stop, the status of task is aborted.
Change-Id: I9c5888f3b369c0f1db631085065649c2cdc75346
Signed-off-by: Sahina Bose <sabose(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterAsyncCommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/StopRebalanceGlusterVolumeCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/StopRebalanceGlusterVolumeCommandTest.java
3 files changed, 5 insertions(+), 7 deletions(-)
Approvals:
Kanagaraj M: Looks good to me, approved
Sahina Bose: Verified
--
To view, visit http://gerrit.ovirt.org/18920
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9c5888f3b369c0f1db631085065649c2cdc75346
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Ramesh N <rnachimu(a)redhat.com>
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Shubhendu Tripathi <shtripat(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 2 months
Change in otopi[otopi-1.1]: packaging: spec: use %exclude
by Alon Bar-Lev
Alon Bar-Lev has submitted this change and it was merged.
Change subject: packaging: spec: use %exclude
......................................................................
packaging: spec: use %exclude
I avoided using %exclude as I remembered that some rpm implementations
do not support that.
Then I remembered that it was the AIX rpm implementation... and we do
not support that for packaging.
Change-Id: Id697890aef516a8720c66862b43ec35fdb154cc0
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M otopi.spec.in
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Alon Bar-Lev: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19375
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id697890aef516a8720c66862b43ec35fdb154cc0
Gerrit-PatchSet: 1
Gerrit-Project: otopi
Gerrit-Branch: otopi-1.1
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
11 years, 2 months
Change in otopi[master]: packaging: spec: use %exclude
by Alon Bar-Lev
Alon Bar-Lev has submitted this change and it was merged.
Change subject: packaging: spec: use %exclude
......................................................................
packaging: spec: use %exclude
I avoided using %exclude as I remembered that some rpm implementations
do not support that.
Then I remembered that it was the AIX rpm implementation... and we do
not support that for packaging.
Change-Id: Id697890aef516a8720c66862b43ec35fdb154cc0
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M otopi.spec.in
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Alon Bar-Lev: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19373
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id697890aef516a8720c66862b43ec35fdb154cc0
Gerrit-PatchSet: 1
Gerrit-Project: otopi
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
11 years, 2 months
Change in ovirt-engine[master]: engine: Cache spice support for os/compatibility version
by tjelinek@redhat.com
Tomas Jelinek has submitted this change and it was merged.
Change subject: engine: Cache spice support for os/compatibility version
......................................................................
engine: Cache spice support for os/compatibility version
Patch 31903bda17f97c2d785238b3d0d557d3c24f40b9 introduced detection of
spice support on OSs and compatibility version. This detection
implemented as an async query to OsRepository. This query is called from
updateActionAvailability but the design requires the calls to be
synchronous. This patch introduces caching spice support depending on
all OSs and compatibility versions.
Change-Id: Ib97d68ccd0d30fd07e8d1a7d1322f731aef220f7
Signed-off-by: Frantisek Kobzik <fkobzik(a)redhat.com>
Bug-Url: https://bugzilla.redhat.com/998705
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/OsRepositoryQuery.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/HotPlugDiskToVmCommandTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/osinfo/OsRepository.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/osinfo/OsRepositoryImpl.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/OsQueryParameters.java
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/osinfo/OsRepositoryImplTest.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/dataprovider/AsyncDataProvider.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/ConsoleModelsCache.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmListModel.java
9 files changed, 64 insertions(+), 39 deletions(-)
Approvals:
Tomas Jelinek: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19137
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib97d68ccd0d30fd07e8d1a7d1322f731aef220f7
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Frank Kobzik <fkobzik(a)redhat.com>
Gerrit-Reviewer: Frank Kobzik <fkobzik(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 2 months
Change in ovirt-engine[master]: engine: Added profile logging to VM run/VNIC plug
by masayag@redhat.com
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Added profile logging to VM run/VNIC plug
......................................................................
engine: Added profile logging to VM run/VNIC plug
Added logging of profile information to the flows of running a VM and
hot plugging a VNIC.
Change-Id: I483745793213a49fcb0ca1ad0d75ec4faf22f35c
Bug-Url: https://bugzilla.redhat.com/1005544
Signed-off-by: Mike Kolesnik <mkolesni(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VmInfoBuilder.java
1 file changed, 6 insertions(+), 2 deletions(-)
Approvals:
Moti Asayag: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/18967
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I483745793213a49fcb0ca1ad0d75ec4faf22f35c
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 2 months
Change in ovirt-engine[master]: frontend: [JP] Resource allocation broken
by tjelinek@redhat.com
Tomas Jelinek has submitted this change and it was merged.
Change subject: frontend: [JP] Resource allocation broken
......................................................................
frontend: [JP] Resource allocation broken
In new/edit/clone VM the resource allocation tab's layout was broken.
Since the original design was too vulnerable to break in different languages
fixed by changing the layout to a more robust one.
Change-Id: Iea77af79f7552d855685fab8a8521a2465808aa7
Signed-off-by: Tomas Jelinek <tjelinek(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/view/popup/AbstractVmPopupView.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/editor/ListModelListBoxOnlyEditor.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/AbstractVmPopupWidget.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/AbstractVmPopupWidget.ui.xml
4 files changed, 89 insertions(+), 31 deletions(-)
Approvals:
Tomas Jelinek: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19326
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iea77af79f7552d855685fab8a8521a2465808aa7
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 2 months
Change in ovirt-engine[master]: frontend: make "any host in cluster" bigger
by tjelinek@redhat.com
Tomas Jelinek has submitted this change and it was merged.
Change subject: frontend: make "any host in cluster" bigger
......................................................................
frontend: make "any host in cluster" bigger
In french locale it was broken into 2 lines. The
width: 150px did not make any sense so removing which
makes it 100% width (the default).
Change-Id: I9e8576b0c355a6ac67a8b3a7c96fa11fb3c87006
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1001853
Signed-off-by: Tomas Jelinek <tjelinek(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/vm/VmRunOncePopupWidget.ui.xml
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tomas Jelinek: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19325
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9e8576b0c355a6ac67a8b3a7c96fa11fb3c87006
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 2 months
Change in ovirt-engine[master]: restapi: Fix botched merge
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: restapi: Fix botched merge
......................................................................
restapi: Fix botched merge
Reintroduced acked changes to test files that were mistakenly removed in
a bad merge of If351d209d7828f0d59926bb98da9317567976d41.
Relates-To: https://bugzilla.redhat.com/show_bug.cgi?id=990962
Signed-off-by: Federico Simoncelli <fsimonce(a)redhat.com>
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
Change-Id: Ia5667a149b7ad832aab6457cb333fa781952c411
---
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendDiskResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainDiskResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendTemplateDiskResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendVmDiskResourceTest.java
4 files changed, 119 insertions(+), 0 deletions(-)
Approvals:
Federico Simoncelli: Looks good to me, but someone else must approve
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19357
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia5667a149b7ad832aab6457cb333fa781952c411
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Federico Simoncelli <fsimonce(a)redhat.com>
11 years, 2 months
Change in ovirt-engine[master]: webadmin: cluster dialog - cropped labels in ES locale
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: webadmin: cluster dialog - cropped labels in ES locale
......................................................................
webadmin: cluster dialog - cropped labels in ES locale
Cluster dialog:
fixed cropped labels in Optimization and Resilience Policy Tabs
(es_ES locale).
Change-Id: Iff1d5d2b3294c047fd63b6b5c8f6dfa37fb6c6d8
Signed-off-by: Daniel Erez <derez(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/cluster/ClusterPopupView.ui.xml
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19353
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iff1d5d2b3294c047fd63b6b5c8f6dfa37fb6c6d8
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 2 months
Change in ovirt-engine[master]: core: rename ExecuteQuery to executeQuery in LDAP commands
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: core: rename ExecuteQuery to executeQuery in LDAP commands
......................................................................
core: rename ExecuteQuery to executeQuery in LDAP commands
Change-Id: I6c52afb969dd607167d8a124fcd88db46f9a158e
Signed-off-by: Alissa Bonas <abonas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/adbroker/InternalAuthenticateUserCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/adbroker/InternalBrokerCommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/adbroker/InternalGetAdGroupByGroupIdCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/adbroker/InternalGetAdUserByUserIdCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/adbroker/InternalGetAdUserByUserIdListCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/adbroker/InternalGetAdUserByUserNameCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/adbroker/InternalSearchGroupsByQueryCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/adbroker/InternalSearchUserByQueryCommand.java
8 files changed, 9 insertions(+), 9 deletions(-)
Approvals:
Yair Zaslavsky: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/19138
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6c52afb969dd607167d8a124fcd88db46f9a158e
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 2 months