Change in ovirt-engine[master]: engine: event should contain the iface which exceeded define...
by alkaplan@redhat.com
Alona Kaplan has submitted this change and it was merged.
Change subject: engine: event should contain the iface which exceeded defined threshold
......................................................................
engine: event should contain the iface which exceeded defined threshold
A general event was reported per host when any of the host's NICs exceeded
the threshold (based TX or RX values). The event didn't contain the nics
name. And containd just the max TX or RX from all the interfaces.
This patch extends it to a specific event per interface.
Change-Id: I22b3510398ac6fa3acf93fcb596dd6ea10b26366
Bug-Url: https://bugzilla.redhat.com/1070667
Signed-off-by: Alona Kaplan <alkaplan(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/AuditLogType.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/VdcEventNotificationUtils.java
M backend/manager/modules/dal/src/main/resources/bundles/AuditLogMessages.properties
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsUpdateRunTimeInfo.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/LocalizedEnums.java
M frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/LocalizedEnums.properties
A packaging/dbscripts/upgrade/03_05_0110_add_host_interface_high_network_use_event.sql
7 files changed, 23 insertions(+), 12 deletions(-)
Approvals:
Alona Kaplan: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/25609
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I22b3510398ac6fa3acf93fcb596dd6ea10b26366
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: mooli tayer <mtayer(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-engine[master]: webadmin: Only set cluster once when opening VM dialog
by lvernia@redhat.com
Lior Vernia has submitted this change and it was merged.
Change subject: webadmin: Only set cluster once when opening VM dialog
......................................................................
webadmin: Only set cluster once when opening VM dialog
Previously the cluster could potentially be called twice in the
initialization of the dialog: once UiCommonEditorVisitor set the
selected item to be the first in the collection, then if the VM
belonged to another cluster the selection would change. This would
cause issues due to asynchronous tasks, triggered by the
selectedItemChangedEvent, returning in reversed order.
This is fixed by using the new overload of ListModel.setItems(), to
make sure that the selected cluster is properly selected the first
time and so won't trigger dual sets of backend queries.
Change-Id: I5b4dd3328f207dadb73ee93d27f084249f3f9704
Bug-Url: https://bugzilla.redhat.com/1070835
Signed-off-by: Lior Vernia <lvernia(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/UnitVmModel.java
1 file changed, 8 insertions(+), 15 deletions(-)
Approvals:
Lior Vernia: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/25652
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5b4dd3328f207dadb73ee93d27f084249f3f9704
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-engine[master]: webadmin: Overload ListModel.setItems() with selectedItem
by lvernia@redhat.com
Lior Vernia has submitted this change and it was merged.
Change subject: webadmin: Overload ListModel.setItems() with selectedItem
......................................................................
webadmin: Overload ListModel.setItems() with selectedItem
Added an overload that includes an argument specifying the desired
selectedItem after the items are set; previously this was being set to
null, which could cause problems if the ListModel is associated with
an editor that implements HasConstrainedValue (because then
UiCommonEditorVisitor would override the null value and select the
first item in the collection).
Change-Id: Id6de644297cdd5eb965720fc64aea1a5a735ea24
Bug-Url: https://bugzilla.redhat.com/1070835
Signed-off-by: Lior Vernia <lvernia(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/ListModel.java
1 file changed, 18 insertions(+), 2 deletions(-)
Approvals:
Tomas Jelinek: Looks good to me, but someone else must approve
Alexander Wels: Looks good to me, but someone else must approve
Vojtech Szocs: Looks good to me, approved
Lior Vernia: Verified
--
To view, visit http://gerrit.ovirt.org/25651
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id6de644297cdd5eb965720fc64aea1a5a735ea24
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-engine[master]: tools: adding missing space to fix type
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: tools: adding missing space to fix type
......................................................................
tools: adding missing space to fix type
Bug-Url: https://bugzilla.redhat.com/1058957
Change-Id: I663852b5ab9617e864413f760afe56e79cbdf3cb
Signed-off-by: Yair Zaslavsky <yzaslavs(a)redhat.com>
---
M backend/manager/tools/src/main/java/org/ovirt/engine/core/config/entity/helper/PasswordValueHelper.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Oved Ourfali: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26229
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I663852b5ab9617e864413f760afe56e79cbdf3cb
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-reports[master]: reports: br45 report - added comments to queries
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: reports: br45 report - added comments to queries
......................................................................
reports: br45 report - added comments to queries
Changed the code structure so it will be more readable
and added commets.
Change-Id: Iefb7be12b92a0f5e1df8eb2cf0179236ca7398b3
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M packaging/ovirt-reports/resources/Reports/users_usage/users_spice_sessions_activity_br45_files/full details.jrxml.data
M packaging/ovirt-reports/resources/Reports/users_usage/users_spice_sessions_activity_br45_files/users_spice_sessions_activity_br45_jrxml.data
2 files changed, 826 insertions(+), 699 deletions(-)
Approvals:
Shirly Radco: Verified; Looks good to me, but someone else must approve
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/25089
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iefb7be12b92a0f5e1df8eb2cf0179236ca7398b3
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 8 months
Change in ovirt-engine[master]: core: make migrate commands non-transactive
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: make migrate commands non-transactive
......................................................................
core: make migrate commands non-transactive
Patch 94e48a02 removed the global transaction during RunVmCommand.
Global transactions should also be removed from the migrate commands
for the same reasons and because it prevents us from migrating multiple
VMs from different hosts to the same host while one of the migrations
is in its execute phase or start a VM on a host while another VM is
migrating to that host and the migration is in its execute phase.
Change-Id: I4894ebd5f062174f9780926a0ce6b499fcc0fc7b
Bug-Url: https://bugzilla.redhat.com/1064931
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/InternalMigrateVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmToServerCommand.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/MigrateVDSCommand.java
4 files changed, 25 insertions(+), 23 deletions(-)
Approvals:
Roy Golan: Looks good to me, approved
Arik Hadas: Verified
--
To view, visit http://gerrit.ovirt.org/24799
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4894ebd5f062174f9780926a0ce6b499fcc0fc7b
Gerrit-PatchSet: 19
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Michal Skrivanek <michal.skrivanek(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-engine[master]: webadmin: Fixed message when adding Posix domain when not su...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Fixed message when adding Posix domain when not supported
......................................................................
webadmin: Fixed message when adding Posix domain when not supported
The message when adding a Posix domain when it's not supported on the
cluster was broken and lacking the action type and entity type
Change-Id: I237e40dd325c7b36c4413eab48e3aed41c090c4f
Bug-Url: https://bugzilla.redhat.com/1074254
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/AddStorageDomainCommand.java
1 file changed, 5 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved
Maor Lipchuk: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26010
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I237e40dd325c7b36c4413eab48e3aed41c090c4f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-engine[master]: core: Correct error message
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Correct error message
......................................................................
core: Correct error message
The error message ACTION_NOT_SUPPORTED_FOR_CLUSTER_POOL_LEVEL lacked the
type parameter which resulted in message like "The Action add is not
supported" instead of "add Disk" for instance.
Change-Id: I5517297e0de3350f3d62ab67cb908b4525e306d8
Related-To: https://bugzilla.redhat.com/1074254
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
4 files changed, 4 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26009
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5517297e0de3350f3d62ab67cb908b4525e306d8
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-engine[master]: core: set vm exit status to error on fencing
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: set vm exit status to error on fencing
......................................................................
core: set vm exit status to error on fencing
As part of fence operation, we set the VM status to down using
SetVmStatusVDSCommand. This command did not filled the exit status of
the VM which should be ERROR in this case. So this patch adds that
missing part by passing the exit status that should be set for the VM
while changing its status through the parameters of the command.
Change-Id: If541c6d33a7cfa310ba776e4bc7fa0f1e45aa077
Bug-Url: https://bugzilla.redhat.com/1077706
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/FenceVdsBaseCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/vdscommands/SetVmStatusVDSCommandParameters.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/ResourceManager.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/SetVmStatusVDSCommand.java
4 files changed, 35 insertions(+), 17 deletions(-)
Approvals:
Eli Mesika: Looks good to me, but someone else must approve
Omer Frenkel: Looks good to me, approved
Arik Hadas: Verified
--
To view, visit http://gerrit.ovirt.org/26101
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If541c6d33a7cfa310ba776e4bc7fa0f1e45aa077
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-dwh[master]: packaging: added release notes
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: packaging: added release notes
......................................................................
packaging: added release notes
Change-Id: I1923db622e847b5df8f4810d33ebf6308fc5c79f
Signed-off-by: Yaniv Dary <ydary(a)redhat.com>
---
M ovirt-engine-dwh.spec.in
1 file changed, 5 insertions(+), 0 deletions(-)
Approvals:
Yaniv Dary: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26218
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1923db622e847b5df8f4810d33ebf6308fc5c79f
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-dwh
Gerrit-Branch: master
Gerrit-Owner: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 8 months