Change in ovirt-engine[master]: core: domain might remain locked on deactivation
by laravot@redhat.com
Liron Aravot has submitted this change and it was merged.
Change subject: core: domain might remain locked on deactivation
......................................................................
core: domain might remain locked on deactivation
When passing the compensation context to the child command the
'recorded' changes aren't reverted becasue when attempting to load the
compensation data the load is by the command id which is different
between the parent command and the child command.
When no tasks are created when deactivating domain and the actual
deactivation fails, the domain remained locked because of the above
reason.
Change-Id: I4a1bea6522ceb8c83be9466ed50748559745c3c8
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1184927
Signed-off-by: Liron Aravot <laravot(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/DeactivateStorageDomainWithOvfUpdateCommand.java
1 file changed, 2 insertions(+), 3 deletions(-)
Approvals:
Allon Mureinik: Looks good to me, approved
Liron Aravot: Verified
--
To view, visit http://gerrit.ovirt.org/37201
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4a1bea6522ceb8c83be9466ed50748559745c3c8
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[ovirt-engine-3.5]: core: Fine-tune Storage space alerts policy
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Fine-tune Storage space alerts policy
......................................................................
core: Fine-tune Storage space alerts policy
Alerts were sent if the available space in GB (Integer) or percentage
were less or equal to the set thresholds. This patch changes it so
alerts would only be sent if the value is actually less than the
threshold.
Change-Id: Ic061ffc3e052a38fd9c923ffcc66eb1748ed60cf
Bug-Url: https://bugzilla.redhat.com/1184807
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/IrsProxyData.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Looks good to me, approved
Vered Volansky: Verified
--
To view, visit http://gerrit.ovirt.org/37219
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic061ffc3e052a38fd9c923ffcc66eb1748ed60cf
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[master]: core: Remove redundant threshold call
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Remove redundant threshold call
......................................................................
core: Remove redundant threshold call
While adding storage domains to a map in
ImagesHandler.fillImagesMapBasedOnTemplate(), there's a threshold check.
This check is redundant and buggy here.
Redundant because there are storage allocation checks in the system
now, which should be called in due time.
Buggy, since in case the threshold has been met, the threshold
validation fails, but with no error at the time of failure.
The map is not filled correctly, and we get another, unrelated error.
This patch removes the threshold validation and relies on it being
called when it should.
Change-Id: Ifb4357a19bc51ae5feb3c8e79ff36f3adacc327f
Bug-Url: https://bugzilla.redhat.com/tbd
Related-To: https://bugzilla.redhat.com/1179690
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommonVmPoolWithVmsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImagesHandler.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MoveOrCopyTemplateCommand.java
4 files changed, 7 insertions(+), 9 deletions(-)
Approvals:
Allon Mureinik: Looks good to me, approved
Vered Volansky: Verified
--
To view, visit http://gerrit.ovirt.org/37213
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifb4357a19bc51ae5feb3c8e79ff36f3adacc327f
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Candace Sheremeta <cshereme(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[master]: core: Fix Wrong Access Modifier
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Fix Wrong Access Modifier
......................................................................
core: Fix Wrong Access Modifier
The method getExtraConfigDescriptors should have a protected access
modifier rather than public.
Change-Id: I08886d1dff24a1732e7614c6bdae616a4add123c
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AbstractQueryTest.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Allon Mureinik: Looks good to me, approved
Idan Shaby: Verified
--
To view, visit http://gerrit.ovirt.org/37208
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I08886d1dff24a1732e7614c6bdae616a4add123c
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[ovirt-engine-3.5]: core: Support search disk by name
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Support search disk by name
......................................................................
core: Support search disk by name
Currently we only support searching disk by "alias", not by "name". But
name is used in many places as an alias for "alias", so it makes sense
to allow it as well in search queries.
Change-Id: I09f910f017945ceb5099cb724fb2e6432769a11c
Bug-Url: https://bugzilla.redhat.com/1173196
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
(cherry picked from commit 6a6a6fc7104c0a8a6483ace21957f25067f3061e)
---
M backend/manager/modules/searchbackend/src/main/java/org/ovirt/engine/core/searchbackend/DiskConditionFieldAutoCompleter.java
1 file changed, 4 insertions(+), 0 deletions(-)
Approvals:
Juan Hernandez: Verified
Allon Mureinik: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37152
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I09f910f017945ceb5099cb724fb2e6432769a11c
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[master]: core: Fine-tune Storage space alerts policy
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Fine-tune Storage space alerts policy
......................................................................
core: Fine-tune Storage space alerts policy
Alerts were sent if the available space in GB (Integer) or percentage
were less or equal to the set thresholds. This patch changes it so
alerts would only be sent if the value is actually less than the
threshold.
Change-Id: Ic061ffc3e052a38fd9c923ffcc66eb1748ed60cf
Bug-Url: https://bugzilla.redhat.com/1178480
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/IrsProxyData.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Vered Volansky: Verified
--
To view, visit http://gerrit.ovirt.org/36557
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic061ffc3e052a38fd9c923ffcc66eb1748ed60cf
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[ovirt-engine-3.5]: Due to commit a276f142 foreman id is not provided in vds sta...
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: Due to commit a276f142 foreman id is not provided in vds static table
......................................................................
Due to commit a276f142 foreman id is not provided in vds static table
By Changing the order of adding vdsStatic db we miss the update of
setHostProviderId. This patch removes the duplication and use directly
vdsStatic to update provider id.
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1113003
Change-Id: I163311d3c3e7edc89a0ca77a94eed688528ad192
Signed-off-by: Yaniv Bronhaim <ybronhei(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVdsCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/AddVdsActionParameters.java
2 files changed, 2 insertions(+), 5 deletions(-)
Approvals:
Yaniv Bronhaim: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37113
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I163311d3c3e7edc89a0ca77a94eed688528ad192
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Yaniv Bronhaim <ybronhei(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Yaniv Bronhaim <ybronhei(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[master]: webadmin: Migration options too small
by tjelinek@redhat.com
Tomas Jelinek has submitted this change and it was merged.
Change subject: webadmin: Migration options too small
......................................................................
webadmin: Migration options too small
New/edit VM -> Host -> migration options: cut.
Fixed by making the list box a bit bigger
The methods setContentWrapperStypeName and setContentWidgetContainerStyle are
called "set" and not "add" to be exposed to ui.xml
Change-Id: I2ec2add329cbbe611c07f4eda2f70bacc8a9f3fc
Bug-Url: https://bugzilla.redhat.com/1166046
Signed-off-by: Tomas Jelinek <tjelinek(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/Align.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/editor/generic/EntityModelDetachableWidget.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/AbstractVmPopupWidget.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/AbstractVmPopupWidget.ui.xml
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/pool/PoolEditPopupWidget.java
5 files changed, 54 insertions(+), 11 deletions(-)
Approvals:
Tomas Jelinek: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37048
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2ec2add329cbbe611c07f4eda2f70bacc8a9f3fc
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[ovirt-engine-3.5]: webadmin: Determine whether to fetch ISO domain images list ...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Determine whether to fetch ISO domain images list correctly
......................................................................
webadmin: Determine whether to fetch ISO domain images list correctly
Change-Id: I6cb6201209227e0968b600817dfc1e40ed327cbf
Bug-Url: https://bugzilla.redhat.com/1184535
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageIsoListModel.java
1 file changed, 4 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Verified
Allon Mureinik: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37198
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6cb6201209227e0968b600817dfc1e40ed327cbf
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 2 months
Change in ovirt-engine[master]: webadmin: Determine whether to fetch ISO domain images list ...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Determine whether to fetch ISO domain images list correctly
......................................................................
webadmin: Determine whether to fetch ISO domain images list correctly
Change-Id: I6cb6201209227e0968b600817dfc1e40ed327cbf
Bug-Url: https://bugzilla.redhat.com/1184535
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageIsoListModel.java
1 file changed, 4 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Verified
Allon Mureinik: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/37196
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6cb6201209227e0968b600817dfc1e40ed327cbf
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 2 months