Change in ovirt-engine[master]: core: RestoreCinderSnapshot should delete volumes by order.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: RestoreCinderSnapshot should delete volumes by order.
......................................................................
core: RestoreCinderSnapshot should delete volumes by order.
Re-implement restore Cinder snapshot to delete a Cinder volume and all
its descendants from the DB by calling RemoveCinderDiskVolume for each
volume by order.
The order is important for since Cinder can only remove volume after all
its snapshots get deleted first.
Change-Id: Ife6ac08ca86a4cb2b30174e3de6422d9db5cbb65
Bug-Url: https://bugzilla.redhat.com/1256048
Bug-Url: https://bugzilla.redhat.com/1256049
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/cinder/RestoreFromCinderSnapshotCommand.java
D backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/cinder/RestoreFromCinderSnapshotCommandCallback.java
2 files changed, 41 insertions(+), 214 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/49419
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ife6ac08ca86a4cb2b30174e3de6422d9db5cbb65
Gerrit-PatchSet: 10
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: before unlock a VM, fetch it from the DB
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: before unlock a VM, fetch it from the DB
......................................................................
core: before unlock a VM, fetch it from the DB
The VM which is used to be unlocked is the VM from the meory, so the VM
might be with DOWN status although it was locked on the proccess.
Since CoCo handle the class in the memory (unlike the Async Task
functionality), after commiting/undo a previewed Cinder snapshot, the VM
from the memory is being unlocked but since the status of the memory of
the VM is DOWN, the engine doesn't unlock it.
The proposed fix is to make the VM property to be null in order to refresh
the VM status from db.
Bug-Url: https://bugzilla.redhat.com/1256048
Bug-Url: https://bugzilla.redhat.com/1256049
Change-Id: I7edd4e8b23277c57939bd5e965eb4da29e3600d3
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VmCommand.java
1 file changed, 2 insertions(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/49418
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7edd4e8b23277c57939bd5e965eb4da29e3600d3
Gerrit-PatchSet: 10
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: RemoveVdsCommand methods naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: RemoveVdsCommand methods naming conventions
......................................................................
core: RemoveVdsCommand methods naming conventions
Fixed naming conventions of the RemoveVdsCommand class' methods
as per the recommended Java naming conventions.
Change-Id: Ib74b8ee99417dbfedaf5cddac5e7bc95aa7c2aac
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveVdsCommand.java
1 file changed, 8 insertions(+), 8 deletions(-)
Approvals:
Ravi Nori: Looks good to me, but someone else must approve
Allon Mureinik: Verified; Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49888
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib74b8ee99417dbfedaf5cddac5e7bc95aa7c2aac
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: IntegerCompatTest method naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: IntegerCompatTest method naming conventions
......................................................................
core: IntegerCompatTest method naming conventions
Renamed IntegerCompatTest.TryParse to tryParse so it both follows the
name of the method it tests and the proper Java naming conventions.
Change-Id: Id2534833419222266dc0e4aa321b3d6c97a4ce12
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/compat/src/test/java/org/ovirt/engine/core/compat/IntegerCompatTest.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Oved Ourfali: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49831
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id2534833419222266dc0e4aa321b3d6c97a4ce12
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: HostValidatorTest methods naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: HostValidatorTest methods naming conventions
......................................................................
core: HostValidatorTest methods naming conventions
Fixed naming conventions of the HostValidatorTest class' methods
as per the recommended Java naming conventions.
Change-Id: Ib0a8380a1b46ef4869588a82c56ada5429e0ccf3
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/validator/HostValidatorTest.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49902
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib0a8380a1b46ef4869588a82c56ada5429e0ccf3
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: Async tasks methods naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Async tasks methods naming conventions
......................................................................
core: Async tasks methods naming conventions
Fixed naming conventions of the async tasks handling classes' methods
as per the recommended Java naming conventions.
Change-Id: Ic9b5de60fc64c03d1cbabf1da95e2693545dd445
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommandMultiAsyncTasks.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/tasks/CommandAsyncTask.java
2 files changed, 13 insertions(+), 13 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Ravi Nori: Looks good to me, but someone else must approve
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/49887
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic9b5de60fc64c03d1cbabf1da95e2693545dd445
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: AlertDirector methods naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AlertDirector methods naming conventions
......................................................................
core: AlertDirector methods naming conventions
Fixed naming conventions of the AlertDirector class' methods
as per the recommended Java naming conventions.
Change-Id: I45c235e1b0fd42a6cb5053f34d24a1b41411730c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddExternalEventCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/FenceQueryBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/InitVdsOnUpCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSyncJob.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/pm/PmHealthCheckManager.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/scheduling/SchedulingManager.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/FenceVdsManualyCommand.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AlertDirector.java
9 files changed, 24 insertions(+), 24 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/49864
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I45c235e1b0fd42a6cb5053f34d24a1b41411730c
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: Regex methods naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Regex methods naming conventions
......................................................................
core: Regex methods naming conventions
Fixed naming conventions of the Regex class' methods as per the
recommended Java naming conventions.
Change-Id: If2dabe57deeef2565ce18ab76b7adb91c11942ef
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/hostdeploy/RegisterVdsQuery.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/FenceValidator.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/TimeZoneType.java
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/utils/I18NRegexpTest.java
M backend/manager/modules/compat/src/main/java/org/ovirt/engine/core/compat/Regex.java
M backend/manager/modules/compat/src/test/java/org/ovirt/engine/core/compat/RegexTest.java
M backend/manager/modules/searchbackend/src/main/java/org/ovirt/engine/core/searchbackend/ADSyntaxChecker.java
M backend/manager/modules/searchbackend/src/main/java/org/ovirt/engine/core/searchbackend/BaseConditionFieldAutoCompleter.java
M backend/manager/modules/searchbackend/src/main/java/org/ovirt/engine/core/searchbackend/SyntaxChecker.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ovf/OvfVmWriter.java
M frontend/webadmin/modules/gwt-extension/src/main/java/org/ovirt/engine/ui/uioverrides/org/ovirt/engine/core/compat/Regex.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/validation/RegexValidation.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/MailAddress.java
13 files changed, 47 insertions(+), 47 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Vojtech Szocs: Looks good to me, but someone else must approve
Oved Ourfali: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49830
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If2dabe57deeef2565ce18ab76b7adb91c11942ef
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: MaintenanceNumberOfVdssCommand methods naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: MaintenanceNumberOfVdssCommand methods naming conventions
......................................................................
core: MaintenanceNumberOfVdssCommand methods naming conventions
Fixed naming conventions of the MaintenanceNumberOfVdssCommand class'
methods as per the recommended Java naming conventions.
Change-Id: Ie77d0a225b50d502b4742a444794134605cc781e
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MaintenanceNumberOfVdssCommand.java
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/49886
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie77d0a225b50d502b4742a444794134605cc781e
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: SSH methods naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: SSH methods naming conventions
......................................................................
core: SSH methods naming conventions
Fixed naming conventions of the SSH-related classes' methods as per
the recommended Java naming conventions.
Change-Id: Ic9390c7bd1400bc65c0e4b4eacaa5a06fd674ccb
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/utils/EngineSSHDialog.java
M backend/manager/modules/uutils/src/main/java/org/ovirt/engine/core/uutils/ssh/SSHClient.java
M backend/manager/modules/uutils/src/main/java/org/ovirt/engine/core/uutils/ssh/SSHDialog.java
M backend/manager/modules/uutils/src/test/java/org/ovirt/engine/core/uutils/ssh/SSHDialogTest.java
M backend/manager/modules/uutils/src/test/java/org/ovirt/engine/core/uutils/ssh/TimeoutTest.java
5 files changed, 15 insertions(+), 15 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Martin Peřina: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Oved Ourfali: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49829
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic9390c7bd1400bc65c0e4b4eacaa5a06fd674ccb
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months