Change in ovirt-engine[ovirt-engine-3.6]: engine: Storage validation in LSM flow
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: engine: Storage validation in LSM flow
......................................................................
engine: Storage validation in LSM flow
The patch I9f42f387781425d16f53a0e8a34d859365808ec0 introduced a change
that the disks validated in CreateAllSnapshotsFromVmCommand are all
the snappable disks.
This patch is reverting the mentioned above.
We need to check only the disks that the user selected.
LSM flow uses also CreateAllSnapshotsFromVmCommand.
In this case, the disks are already validated in the LSM command,
no need to check them again.
Change-Id: I0bb0aa45f54824ed93e299827c3f38c0905bb3cd
Bug-Url: https://bugzilla.redhat.com/1282957
Bug-Url: https://bugzilla.redhat.com/1287025
Signed-off-by: Fred Rolland <frolland(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CreateAllSnapshotsFromVmCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/CreateAllSnapshotsFromVmCommandTest.java
2 files changed, 12 insertions(+), 17 deletions(-)
Approvals:
Tal Nisan: Passed CI tests
Allon Mureinik: Looks good to me, approved
Freddy Rolland: Verified
--
To view, visit https://gerrit.ovirt.org/49953
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0bb0aa45f54824ed93e299827c3f38c0905bb3cd
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[ovirt-engine-3.6]: core: Use execution context when calling parent command.
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Use execution context when calling parent command.
......................................................................
core: Use execution context when calling parent command.
Avoid overriding execution context when calling end command at Create
Cinder snapshot command.
Change-Id: I4847e85d6a67bf1304d741f984c83f231e0fd6fd
Bug-Url: https://bugzilla.redhat.com/1270725
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CreateAllSnapshotsFromVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/CreateCinderSnapshotCommand.java
2 files changed, 3 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Passed CI tests
Daniel Erez: Looks good to me, approved
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/49950
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4847e85d6a67bf1304d741f984c83f231e0fd6fd
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[ovirt-engine-3.6]: core: Update executionContext with Steps.
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Update executionContext with Steps.
......................................................................
core: Update executionContext with Steps.
When executing a command through the CommandExecutor as part of an
execution flow, the steps in the executionContext should be initialized as well.
At this particular bug a stateless VM is being powering up and a step indicating
the snapshot is being created is initialized in the context and should be passed to the
child command CreateCinderSnapshotCommand.
The proposed fix adds the initialization for steps and jobs to the
executionContext when calling createDefaultContextForTasksImpl
Change-Id: I4ee874e3da01504115e1fa2fd2e66de51d441a9d
Bug-Url: https://bugzilla.redhat.com/1270725
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/job/ExecutionHandler.java
1 file changed, 3 insertions(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Maor Lipchuk: Verified
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49949
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4ee874e3da01504115e1fa2fd2e66de51d441a9d
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[ovirt-engine-3.6]: engine: WebSocketProxy set to be reloadable
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: engine: WebSocketProxy set to be reloadable
......................................................................
engine: WebSocketProxy set to be reloadable
The 'WebSocketProxy' configuration value (vdc_options, ConfigValues)
is set to be reloadable - the engine does not need to be
restarted to take effect of a change.
Steps needed to reload the configuration on-the-fly can be found
in the bug description.
Change-Id: I62a6f37037fff61adb902428b163814abd9e7f43
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1124851
Signed-off-by: Marek Libra <mlibra(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/config/ConfigValues.java
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Marek Libra: Verified
Arik Hadas: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49552
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I62a6f37037fff61adb902428b163814abd9e7f43
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Marek Libra <mlibra(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Marek Libra <mlibra(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: checkstyle: Type names
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: checkstyle: Type names
......................................................................
checkstyle: Type names
Add a checkstyle check to ensure type names in the project follow Java's
naming conventions.
Change-Id: Id88d614ac5d929a18bc7003890c7c779036cd142
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M build-tools-root/checkstyles/src/main/resources/checkstyle-suppressions.xml
M build-tools-root/checkstyles/src/main/resources/checkstyle.xml
2 files changed, 2 insertions(+), 0 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49828
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id88d614ac5d929a18bc7003890c7c779036cd142
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: Rename SETUP_NETWORKS_RESOLUTION
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Rename SETUP_NETWORKS_RESOLUTION
......................................................................
core: Rename SETUP_NETWORKS_RESOLUTION
Renamed SETUP_NETWORKS_RESOLUTION to SetupNetworksResolution, as per
the recommended Java naming conventions.
Change-Id: I2f109fced77908bfe5c46dc22ac694ac44e1ccad
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/host/SetupNetworksCommand.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49827
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2f109fced77908bfe5c46dc22ac694ac44e1ccad
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: Rename VNIC_PROFILE_PROPERTIES
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Rename VNIC_PROFILE_PROPERTIES
......................................................................
core: Rename VNIC_PROFILE_PROPERTIES
Renamed VNIC_PROFILE_PROPERTIES to VnicProfileProperties, as per the
recommended Java naming conventions.
Change-Id: I7c48b495ba004d90a5188276682ef0e6e9564dc4
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VmInfoBuilder.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VmInfoBuilderBase.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VmOldInfoBuilder.java
3 files changed, 11 insertions(+), 11 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49826
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7c48b495ba004d90a5188276682ef0e6e9564dc4
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: SysprepHandler methods naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: SysprepHandler methods naming conventions
......................................................................
core: SysprepHandler methods naming conventions
Fixed naming conventions of the SysprepHandler class and its test's
methods as per the recommended Java naming conventions.
Change-Id: I5b35e1b2d7e7f1dd9c25fc47160b541a17aebcbc
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/SysprepHandler.java
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/vdsbroker/SysprepHandlerTest.java
2 files changed, 9 insertions(+), 9 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/49877
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5b35e1b2d7e7f1dd9c25fc47160b541a17aebcbc
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: OvfVmReader methods naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: OvfVmReader methods naming conventions
......................................................................
core: OvfVmReader methods naming conventions
Fixed naming conventions of the OvfVmReader class' methods
as per the recommended Java naming conventions.
Change-Id: I5d402502989e81dd98b1f77ab5c1203ef1ffc9ee
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ovf/OvfVmReader.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Arik Hadas: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49859
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5d402502989e81dd98b1f77ab5c1203ef1ffc9ee
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: BootSequenceTest methods naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: BootSequenceTest methods naming conventions
......................................................................
core: BootSequenceTest methods naming conventions
Fixed naming conventions of the BootSequenceTest class' methods as per
the recommended Java naming conventions.
Change-Id: I57dd9124ff03b655eb1124be3fb29e67a62ce7b2
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/common/src/test/java/org/ovirt/engine/core/common/businessentities/BootSequenceTest.java
1 file changed, 11 insertions(+), 11 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Arik Hadas: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49853
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I57dd9124ff03b655eb1124be3fb29e67a62ce7b2
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months