Change in ovirt-engine[master]: engine: Event classes naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: engine: Event classes naming conventions
......................................................................
engine: Event classes naming conventions
Fixed the naming conventions of the event_subscriber,
event_subscriber_id and event_notification_hist classes, local
variables and methods to comply with Java conventions.
Change-Id: Ib98de89b8edfa5a7745f9189e6361cbe89df7774
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddEventSubscriptionCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/EventSubscriptionCommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetEventSubscribersBySubscriberIdGroupedQuery.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveEventSubscriptionCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/EventSubscriptionParametesBase.java
R backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/EventNotificationHist.java
A backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/EventSubscriber.java
R backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/EventSubscriberId.java
D backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/event_subscriber.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/EventDao.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/EventDaoImpl.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/EventDaoTest.java
M frontend/webadmin/modules/gwt-common/src/main/resources/org/ovirt/engine/core/Common.gwt.xml
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/users/UserEventNotifierListModel.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/gin/ClientGinjectorExtension.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/gin/uicommon/UserModule.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/presenter/tab/user/SubTabUserEventNotifierPresenter.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/tab/user/SubTabUserEventNotifierView.java
18 files changed, 283 insertions(+), 286 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/49825
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib98de89b8edfa5a7745f9189e6361cbe89df7774
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: engine: Storage validation in LSM flow
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: engine: Storage validation in LSM flow
......................................................................
engine: Storage validation in LSM flow
The patch I9f42f387781425d16f53a0e8a34d859365808ec0 introduced a change
that the disks validated in CreateAllSnapshotsFromVmCommand are all
the snappable disks.
This patch is reverting the mentioned above.
We need to check only the disks that the user selected.
LSM flow uses also CreateAllSnapshotsFromVmCommand.
In this case, the disks are already validated in the LSM command,
no need to check them again.
Change-Id: I0bb0aa45f54824ed93e299827c3f38c0905bb3cd
Bug-Url: https://bugzilla.redhat.com/1282957
Bug-Url: https://bugzilla.redhat.com/1287025
Signed-off-by: Fred Rolland <frolland(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/CreateAllSnapshotsFromVmCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/snapshots/CreateAllSnapshotsFromVmCommandTest.java
2 files changed, 12 insertions(+), 17 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved; Passed CI tests
Freddy Rolland: Verified
--
To view, visit https://gerrit.ovirt.org/49446
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0bb0aa45f54824ed93e299827c3f38c0905bb3cd
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Fred Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: Unbreak DAO tests
by rgolan@redhat.com
Roy Golan has submitted this change and it was merged.
Change subject: core: Unbreak DAO tests
......................................................................
core: Unbreak DAO tests
Commit b3eacdb46f2b9c65ca184c9352b39f766d0c936b introduced Java 8
bytecode to the Ovf*Reader classes. While these classes are not used by
any way, shape or form by the DAOs, they are part of the utils project,
which the dao project depends on. Thus, when the DAO tests scan for
beans, they encounter this class, and fail since Spring 3 we are using
cannot handle Java 8 bytecode.
This patch fixes the tests by moving the CdiIntegration test class to a
sensible place (org.ovirt.engine.core.dal), and reducing the scope beans
are searched for to org.ovirt.engine.core.dal and
org.ovirt.engine.core.dao.
As a side bonus, this patch offers a slight performance boost to the
tests, as they no longer need to scan the entire org.ovirt.engine.core
huge package.
Change-Id: I8c7a749d5c37f4dcbfd95cea1e01a93520d2ce87
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
R backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dal/CdiIntegration.java
M backend/manager/modules/dal/src/test/resources/test-beans.xml
2 files changed, 3 insertions(+), 2 deletions(-)
Approvals:
Allon Mureinik: Verified
Roy Golan: Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/49948
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8c7a749d5c37f4dcbfd95cea1e01a93520d2ce87
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: Use execution context when calling parent command.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Use execution context when calling parent command.
......................................................................
core: Use execution context when calling parent command.
Avoid overriding execution context when calling end command at Create
Cinder snapshot command.
Change-Id: I4847e85d6a67bf1304d741f984c83f231e0fd6fd
Bug-Url: https://bugzilla.redhat.com/1270725
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/CreateAllSnapshotsFromVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/CreateCinderSnapshotCommand.java
2 files changed, 3 insertions(+), 3 deletions(-)
Approvals:
Daniel Erez: Looks good to me, approved
Maor Lipchuk: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/49680
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4847e85d6a67bf1304d741f984c83f231e0fd6fd
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[ovirt-engine-3.6]: Revert "webadmin: adding custom bond validation to hostSetup...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: Revert "webadmin: adding custom bond validation to hostSetupNetwork"
......................................................................
Revert "webadmin: adding custom bond validation to hostSetupNetwork"
A part of a sequence of patches needed to be merged in certain way.
This reverts commit 32754d0e1f15fac67b3f876a95da781ebba6c34e.
Change-Id: I537a4e916062f6b0421791d03edbfb8851b70c5b
Signed-off-by: Eliraz Levi <elevi(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/dataprovider/AsyncDataProvider.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostBondInterfaceModel.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/host/HostBondPopupView.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/host/HostBondPopupView.ui.xml
4 files changed, 24 insertions(+), 39 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/49943
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I537a4e916062f6b0421791d03edbfb8851b70c5b
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Eliraz Levi <elevi(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
8 years, 11 months
Change in ovirt-engine[master]: core: create UpdateVmDiskCommand.setVolumeDescription
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: create UpdateVmDiskCommand.setVolumeDescription
......................................................................
core: create UpdateVmDiskCommand.setVolumeDescription
This patch creates the method setVolumeDescription in order to make it
easier to test the command, and fixes the test.
Change-Id: I52a0ea91e34190b2ef23fdc95a3e6e5589c73d4e
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmDiskCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/UpdateVmDiskCommandTest.java
2 files changed, 8 insertions(+), 14 deletions(-)
Approvals:
Tal Nisan: Passed CI tests
Allon Mureinik: Looks good to me, approved
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/49610
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I52a0ea91e34190b2ef23fdc95a3e6e5589c73d4e
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: remove unused mock from UpdateVmDiskCommandTest
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: remove unused mock from UpdateVmDiskCommandTest
......................................................................
core: remove unused mock from UpdateVmDiskCommandTest
Change-Id: Ibae12726ccd0a970b30e7a734d7e3ecca8778bdf
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/UpdateVmDiskCommandTest.java
1 file changed, 0 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Passed CI tests
Allon Mureinik: Looks good to me, approved
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/49609
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibae12726ccd0a970b30e7a734d7e3ecca8778bdf
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: remove unused mock from MoveOrCopyDiskCommandTest
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: remove unused mock from MoveOrCopyDiskCommandTest
......................................................................
core: remove unused mock from MoveOrCopyDiskCommandTest
Change-Id: I1001c5d7754201b2bc9b85a43760c7ba810696b4
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/MoveOrCopyDiskCommandTest.java
1 file changed, 0 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Passed CI tests
Allon Mureinik: Looks good to me, approved
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/49608
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1001c5d7754201b2bc9b85a43760c7ba810696b4
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: switch getQuery().getUserID() with getUser().getId()
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: switch getQuery().getUserID() with getUser().getId()
......................................................................
core: switch getQuery().getUserID() with getUser().getId()
Since it's a user query, we can take the user id directrly from the user and
not from the query.
Change-Id: I56ef6242bcd733709cdc50b1b950883f0465929f
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/GetNextAvailableDiskAliasNameByVMIdQueryTest.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Passed CI tests
Allon Mureinik: Looks good to me, approved
Freddy Rolland: Looks good to me, but someone else must approve
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/49483
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I56ef6242bcd733709cdc50b1b950883f0465929f
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: remove call to acquireLockInternal() from CDA
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: remove call to acquireLockInternal() from CDA
......................................................................
core: remove call to acquireLockInternal() from CDA
This patch removes the call to acquireLockInternal() in AddDiskCommand's
CDA and overrides applyLockProperties instead, to use the locking
infrastructure.
Change-Id: Iea13ca55ad8efa14744e843fae46e4b6fb4543f8
Signed-off-by: Idan Shaby <ishaby(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddDiskCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AddDiskCommandTest.java
2 files changed, 6 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved; Passed CI tests
Idan Shaby: Verified
--
To view, visit https://gerrit.ovirt.org/49482
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iea13ca55ad8efa14744e843fae46e4b6fb4543f8
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months