Change in ovirt-engine[master]: core: GetUnregisteredBlockStorageDomainsQueryTest mocking
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetUnregisteredBlockStorageDomainsQueryTest mocking
......................................................................
core: GetUnregisteredBlockStorageDomainsQueryTest mocking
Remove redundant mocking that adds nothing to the test and may actually
cause it to fail under strict mocking.
Change-Id: I26039b40c496646dfabd8cfdaeb48c9cae05e7cf
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/domain/GetUnregisteredBlockStorageDomainsQueryTest.java
1 file changed, 0 insertions(+), 12 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Maor Lipchuk: Looks good to me, approved
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/72130
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I26039b40c496646dfabd8cfdaeb48c9cae05e7cf
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: createNetworkAttachmentWithIpv4Configuration args
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: createNetworkAttachmentWithIpv4Configuration args
......................................................................
core: createNetworkAttachmentWithIpv4Configuration args
The netmask and address passed to
createNetworkAttachmentWithIpv4Configuration are always null. This patch
inlines these arguments to clean up the code and make it easier to read.
Change-Id: Idbc50dfc8ec23275ed56bb434d7ce49e87edfdcd
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/validator/NetworkAttachmentValidatorTest.java
1 file changed, 6 insertions(+), 11 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Martin Mucha: Looks good to me, but someone else must approve
Allon Mureinik: Verified; Passed CI tests
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/72129
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idbc50dfc8ec23275ed56bb434d7ce49e87edfdcd
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: GetGlusterGeoReplicationEligibleVolumesQueryTest mocking
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetGlusterGeoReplicationEligibleVolumesQueryTest mocking
......................................................................
core: GetGlusterGeoReplicationEligibleVolumesQueryTest mocking
Remove redundant mocking that adds nothing to the test and may actually
cause it to fail under strict mocking.
Change-Id: Ia2b737d5afccd197012524ad396de8fcf2cb6f6f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetGlusterGeoReplicationEligibleVolumesQueryTest.java
1 file changed, 0 insertions(+), 25 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/72131
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia2b737d5afccd197012524ad396de8fcf2cb6f6f
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: Unused NetworkAttachmentValidatorTest members
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Unused NetworkAttachmentValidatorTest members
......................................................................
core: Unused NetworkAttachmentValidatorTest members
Change-Id: I847e30922d3d41243e377a53393344753814a602
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/validator/NetworkAttachmentValidatorTest.java
1 file changed, 0 insertions(+), 26 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Martin Mucha: Looks good to me, but someone else must approve
Allon Mureinik: Verified; Passed CI tests
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/72128
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I847e30922d3d41243e377a53393344753814a602
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: GetGlusterVolumeProfileInfoQueryTest mocking
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetGlusterVolumeProfileInfoQueryTest mocking
......................................................................
core: GetGlusterVolumeProfileInfoQueryTest mocking
Removed redundant mocking.
Change-Id: I631b8ed2fbbab9dba4651452e97293f6285f88ed
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetGlusterVolumeProfileInfoQueryTest.java
1 file changed, 0 insertions(+), 10 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/72124
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I631b8ed2fbbab9dba4651452e97293f6285f88ed
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: NetworkAttachmentValidatorTest mocking
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: NetworkAttachmentValidatorTest mocking
......................................................................
core: NetworkAttachmentValidatorTest mocking
Remove redundant mocking that adds nothing to the test and may actually
cause it to fail under strict mocking.
Change-Id: I1af5ef47a8c06410d8866ecdb0a9913b26519b76
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/validator/NetworkAttachmentValidatorTest.java
1 file changed, 0 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Martin Mucha: Looks good to me, but someone else must approve
Allon Mureinik: Verified; Passed CI tests
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/72127
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1af5ef47a8c06410d8866ecdb0a9913b26519b76
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: ImportHostedEngineStorageDomainCommandTest mocking
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportHostedEngineStorageDomainCommandTest mocking
......................................................................
core: ImportHostedEngineStorageDomainCommandTest mocking
Remove redundant mocking that adds nothing to the test and may actually
cause it to fail under strict mocking.
Change-Id: I5c46608f4bc0d104230ff339e9b7248983a442c0
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/domain/ImportHostedEngineStorageDomainCommandTest.java
1 file changed, 0 insertions(+), 9 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/72126
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5c46608f4bc0d104230ff339e9b7248983a442c0
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: GetUnregisteredDisksQueryTest mocking
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetUnregisteredDisksQueryTest mocking
......................................................................
core: GetUnregisteredDisksQueryTest mocking
Remove redundant mocking that adds nothing to the test and may actually
cause it to fail under strict mocking.
Change-Id: I0237ad5f9e1a84d378475484964ee9c95985161f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/disk/image/GetUnregisteredDisksQueryTest.java
1 file changed, 0 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Maor Lipchuk: Looks good to me, approved
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/72125
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0237ad5f9e1a84d378475484964ee9c95985161f
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: testExecuteQueryWithNotExistingIscsiBond mocking
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: testExecuteQueryWithNotExistingIscsiBond mocking
......................................................................
core: testExecuteQueryWithNotExistingIscsiBond mocking
This test is supposed to test the scenario where the requested bond
does not existing in the database.
Mocking the fact that some random other bond does exist in the database
is pointless, and actually fails the test under strict mocking.
Change-Id: I3d6889c345d5e4c3b16b14158e9c4fdebb78cb56
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/connection/iscsibond/GetIscsiBondByIdQueryTest.java
1 file changed, 0 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/72123
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3d6889c345d5e4c3b16b14158e9c4fdebb78cb56
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: AddCpuProfileCommandTest @InjectMocks
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AddCpuProfileCommandTest @InjectMocks
......................................................................
core: AddCpuProfileCommandTest @InjectMocks
Use @InjectMocks to inject the tests dependencies instead of the
convoluted boilerplate practice of using doReturn.
Note that the mocked DAO was changed from ProfilesDao<CpuProfile> to
CpuProfileDao so that the injection mechanism would pick up on it.
Change-Id: I16a0a261df0ddfed0debd3edaf2711c17e02b0af
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/profiles/AddCpuProfileCommandTest.java
1 file changed, 13 insertions(+), 47 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/72122
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I16a0a261df0ddfed0debd3edaf2711c17e02b0af
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months