Change in ovirt-engine[master]: core: ImagesHandler#prepareSnapshotConfigWithAlternateImage(...
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImagesHandler#prepareSnapshotConfigWithAlternateImage(Snapshot, Guid, DiskImage)
......................................................................
core: ImagesHandler#prepareSnapshotConfigWithAlternateImage(Snapshot, Guid, DiskImage)
Inlined a convenience method that doesn't really add anything to the
code's readability. Moreover, it hides the OvfManager in a fashion it
can't be injected.
This patch exposes the OvfManager so following patches can call the
method with an injected OvfManger.
Change-Id: I10283b720abdee234e9a82e37872853677556b79
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/RemoveSnapshotSingleDiskCommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/ImagesHandler.java
2 files changed, 3 insertions(+), 6 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/71934
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I10283b720abdee234e9a82e37872853677556b79
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: ImagesHandler#prepareSnapshotConfigWithoutImageSingleI...
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImagesHandler#prepareSnapshotConfigWithoutImageSingleImage(Snapshot, Guid, OvfManager)
......................................................................
core: ImagesHandler#prepareSnapshotConfigWithoutImageSingleImage(Snapshot, Guid, OvfManager)
Inline a method that's used only in tests.
Change-Id: I580910a86361086f61ff6c18ca10298fe45b985c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/ImagesHandler.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/disk/image/RemoveImageCommandTest.java
2 files changed, 1 insertion(+), 5 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/71933
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I580910a86361086f61ff6c18ca10298fe45b985c
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: @Inject OvfVmIconDefaultsProvider
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: @Inject OvfVmIconDefaultsProvider
......................................................................
core: @Inject OvfVmIconDefaultsProvider
OvfVmIconDefaultsProvider is a stateless utility which is currently
injected via the old SimpleDependencyInjector. This patch converts it
to a standard java @Singleton, and @Injects it where needed.
The patch includes:
1. Moving OvfVmIconDefaultsProvider to
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/utils/ovf
alongside OvfManager where it's used.
2. Convert OvfVmIconDefaultsProvider to a class annotated with
@Singleton and removed the anonymous implementation from Backend
3. Move the actual logic from GetVmIconDefaultsQuery to
OvfVmIconDefaultsProvider. This way, the utility can be used
wherever needed, and leave the query to just handle the (dummy)
parameters and the return value, instead of having a redundant
roundtrip to call the backend to run the query and then extract the
result.
4. @Inject OvfVmIconDefaultsProvider instead of using the
SimpleDependencyInjector.
5. Fix tests accordingly.
Change-Id: I0ae5d1d73922e2d3e4098edf5d41c6d344270e84
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/Backend.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetVmIconDefaultsQuery.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/utils/ovf/OvfManager.java
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/utils/ovf/OvfVmIconDefaultsProvider.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/disk/image/RemoveImageCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/utils/ovf/OvfManagerTest.java
D backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ovf/OvfVmIconDefaultsProvider.java
7 files changed, 49 insertions(+), 59 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/71939
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0ae5d1d73922e2d3e4098edf5d41c6d344270e84
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[ovirt-engine-4.1]: webadmin: disable unsetting initally assigned network role
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: disable unsetting initally assigned network role
......................................................................
webadmin: disable unsetting initally assigned network role
Make a network role checkbox not editable in manage network dialog
if that was initially set and the flow is Networks->Clusters.
Change-Id: I5983a8240a8f115c11d6ed5ee2d92d50922c934b
Bug-Url: https://bugzilla.redhat.com/1329893
Signed-off-by: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
(cherry picked from commit cd46f7b5767e403a03db155f1ada3ad65138d65a)
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/table/column/AbstractCheckboxColumn.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/ApplicationConstants.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/cluster/ClusterManageNetworkPopupView.java
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/webadmin/ApplicationConstants.properties
4 files changed, 62 insertions(+), 13 deletions(-)
Approvals:
Alona Kaplan: Looks good to me, approved
Jenkins CI: Passed CI tests
Yevgeny Zaspitsky: Verified
--
To view, visit https://gerrit.ovirt.org/72115
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5983a8240a8f115c11d6ed5ee2d92d50922c934b
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: engine: Error message when trying to remove and update same ...
by Code Review
>From Alona Kaplan <alkaplan(a)redhat.com>:
Alona Kaplan has submitted this change and it was merged.
Change subject: engine: Error message when trying to remove and update same bond
......................................................................
engine: Error message when trying to remove and update same bond
Change-Id: I4f583fac4e59c17418bc348513d5ae37cb9700fd
Bug-Url: https://bugzilla.redhat.com/1413377
Signed-off-by: Alona Kaplan <alkaplan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/host/HostSetupNetworksValidator.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/network/host/HostSetupNetworksValidatorTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/EngineMessage.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/frontend/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
8 files changed, 64 insertions(+), 1 deletion(-)
Approvals:
Martin Mucha: Looks good to me, but someone else must approve
Alona Kaplan: Verified; Passed CI tests
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/71956
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4f583fac4e59c17418bc348513d5ae37cb9700fd
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: webadmin: Reuse the id of newly created bond with removed bo...
by Code Review
>From Alona Kaplan <alkaplan(a)redhat.com>:
Alona Kaplan has submitted this change and it was merged.
Change subject: webadmin: Reuse the id of newly created bond with removed bond name
......................................................................
webadmin: Reuse the id of newly created bond with removed bond name
Change-Id: Ideb713af5617e07f5bc63e2b35556e99cf436975
Bug-Url: https://bugzilla.redhat.com/1413377
Signed-off-by: Alona Kaplan <alkaplan(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostSetupNetworksModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/network/DataFromHostSetupNetworksModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/network/NetworkOperation.java
M frontend/webadmin/modules/uicommonweb/src/test/java/org/ovirt/engine/ui/uicommonweb/models/hosts/network/ExecuteNetworkCommandInNetworkOperationTest.java
4 files changed, 67 insertions(+), 10 deletions(-)
Approvals:
Alona Kaplan: Verified; Passed CI tests
Daniel Erez: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/71955
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ideb713af5617e07f5bc63e2b35556e99cf436975
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: core: fix warning logs that use %s
by Code Review
>From Arik Hadas <ahadas(a)redhat.com>:
Arik Hadas has submitted this change and it was merged.
Change subject: core: fix warning logs that use %s
......................................................................
core: fix warning logs that use %s
Apparently Logger#warn does not use String#format in order to construct
warning messages and thus we should not use '%s' (even for strings) but
to use '{}' instead.
Change-Id: Id170b80807a0c3dc0a3669bd38bd9d5d6acf5ed3
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsBrokerObjectsBuilder.java
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/72113
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id170b80807a0c3dc0a3669bd38bd9d5d6acf5ed3
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Milan Zamazal <mzamazal(a)redhat.com>
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-host-deploy[ovirt-host-deploy-1.6]: build: post ovirt-host-deploy-1.6.0
by Code Review
>From Yedidyah Bar David <didi(a)redhat.com>:
Yedidyah Bar David has submitted this change and it was merged.
Change subject: build: post ovirt-host-deploy-1.6.0
......................................................................
build: post ovirt-host-deploy-1.6.0
Change-Id: I46462c839213e34c77541fb809c0811a8e7be32a
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
---
M ChangeLog
M automation/build-artifacts.sh
M configure.ac
3 files changed, 8 insertions(+), 3 deletions(-)
Approvals:
Barak Korren: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Yedidyah Bar David: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/72114
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I46462c839213e34c77541fb809c0811a8e7be32a
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-host-deploy
Gerrit-Branch: ovirt-host-deploy-1.6
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Barak Korren <bkorren(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: webadmin: disable unsetting initally assigned network role
by Code Review
>From Alona Kaplan <alkaplan(a)redhat.com>:
Alona Kaplan has submitted this change and it was merged.
Change subject: webadmin: disable unsetting initally assigned network role
......................................................................
webadmin: disable unsetting initally assigned network role
Make a network role checkbox not editable in manage network dialog
if that was initially set and the flow is Networks->Clusters.
Change-Id: I5983a8240a8f115c11d6ed5ee2d92d50922c934b
Bug-Url: https://bugzilla.redhat.com/1329893
Signed-off-by: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/table/column/AbstractCheckboxColumn.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/ApplicationConstants.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/cluster/ClusterManageNetworkPopupView.java
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/webadmin/ApplicationConstants.properties
4 files changed, 62 insertions(+), 13 deletions(-)
Approvals:
Martin Mucha: Looks good to me, but someone else must approve
Alona Kaplan: Looks good to me, approved
Jenkins CI: Passed CI tests
Yevgeny Zaspitsky: Verified
--
To view, visit https://gerrit.ovirt.org/71817
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5983a8240a8f115c11d6ed5ee2d92d50922c934b
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months
Change in ovirt-engine[master]: packaging: setup: DB configuration plugin
by Code Review
>From Roy Golan <rgolan(a)redhat.com>:
Roy Golan has submitted this change and it was merged.
Change subject: packaging: setup: DB configuration plugin
......................................................................
packaging: setup: DB configuration plugin
Motivation
A setup may fail with misconfigured db properties, but it fails-fast,
and that may send the user into a loop untill all the db values are
configured correctly while instead we can report all the missing
items at once and offer to fix them
Change
Default configuration are decleared by the core setup files and extra
configuration are inside configuration.py
Whenever a configuration item is decleraed as must, the setup will
try to fix ammend postgres.conf and restart postgres
(notice, won't work for dev-env unless combind with sudo).
If the db is a remote db, the user will get a warning with the
misconfigured items and setup will abort
Result
Setup can auto fix mandatory db configurations without asking for manual
intervention.
Change-Id: I99d5a661044a4077589326b8f215fa2152952304
Bug-Url: https://bugzilla.redhat.com/1388433
Signed-off-by: Roy Golan <rgolan(a)redhat.com>
---
M packaging/setup/ovirt_engine_setup/engine/constants.py
M packaging/setup/ovirt_engine_setup/engine_common/constants.py
M packaging/setup/ovirt_engine_setup/engine_common/database.py
M packaging/setup/ovirt_engine_setup/engine_common/dwh_shared_constants.py
M packaging/setup/ovirt_engine_setup/engine_common/postgres.py
M packaging/setup/ovirt_engine_setup/provisiondb/constants.py
M packaging/setup/plugins/ovirt-engine-setup/ovirt-engine/db/__init__.py
A packaging/setup/plugins/ovirt-engine-setup/ovirt-engine/db/configuration.py
8 files changed, 348 insertions(+), 128 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Yedidyah Bar David: Looks good to me, but someone else must approve
Roy Golan: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/70422
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I99d5a661044a4077589326b8f215fa2152952304
Gerrit-PatchSet: 37
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Phillip Bailey <phbailey(a)redhat.com>
Gerrit-Reviewer: Rafael Martins <rmartins(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 9 months