Change in ovirt-engine[master]: webadmin: Format the message to make it readable.
by gchaplik@redhat.com
Gilad Chaplik has submitted this change and it was merged.
Change subject: webadmin: Format the message to make it readable.
......................................................................
webadmin: Format the message to make it readable.
Following message is displayed in one single line making it hard to read -
"Please use your VNC client to connect to this VM.Use the following parameters:IP:Port: machinename:portPassword: passwd(note: this password is valid for 120 seconds)"
This patch reformats it to look like -
"Please use your VNC client to connect to this VM.
Use the following parameters:
IP:Port -- machine:port
Password: passwd
(note: this password is valid for 120 seconds)"
Change-Id: I2e655dc854ec37535cdc1044dc88fd51d74525c3
Signed-off-by: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
---
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/Messages.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Gilad Chaplik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7458
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2e655dc854ec37535cdc1044dc88fd51d74525c3
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Ryan Harper <ryanh(a)us.ibm.com>
Gerrit-Reviewer: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
12 years, 4 months
Change in ovirt-engine[master]: engines: improve data integrity in remove quota (#848816)
by gchaplik@redhat.com
Gilad Chaplik has submitted this change and it was merged.
Change subject: engines: improve data integrity in remove quota (#848816)
......................................................................
engines: improve data integrity in remove quota (#848816)
https://bugzilla.redhat.com/848816
Problem:
- with the enable of multiple quota in a single remove the possibility
for concurrency problems increase.
- if after the quota was removed from the cache and before it is removed
from the database it is accessed it may be loaded in to the cache and
stay there until it is removed once more.
Solution:
- switched the order of execution, first remove from DB and the from cache
now the operation cannot end in an inconsistent state
Change-Id: Ic9850db0041b7106c5a938b2089f4641235ea814
Signed-off-by: Noam Slomianko <nslomian(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveQuotaCommand.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Gilad Chaplik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7505
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic9850db0041b7106c5a938b2089f4641235ea814
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Noam Slomianko <nslomian(a)redhat.com>
Gerrit-Reviewer: Doron Fediuck <dfediuck(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Noam Slomianko <nslomian(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
12 years, 4 months
Change in ovirt-engine[master]: core: Improve unit-tests for MTU differences(#852052)
by masayag@redhat.com
Moti Asayag has submitted this change and it was merged.
Change subject: core: Improve unit-tests for MTU differences(#852052)
......................................................................
core: Improve unit-tests for MTU differences(#852052)
The patch improves MTU differences tests.
Change-Id: Ibf2ee87d2d95f814898edd06ca3a3c37309c34ab
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/SetupNetworksHelper.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/SetupNetworksHelperTest.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/NetworkUtils.java
3 files changed, 34 insertions(+), 19 deletions(-)
Approvals:
Moti Asayag: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7728
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibf2ee87d2d95f814898edd06ca3a3c37309c34ab
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: engine: Change setup networks to handle VDSM errors (#845205...
by mkolesni@redhat.com
Mike Kolesnik has submitted this change and it was merged.
Change subject: engine: Change setup networks to handle VDSM errors (#845205)
......................................................................
engine: Change setup networks to handle VDSM errors (#845205)
https://bugzilla.redhat.com/845205
Due to future task being used, special care needed to be taken to make
the command behave as a normal command would when sending a VDSM
command.
Now the VDSM error codes should be returned to client in case of an
error.
Change-Id: Ic833efde810e3e204612f4ba522e6c7aaa32c237
Signed-off-by: Mike Kolesnik <mkolesni(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/SetupNetworksCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VDSBrokerFrontendImpl.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsHandler.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/FutureVDSCommand.java
4 files changed, 33 insertions(+), 27 deletions(-)
Approvals:
Mike Kolesnik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7679
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic833efde810e3e204612f4ba522e6c7aaa32c237
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Muli Salem <msalem(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
12 years, 4 months
Change in ovirt-engine[master]: core: Clear current SPM upon "Not SPM" error
by masayag@redhat.com
Moti Asayag has submitted this change and it was merged.
Change subject: core: Clear current SPM upon "Not SPM" error
......................................................................
core: Clear current SPM upon "Not SPM" error
Clear the current SPM when we get a "Not SPM" error from the
current SPM, this is needed when we have a host which is not an SPM
anymore (Cause of being fenced for instance) which still gets SPM
commands sent to it and returns "Not SPM", so instead waiting for the
next SPM status check, we immediately remove it and start spmStart process
to find an SPM host
Change-Id: Id0c9aa8c11ba115580d64c2c64873e059c986bbc
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/IrsBrokerCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Moti Asayag: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7727
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id0c9aa8c11ba115580d64c2c64873e059c986bbc
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: packaging: Improve the error message on engine-upgrade when ...
by bazulay@redhat.com
Barak Azulay has submitted this change and it was merged.
Change subject: packaging: Improve the error message on engine-upgrade when dwh is up (BZ#843495)
......................................................................
packaging: Improve the error message on engine-upgrade when dwh is up (BZ#843495)
https://bugzilla.redhat.com/show_bug.cgi?id=843495
This patch improves the error message when dwhd service is up on engine-upgrade.
The issue is when dwhd service is up, engine update will fail due to open connections to the
DB.
Change-Id: I8ea0d058f8bc9c43ee03be74dcb9d7ed815c0293
Signed-off-by: Kiril Nesenko <knesenko(a)redhat.com>
---
M packaging/fedora/setup/engine-upgrade.py
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Barak Azulay: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7691
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8ea0d058f8bc9c43ee03be74dcb9d7ed815c0293
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Kiril Nesenko <knesenko(a)redhat.com>
Gerrit-Reviewer: Alex Lourie <alourie(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Barak Azulay <bazulay(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Kiril Nesenko <knesenko(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
12 years, 4 months
Change in ovirt-engine[master]: engine: RunMultipleAction - supporting Run Only If All CanDo...
by gchaplik@redhat.com
Gilad Chaplik has submitted this change and it was merged.
Change subject: engine: RunMultipleAction - supporting Run Only If All CanDo Pass
......................................................................
engine: RunMultipleAction - supporting Run Only If All CanDo Pass
A new boolean parameter is added to MultipleActionsRunner to
support run the actions only if CanDo of all commands are passed.
The new field isRunOnlyIfAllCanDoPass will be false by default
so the RunMultipleAction behaves as it was previously.
Change-Id: If8f249484a451be44d3286c865806c5f8364f74a
Signed-off-by: Kanagaraj M <kmayilsa(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/Backend.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MultipleActionsRunner.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/AttachStorageDomainsMultipleActionRunner.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/interfaces/BackendLocal.java
M frontend/api/genericapi/src/main/java/org/ovirt/engine/ui/genericapi/GenericApiService.java
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/Frontend.java
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/gwtservices/GenericApiGWTService.java
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/server/gwt/GenericApiGWTServiceImpl.java
8 files changed, 55 insertions(+), 19 deletions(-)
Approvals:
Gilad Chaplik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7287
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If8f249484a451be44d3286c865806c5f8364f74a
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Shireesh Anjal <sanjal(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
12 years, 4 months
Change in ovirt-engine[master]: webadmin: skipping cpu validation while saving gluster clust...
by gchaplik@redhat.com
Gilad Chaplik has submitted this change and it was merged.
Change subject: webadmin: skipping cpu validation while saving gluster cluster
......................................................................
webadmin: skipping cpu validation while saving gluster cluster
While creating gluster cluster, the cpu field will not be validated.
CPU field is mandated in case the virt service is enabled for the cluster.
While editing any cluster if the cpu is already empty, it is allowed
to save without selecting any cpu.
Change-Id: I212eb24cee1c8a7f70af8f420e8582e73bab431c
Signed-off-by: Kanagaraj M <kmayilsa(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/clusters/ClusterListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/datacenters/DataCenterGuideModel.java
2 files changed, 9 insertions(+), 3 deletions(-)
Approvals:
Gilad Chaplik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/5792
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I212eb24cee1c8a7f70af8f420e8582e73bab431c
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Itamar Heim <iheim(a)redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Shireesh Anjal <sanjal(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
12 years, 4 months
Change in ovirt-engine[master]: core: Remove deprecated StringHelper in AddStorageServerConn...
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: Remove deprecated StringHelper in AddStorageServerConnectionCommand.
......................................................................
core: Remove deprecated StringHelper in AddStorageServerConnectionCommand.
Replaced StringHelper with StringUtils.
Change-Id: I3fe37c0f30fe02d253dd7ff36bcb5425f4205c1d
Signed-off-by: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/AddStorageServerConnectionCommand.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7386
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3fe37c0f30fe02d253dd7ff36bcb5425f4205c1d
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
12 years, 4 months
Change in ovirt-engine[master]: core: Remove deprecated StringHelper in RunVmCommandBase.
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: Remove deprecated StringHelper in RunVmCommandBase.
......................................................................
core: Remove deprecated StringHelper in RunVmCommandBase.
Replaced StringHelper with StringUtils
Change-Id: I5a9ca5490ccfd8f63f052ad0dfb6ae002cfd412f
Signed-off-by: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommandBase.java
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7278
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5a9ca5490ccfd8f63f052ad0dfb6ae002cfd412f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
12 years, 4 months