Change in ovirt-engine[master]: userportal, webadmin: XSRF token generation fix
by awels@redhat.com
Alexander Wels has submitted this change and it was merged.
Change subject: userportal,webadmin: XSRF token generation fix
......................................................................
userportal,webadmin: XSRF token generation fix
- Fix token generation to use session id instead of passed
in jsessionid cookie, as that value might be stale. This
prevents a lot of 500 errors in the log due to automatic
login.
Change-Id: I3e9a234bada73873f398d4220808f573810440dc
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1115918
Signed-off-by: Alexander Wels <awels(a)redhat.com>
---
A frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/server/gwt/OvirtXsrfTokenServiceServlet.java
M frontend/webadmin/modules/frontend/src/main/resources/META-INF/web-fragment.xml
2 files changed, 28 insertions(+), 1 deletion(-)
Approvals:
Alexander Wels: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/30849
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3e9a234bada73873f398d4220808f573810440dc
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Einav Cohen <ecohen(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[ovirt-engine-3.5]: core: Calculate storage format when adding an SD
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Calculate storage format when adding an SD
......................................................................
core: Calculate storage format when adding an SD
Removed the default V1 format from StorageDomainStatic's constructor so
it can be calculated when adding a domain without specifying the format
via REST.
The logic goes as follows:
- If the format is specified (as is the case in all the edit scenarios
as well as when adding a new domain via the GUI), leave it alone
- If it's a data domain, set the format to the format required by the
pool's version.
Note: Creating a domain by a host not attached to a pool is currently
NOT supported. This patch does not change that behavior, nor does it
handle this situation.
- If it's not a data domain, use V1 (i.e., preserve the old behavior).
Change-Id: If469bb655e9a65e2d0afcee164655fa0bdfa5d99
Bug-Url: https://bugzilla.redhat.com/1120712
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/AddStorageDomainCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/StorageDomainStatic.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/StorageDomainDynamicDAOTest.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/StorageDomainStaticDAOTest.java
4 files changed, 23 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/31348
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If469bb655e9a65e2d0afcee164655fa0bdfa5d99
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[ovirt-engine-3.5]: core: AddStorageDomainCommand.getTargetStoragePool
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: AddStorageDomainCommand.getTargetStoragePool
......................................................................
core: AddStorageDomainCommand.getTargetStoragePool
Extracted AddStorageDomainCommand.getTargetStoragePool for later use
(not to mention the increased readability).
Change-Id: I3776beb5a7426e010f05ca0b4f3dffb128346ed7
Related-To: https://bugzilla.redhat.com/1120712
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/AddStorageDomainCommand.java
1 file changed, 11 insertions(+), 5 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/31347
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3776beb5a7426e010f05ca0b4f3dffb128346ed7
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[ovirt-engine-3.5]: engine: Fix confusing names in async tasks
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: engine: Fix confusing names in async tasks
......................................................................
engine: Fix confusing names in async tasks
Fix confusing name for action and command
parameters in AsyncTasks and Command Entities
Change-Id: I6e619857ae36f1b69a4370ddcf53aee45c2c2c6f
Bug-Url: https://bugzilla.redhat.com/1127774
Signed-off-by: Ravi Nori <rnori(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/tasks/CoCoAsyncTaskHelper.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/tasks/CommandCoordinatorImpl.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/AsyncTasks.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/CommandEntity.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/AsyncTaskDAODbFacadeImpl.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/CommandEntityDaoDbFacadeImpl.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/CommandEntityDaoTest.java
M backend/manager/modules/dal/src/test/resources/fixtures.xml
M packaging/dbscripts/async_tasks_sp.sql
M packaging/dbscripts/command_entities_sp.sql
A packaging/dbscripts/upgrade/03_05_0870_rename_async_tasks_columns.sql
12 files changed, 61 insertions(+), 50 deletions(-)
Approvals:
Ravi Nori: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/31345
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6e619857ae36f1b69a4370ddcf53aee45c2c2c6f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[master]: engine: Remove unused javassisst dependencies
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: engine: Remove unused javassisst dependencies
......................................................................
engine: Remove unused javassisst dependencies
The engine and its test suite do not use Javassisst directly - its is
only used as part of the PowerMock mocking (and is required directly due
to a bug in PowerMock's pom).
Most of PowerMock's usages were removed from the engine a long time ago,
with the exception being the jaxrs module.
This patch removes the leftover javassisst dependencies from all the
other modules that no longer require it.
Change-Id: I360789865b8de899d1a04b0f8a974e95eecc65ca
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/pom.xml
M backend/manager/modules/dal/pom.xml
M backend/manager/modules/restapi/types/pom.xml
3 files changed, 0 insertions(+), 17 deletions(-)
Approvals:
Ori Liel: Looks good to me, but someone else must approve
Allon Mureinik: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/30865
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I360789865b8de899d1a04b0f8a974e95eecc65ca
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mishka8520(a)yahoo.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[master]: core: update support of ppc cpus
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: update support of ppc cpus
......................................................................
core: update support of ppc cpus
Change-Id: I75ea7ce447853f653cc45044cbf8ede64c0a8bb9
Signed-off-by: Omer Frenkel <ofrenkel(a)redhat.com>
---
M packaging/dbscripts/upgrade/pre_upgrade/0000_config.sql
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/31063
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I75ea7ce447853f653cc45044cbf8ede64c0a8bb9
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Michal Skrivanek <michal.skrivanek(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[ovirt-engine-3.5]: engine: Persist command at end of execution
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: engine: Persist command at end of execution
......................................................................
engine: Persist command at end of execution
Persist command at the end of command
execution
Change-Id: I1610e115fb215b9f2dcd587a41c748580f98260d
Bug-Url: https://bugzilla.redhat.com/1127774
Signed-off-by: Ravi Nori <rnori(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/tasks/TaskManagerUtil.java
2 files changed, 28 insertions(+), 12 deletions(-)
Approvals:
Ravi Nori: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/31344
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1610e115fb215b9f2dcd587a41c748580f98260d
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[master]: restapi: duplicate code in export domain tests
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: restapi: duplicate code in export domain tests
......................................................................
restapi: duplicate code in export domain tests
Removed duplicated code where the if and else branches are identical.
Change-Id: I22c496c8957a86d8fc5d915c552218c9fe5943a6
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendExportDomainDiskResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendExportDomainDisksResourceTest.java
2 files changed, 8 insertions(+), 24 deletions(-)
Approvals:
Ori Liel: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/30764
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I22c496c8957a86d8fc5d915c552218c9fe5943a6
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mishka8520(a)yahoo.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[ovirt-engine-3.5]: core: error fix: right bound of range interval should be inc...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: error fix: right bound of range interval should be inclusive.
......................................................................
core: error fix: right bound of range interval should be inclusive.
number of macs in range was invalid, missing one mac, which causes
system complaining about no available mac, when
same start mac and end mac was used. This is not ok, since validations
allows use of same start mac and end mac for given mac range.
Change-Id: I7f1257e752680b56decd69eb9a79caad97378e12
Bug-Url: https://bugzilla.redhat.com/1127245
Signed-off-by: Martin Mucha <mmucha(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/Range.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/network/RangeTest.java
2 files changed, 2 insertions(+), 2 deletions(-)
Approvals:
Martin Mucha: Verified
Moti Asayag: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/31316
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7f1257e752680b56decd69eb9a79caad97378e12
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[ovirt-engine-3.4]: webadmin: attach disk - allow read-only for DirectLUN
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: webadmin: attach disk - allow read-only for DirectLUN
......................................................................
webadmin: attach disk - allow read-only for DirectLUN
Attach disk dialog:
allow read-only selection for DirecLUN disks not using
SCSI pass-through.
Change-Id: Id2ff8730b7da1d20e71339871ee462c23d263c5b
Bug-Url: https://bugzilla.redhat.com/1125373
Signed-off-by: Daniel Erez <derez(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/disks/DisksViewColumns.java
1 file changed, 2 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Daniel Erez: Verified
--
To view, visit http://gerrit.ovirt.org/31343
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id2ff8730b7da1d20e71339871ee462c23d263c5b
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.4
Gerrit-Owner: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 4 months