Change in ovirt-engine[master]: core: Fix assertion
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Fix assertion
......................................................................
core: Fix assertion
Fixed the assertion in
AffinityRulesEnforcementManagerTest#positiveEnforcementUAGTest to have
the test run.
Change-Id: I9c2b1a349d045735b36b480cc214412b542d0733
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/scheduling/AffinityRulesEnforcementManagerTest.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Roy Golan: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/42620
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9c2b1a349d045735b36b480cc214412b542d0733
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tomer Saban <tsaban(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 4 months
Change in ovirt-engine[master]: core: Make AffinityGroupComparator Serializeable
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Make AffinityGroupComparator Serializeable
......................................................................
core: Make AffinityGroupComparator Serializeable
Made the Comparator serializeable, as per Java's best practices for
Comparators.
Change-Id: I31582e682fc876511b69817a6bb5fbd381162625
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/scheduling/arem/AffinityRulesEnforcementPerCluster.java
1 file changed, 2 insertions(+), 1 deletion(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Roy Golan: Looks good to me, approved
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/42631
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I31582e682fc876511b69817a6bb5fbd381162625
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tomer Saban <tsaban(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 4 months
Change in ovirt-engine[master]: core: Use anyLong() instead of anyInt()
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Use anyLong() instead of anyInt()
......................................................................
core: Use anyLong() instead of anyInt()
Use the correct matcher for the long parameter to avoid redundant
widening cast.
Change-Id: I51592e2a68ffe12c9cfe225be88cdcafa68aa71c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/scheduling/AffinityRulesEnforcementManagerTest.java
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Roy Golan: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/42625
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I51592e2a68ffe12c9cfe225be88cdcafa68aa71c
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tomer Saban <tsaban(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 4 months
Change in ovirt-engine[master]: core: Clean up addInjectionsToPerClusterObjects()
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Clean up addInjectionsToPerClusterObjects()
......................................................................
core: Clean up addInjectionsToPerClusterObjects()
Changed iterating over a temporary object with a direct iteration on the
entrySet(). This technique has several advantages:
1. It's more readable.
2. It's shorter.
3. It avoids copying the entire map just to re-initialize it.
Change-Id: Ic08df6c9c798d0b6a2072825a0a64ff2b3d722e6
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/scheduling/AffinityRulesEnforcementManagerTest.java
1 file changed, 4 insertions(+), 6 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Roy Golan: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/42624
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic08df6c9c798d0b6a2072825a0a64ff2b3d722e6
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tomer Saban <tsaban(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 4 months
Change in ovirt-engine[master]: core: Diamond Generics
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Diamond Generics
......................................................................
core: Diamond Generics
Use proper generics where possible in
AffinityRulesEnforcementManagerTest.
Change-Id: Id2e0a425b5d983814dc53a0d1c060f7347770f41
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/scheduling/AffinityRulesEnforcementManagerTest.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Roy Golan: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/42623
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id2e0a425b5d983814dc53a0d1c060f7347770f41
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tomer Saban <tsaban(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 4 months
Change in ovirt-engine[master]: restapi: Fix metadata of "refreshluns"
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Fix metadata of "refreshluns"
......................................................................
restapi: Fix metadata of "refreshluns"
The patch that introduced the "refreshluns" actions also explicitly
documented the "async" matrix parameter for this new action and for the
existing "isattached" action. This isn't correct, as the "async"
parameter is implicitly documented, and documenting it explicitly causes
a duplication. That duplication induces an error in the code generated
by the Java SDK. This patch removes that explicit documentation and also
removes empty elements from the RSDL metadata.
Change-Id: I402ff58e93758e7593c190245cf0a6184af285da
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata.yaml
1 file changed, 5 insertions(+), 10 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved; Passed CI tests
Freddy Rolland: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/42746
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I402ff58e93758e7593c190245cf0a6184af285da
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Freddy Rolland <frolland(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 4 months
Change in ovirt-engine[ovirt-engine-3.5-gluster]: gluster: Corrected geo-rep case of volume snapshot creation
by sabose@redhat.com
Sahina Bose has submitted this change and it was merged.
Change subject: gluster: Corrected geo-rep case of volume snapshot creation
......................................................................
gluster: Corrected geo-rep case of volume snapshot creation
While creating gluster volume snapshot for a geo-replicated
volume, we try to pause the geo-rep session and then create
snapshot for the slave volume first. The pause of the slave
volume should be done only if geo-rep session is not in
one of the states from CREATED, PAUSED or STOPPED.
Modified the code accordingly.
Change-Id: Iaefc24c83168ce53960c9f90597a43d5030f7212
Bug-Url: https://bugzilla.redhat.com/1224902
Signed-off-by: Shubhendu Tripathi <shtripat(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/CreateGlusterVolumeSnapshotCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/PauseGlusterVolumeGeoRepSessionCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/RestoreGlusterVolumeSnapshotCommand.java
3 files changed, 85 insertions(+), 74 deletions(-)
Approvals:
Shubhendu Tripathi: Verified
Sahina Bose: Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/42750
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iaefc24c83168ce53960c9f90597a43d5030f7212
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5-gluster
Gerrit-Owner: Shubhendu Tripathi <shtripat(a)redhat.com>
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Shubhendu Tripathi <shtripat(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 4 months
Change in jenkins[master]: Adding hosted engine plugin CI Jobs
by tlitovsk@redhat.com
Anatoly Litovsky has submitted this change and it was merged.
Change subject: Adding hosted engine plugin CI Jobs
......................................................................
Adding hosted engine plugin CI Jobs
Change-Id: I5c0c80c8a4959477f3972a2cb9ea314640e3d794
Signed-off-by: Tolik Litovsky <tlitovsk(a)redhat.com>
---
M jobs/confs/yaml/jobs/ovirt-node/ovirt-node-job.yaml
M jobs/confs/yaml/scms/ovirt-node-scms.yaml
2 files changed, 38 insertions(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Anatoly Litovsky: Verified; Looks good to me; Passed CI tests; Ready for merge
--
To view, visit https://gerrit.ovirt.org/42613
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5c0c80c8a4959477f3972a2cb9ea314640e3d794
Gerrit-PatchSet: 3
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Anatoly Litovsky <tlitovsk(a)redhat.com>
Gerrit-Reviewer: Anatoly Litovsky <tlitovsk(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Fabian Deutsch <fabiand(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Ryan Barry <rbarry(a)redhat.com>
9 years, 4 months
Change in jenkins[master]: Adding vdsm-plugin to mock rpm builds
by tlitovsk@redhat.com
Anatoly Litovsky has submitted this change and it was merged.
Change subject: Adding vdsm-plugin to mock rpm builds
......................................................................
Adding vdsm-plugin to mock rpm builds
Change-Id: I9492ffc59b9944f7dd4721036df24e89edc4e3df
Signed-off-by: Tolik Litovsky <tlitovsk(a)redhat.com>
---
M jobs/confs/yaml/jobs/ovirt-node/ovirt-node-job.yaml
M jobs/confs/yaml/scms/ovirt-node-scms.yaml
2 files changed, 36 insertions(+), 1 deletion(-)
Approvals:
Jenkins CI: Passed CI tests
Anatoly Litovsky: Verified; Looks good to me; Passed CI tests; Ready for merge
--
To view, visit https://gerrit.ovirt.org/42586
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9492ffc59b9944f7dd4721036df24e89edc4e3df
Gerrit-PatchSet: 5
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Anatoly Litovsky <tlitovsk(a)redhat.com>
Gerrit-Reviewer: Anatoly Litovsky <tlitovsk(a)redhat.com>
Gerrit-Reviewer: David Caro <dcaroest(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Fabian Deutsch <fabiand(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Ryan Barry <rbarry(a)redhat.com>
9 years, 4 months
Change in jenkins[master]: Switching the ovirt-node rpm builds to new mock rpm builds
by tlitovsk@redhat.com
Anatoly Litovsky has submitted this change and it was merged.
Change subject: Switching the ovirt-node rpm builds to new mock rpm builds
......................................................................
Switching the ovirt-node rpm builds to new
mock rpm builds
Change-Id: I4c8da05fe160831c8effd564abe4ece0b7a36b32
Signed-off-by: Tolik Litovsky <tlitovsk(a)redhat.com>
---
D jobs/confs/shell-scripts/build_livecd_tools.sh
M jobs/confs/yaml/builders/ovirt-node-builders.yaml
M jobs/confs/yaml/jobs/ovirt-node/ovirt-node-job.yaml
M jobs/confs/yaml/scms/ovirt-node-scms.yaml
M jobs/confs/yaml/templates/ovirt-node-job-templates.yaml
5 files changed, 35 insertions(+), 56 deletions(-)
Approvals:
Fabian Deutsch: Looks good to me
Jenkins CI: Passed CI tests
Anatoly Litovsky: Verified; Passed CI tests; Ready for merge
--
To view, visit https://gerrit.ovirt.org/42585
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4c8da05fe160831c8effd564abe4ece0b7a36b32
Gerrit-PatchSet: 7
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Anatoly Litovsky <tlitovsk(a)redhat.com>
Gerrit-Reviewer: Anatoly Litovsky <tlitovsk(a)redhat.com>
Gerrit-Reviewer: David Caro <dcaroest(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Fabian Deutsch <fabiand(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Ryan Barry <rbarry(a)redhat.com>
9 years, 4 months