Change in ovirt-engine[ovirt-engine-3.6]: core: prevent duplicate virtio-serial device
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: prevent duplicate virtio-serial device
......................................................................
core: prevent duplicate virtio-serial device
In 3.6 the virtio-serial device becomes managed device. However, it
can still be reported as unmanaged if the VM was started in pre 3.6
version and was running during the upgrade and its ID will be
different than the one stored in the database.
This patch suggests to look for virtio-serial devices not only by
their ID but by their type as well. That way, when we get unamanged
virtio-serial reported by VDSM, we will be able to correlate it to
the managed device and it will prevent adding it again.
This solution assumes that only one virtio-serial device is defined
for each VM.
Change-Id: I3546332024b6ee7667340f031c6c225e1ee67ead
Bug-Url: https://bugzilla.redhat.com/1308885
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/utils/VmDeviceCommonUtils.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VmsMonitoring.java
2 files changed, 23 insertions(+), 2 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/54290
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3546332024b6ee7667340f031c6c225e1ee67ead
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: refactor luns-monitoring
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: refactor luns-monitoring
......................................................................
core: refactor luns-monitoring
1. change the visibility of some methods to package-protected
so it would be possible to mock them.
2. extract the code that fetches the luns connected to a VM
to a separate method so it could be mocked and use stream
API there.
Change-Id: I72fa6d517bc12d288760068d37a5bdfb75cbbc72
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/monitoring/LunDisksMonitoring.java
1 file changed, 13 insertions(+), 13 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Arik Hadas: Verified; Passed CI tests
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/54295
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I72fa6d517bc12d288760068d37a5bdfb75cbbc72
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine-sdk[master]: Add "dist" tag to the names of the RPMs
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: Add "dist" tag to the names of the RPMs
......................................................................
Add "dist" tag to the names of the RPMs
Currently the automation scripts build the RPMs for the package without
the "dist" tag:
EL7: python-ovirt-engine-sdk4-4.0.0.x86_64.rpm
F23: python-ovirt-engine-sdk4-4.0.0.x86_64.rpm
This may cause confussion when RPM files are automatically selected,
using this tag as a crieteria. To avoid those potential issues this
patch modifies the automation scripts so that the explicitly add the
"dist" tag:
EL7: python-ovirt-engine-sdk4-4.0.0.el7.x86_64.rpm
F23: python-ovirt-engine-sdk4-4.0.0.fc23.x86_64.rpm
Change-Id: Icf1663eef395c6afca0d3d40313274f95d9a4f49
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M automation/build-artifacts.sh
1 file changed, 2 insertions(+), 1 deletion(-)
Approvals:
Sandro Bonazzola: Looks good to me, but someone else must approve
Juan Hernandez: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/54294
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Icf1663eef395c6afca0d3d40313274f95d9a4f49
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-sdk
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: extract luns related code from vm-analyzer
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: extract luns related code from vm-analyzer
......................................................................
core: extract luns related code from vm-analyzer
VmAnalyzer should (ideally) take a VM that was reported by VDSM,
compare it to the previous information we have for that VM and
analyze the difference. However, the analyzer currently does
more than that and therefore is not easy to maintain.
This patch extracts the LUN disks handling from VmAnalyzer to
a new class called LunDisksMonitoring. The benefits are:
1. Less not-that-related code in VmAnalyzer and one less DAO to
pass to it.
2. We get to the point where the up-to-date dynamic data of the
VM is persisted to the database faster as we push one database
call per VM that is powering up to be the dynamic VM data is
save to the database.
Change-Id: I6a5f0410a0684c8785c08d27ed88502822158e85
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
A backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/monitoring/LunDisksMonitoring.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/monitoring/VmAnalyzer.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/monitoring/VmAnalyzerFactory.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/monitoring/VmsMonitoring.java
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/monitoring/VmAnalyzerTest.java
5 files changed, 88 insertions(+), 68 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/53718
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6a5f0410a0684c8785c08d27ed88502822158e85
Gerrit-PatchSet: 12
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Michal Skrivanek <mskrivan(a)redhat.com>
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: Extract redundant equals() implementation in PendingRe...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Extract redundant equals() implementation in PendingResource subs
......................................................................
core: Extract redundant equals() implementation in PendingResource subs
Since all subclasses of PendingResource implement equals() in the same way
it's been extracted to an external class to avoid code duplication
Change-Id: I1372ad145a356bdc181ba4f63987e116c6f8995b
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/scheduling/pending/PendingCpuCores.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/scheduling/pending/PendingMemory.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/scheduling/pending/PendingVM.java
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/scheduling/utils/VmSpecificPendingResourceEqualizer.java
4 files changed, 33 insertions(+), 42 deletions(-)
Approvals:
Tal Nisan: Verified
Martin Sivák: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Roy Golan: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/54201
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1372ad145a356bdc181ba4f63987e116c6f8995b
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-hosted-engine-ha[master]: Fix parsing of metadata - we lost extra section because of r...
by msivak@redhat.com
Martin Sivák has submitted this change and it was merged.
Change subject: Fix parsing of metadata - we lost extra section because of rewrite in CRC code
......................................................................
Fix parsing of metadata - we lost extra section because of rewrite in CRC code
Change-Id: I885865798059ad6113b417acc99683ae21ef6d24
Signed-off-by: Martin Sivak <msivak(a)redhat.com>
---
M ovirt_hosted_engine_ha/lib/metadata.py
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Martin Sivák: Verified; Looks good to me, approved
Simone Tiraboschi: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Yedidyah Bar David: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/54275
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I885865798059ad6113b417acc99683ae21ef6d24
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: master
Gerrit-Owner: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[ovirt-engine-3.6]: engine: ObjectIdentityChecker: Exclude transient fields from...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: engine: ObjectIdentityChecker: Exclude transient fields from comparison
......................................................................
engine: ObjectIdentityChecker: Exclude transient fields from comparison
Added new TransientField annotation to mark fields that are not stored
in the DB so their values should be ignored when comparing objects with
ObjectIdentityChecker.
Change-Id: I9ac3388bd2c89c57d69d1766f9fb1c79f635452b
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1238742
Signed-off-by: Shmuel Melamud <smelamud(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VmHandler.java
A backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/TransientField.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VmBase.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ObjectIdentityChecker.java
4 files changed, 35 insertions(+), 3 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Shmuel Leib Melamud: Verified
Arik Hadas: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/54273
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9ac3388bd2c89c57d69d1766f9fb1c79f635452b
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: engine: Ignore change in creationDate for NEXT_RUN
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: engine: Ignore change in creationDate for NEXT_RUN
......................................................................
engine: Ignore change in creationDate for NEXT_RUN
Ignore creationDate when getting list of changed fields to update on
the next run. Otherwise creationDate will always show change in
milliseconds, because creationDate is saved without milliseconds in
OVF, but with milliseconds in the DB.
Change-Id: If672659ba5a433aa9d029b258bf7e36e0fe58b82
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1238742
Signed-off-by: Shmuel Melamud <smelamud(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetVmChangedFieldsForNextRunQuery.java
1 file changed, 6 insertions(+), 0 deletions(-)
Approvals:
Shmuel Leib Melamud: Verified
Arik Hadas: Looks good to me, approved; Passed CI tests
Objections:
Jenkins CI: Failed CI tests
--
To view, visit https://gerrit.ovirt.org/54175
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If672659ba5a433aa9d029b258bf7e36e0fe58b82
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: Cluster migration bandwidth - backend part
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: Cluster migration bandwidth - backend part
......................................................................
core: Cluster migration bandwidth - backend part
migrationBandwidthLimitType and customMigrationNetworkBandwidth
properties added to Cluster entity. They will be used to store bandwidth
limitation settings of migration network.
Limitation types:
* AUTO: Limit copied from host-network QoS if exists or based on minimum
link speed if link speed info is available or same as 'VDSM_CONFIG'
* VDSM_CONFIG: Each host controls speed of outgoing migrations based on local
VDSM configuration.
* CUSTOM: User defined fixed upper bound for outgoing migration
bandwidth.
Change-Id: I7459a3797cac45ec4fa3cf934652b3086fbc481f
Signed-off-by: Jakub Niedermertl <jniederm(a)redhat.com>
Bug-Url: https://bugzilla.redhat.com/1252426
Feature-Page: http://www.ovirt.org/Features/Migration_Enhancements
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/Cluster.java
A backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/MigrationBandwidthLimitType.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/ClusterDaoImpl.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/ClusterDaoTest.java
M backend/manager/modules/dal/src/test/resources/fixtures.xml
M frontend/webadmin/modules/gwt-common/src/main/resources/org/ovirt/engine/core/Common.gwt.xml
A packaging/dbscripts/upgrade/04_00_0260_add_cluster_migration_bandwidth.sql
7 files changed, 112 insertions(+), 3 deletions(-)
Approvals:
Jakub Niedermertl: Verified
Eli Mesika: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Arik Hadas: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/53929
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7459a3797cac45ec4fa3cf934652b3086fbc481f
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Jakub Niedermertl <jniederm(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jakub Niedermertl <jniederm(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: webadmin: Do not fetch disk info together with VM templates
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: webadmin: Do not fetch disk info together with VM templates
......................................................................
webadmin: Do not fetch disk info together with VM templates
In GetVmTemplatesByStoragePoolId and GetVmTemplatesFromStorageDomain
queries, the disk info fetched by them is not used in most situations.
However, fetching the excessive data takes time and slows down the UI.
This patch gets rid of disk info where it is not needed.
In particular, in 'New VM' and similar dialogs the disk info for the
currently selected template is queried separately, while the disk info
fetched previously for every template in the list is not used at all.
Change-Id: I6fa007c1cc7b49efb3d9d4e1c01a852aa8a3cf62
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1308478
Signed-off-by: Shmuel Melamud <smelamud(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetVmTemplatesByStoragePoolIdQuery.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetVmTemplatesFromStorageDomainQuery.java
A backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/GetVmTemplatesFromStorageDomainParameters.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainTemplateResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainTemplatesResourceTest.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/dataprovider/AsyncDataProvider.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageTemplateListModel.java
7 files changed, 40 insertions(+), 12 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Shmuel Leib Melamud: Verified
Arik Hadas: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/53938
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6fa007c1cc7b49efb3d9d4e1c01a852aa8a3cf62
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months