Change in ovirt-engine[ovirt-engine-3.6]: userportal: Fixed New Template dialog size
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: userportal: Fixed New Template dialog size
......................................................................
userportal: Fixed New Template dialog size
Changed the size of the New Template dialog in the user portal so
elements won't slide off it when "Create as a Template Sub Version"
widget is open.
Change-Id: I366f19dc7bb6efd8a2b4b96f539a80d269de5e1b
Bug-Url: https://bugzilla.redhat.com/1190142
Signed-off-by: Tomer Saban <tsaban(a)redhat.com>
(cherry picked from commit 459e70783d11793284d5efe013ef91943a35c11c)
---
M frontend/webadmin/modules/userportal-gwtp/src/main/java/org/ovirt/engine/ui/userportal/section/main/view/popup/vm/VmMakeTemplatePopupView.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/vm/VmMakeTemplatePopupView.java
2 files changed, 2 insertions(+), 2 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
Tomer Saban: Verified
--
To view, visit https://gerrit.ovirt.org/54456
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I366f19dc7bb6efd8a2b4b96f539a80d269de5e1b
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Tomer Saban <tsaban(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Tomer Saban <tsaban(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[ovirt-engine-3.6]: webadmin: Fix name of notifier service
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Fix name of notifier service
......................................................................
webadmin: Fix name of notifier service
Fixes name of ovirt-engine-notifier service.
Change-Id: I58cda9591b782169a3c4df0f1134782a3a204f5b
Bug-Url: https://bugzilla.redhat.com/1321583
Signed-off-by: Martin Perina <mperina(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/ApplicationConstants.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Martin Peřina: Verified
Eli Mesika: Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55407
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I58cda9591b782169a3c4df0f1134782a3a204f5b
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: move and rename updateRunTimeStatisticsData
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: move and rename updateRunTimeStatisticsData
......................................................................
core: move and rename updateRunTimeStatisticsData
This method was in VM class although all it does it to update the
statistics data that was reported by VDSM. Therefore, moving it
to VmStatistics class and rename it to updateRuntimeData.
Change-Id: If5ea639705223689bc47238a8584466d5a4df7f8
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VM.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VmStatistics.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/monitoring/VmAnalyzer.java
3 files changed, 35 insertions(+), 33 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Arik Hadas: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55361
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If5ea639705223689bc47238a8584466d5a4df7f8
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: move and rename updateRunTimeDynamicData
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: move and rename updateRunTimeDynamicData
......................................................................
core: move and rename updateRunTimeDynamicData
This method was in VM class although all it does is to update
the dynamic data that was reported by VDSM. Therefore, moving
it to VmDynamic class and rename it to updateRuntimeData.
Change-Id: Iec5e0baa920be91d30ec15ad75ab8a5771101038
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VM.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VmDynamic.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/monitoring/VmAnalyzer.java
3 files changed, 53 insertions(+), 53 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Arik Hadas: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55318
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iec5e0baa920be91d30ec15ad75ab8a5771101038
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: do not set run-on-vds name in monitoring
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: do not set run-on-vds name in monitoring
......................................................................
core: do not set run-on-vds name in monitoring
VM#runOnVdsName that stores the name of the VDS on which the VM run
should not be updated by the monitoring (no need to - it is not
persisted in the database and not being used afterwards).
Change-Id: Ib767c362acf11ecc8b32adf29dcc43eedf833499
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VM.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/monitoring/VmAnalyzer.java
2 files changed, 2 insertions(+), 4 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Arik Hadas: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55317
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib767c362acf11ecc8b32adf29dcc43eedf833499
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: webadmin: Dont show unregistered subtab if SD is unattached.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: webadmin: Dont show unregistered subtab if SD is unattached.
......................................................................
webadmin: Dont show unregistered subtab if SD is unattached.
When SD is unattached there is not reason to show the unregistered
entities it contains
Change-Id: I19cc30b2dc4265083b459286bf3adf419b6c96e1
Bug-Url: https://bugzilla.redhat.com/1138139
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageListModel.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Daniel Erez: Looks good to me, approved
Maor Lipchuk: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55332
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I19cc30b2dc4265083b459286bf3adf419b6c96e1
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: dal: Fix fetch of unregistered disks to update attached vms.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: dal: Fix fetch of unregistered disks to update attached vms.
......................................................................
dal: Fix fetch of unregistered disks to update attached vms.
Fix the DaoImpl class of unregistered disks so the attached vms will be
propoerly updated at each unregistered disks when fetched.
Change-Id: Ic3aa9afdf0621585a7dc3983f3b2d886d1494d5a
Bug-Url: https://bugzilla.redhat.com/1138139
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/UnregisteredDisksDaoImpl.java
1 file changed, 3 insertions(+), 9 deletions(-)
Approvals:
Daniel Erez: Looks good to me, approved
Maor Lipchuk: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55347
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic3aa9afdf0621585a7dc3983f3b2d886d1494d5a
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: webadmin: remove use of redundant query in list model.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: webadmin: remove use of redundant query in list model.
......................................................................
webadmin: remove use of redundant query in list model.
Since now register disk can also fetch a disk from the storage before
registering it, there is no need to use getUnregisteredDisk query any
more, therefore removing it.
Change-Id: I1b33e77de43fb4ef67f15e5e80c178a390c123b6
Bug-Url: https://bugzilla.redhat.com/1138139
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageRegisterDiskImageListModel.java
1 file changed, 4 insertions(+), 15 deletions(-)
Approvals:
Daniel Erez: Looks good to me, approved
Maor Lipchuk: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55336
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1b33e77de43fb4ef67f15e5e80c178a390c123b6
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Use the refresh indicator for fetching unreg disk.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Use the refresh indicator for fetching unreg disk.
......................................................................
core: Use the refresh indicator for fetching unreg disk.
Use the refresh indicator to refresh the disk using a query or using the
disk from the parameters.
Change-Id: I4b0d299792f6c3fecc4ae19ca480f63003d200f6
Bug-Url: https://bugzilla.redhat.com/1138139
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/RegisterDiskCommand.java
1 file changed, 35 insertions(+), 16 deletions(-)
Approvals:
Daniel Erez: Looks good to me, approved
Maor Lipchuk: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55335
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4b0d299792f6c3fecc4ae19ca480f63003d200f6
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Adding a flag to register disk parameters
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Adding a flag to register disk parameters
......................................................................
core: Adding a flag to register disk parameters
Adding a flag for register disk to determined if the disk should be
refetched from the Storage before registering it.
Change-Id: Ic7a32b30c1c4c407381f93acdf61be4d5daecc60
Bug-Url: https://bugzilla.redhat.com/1138139
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/RegisterDiskParameters.java
1 file changed, 10 insertions(+), 0 deletions(-)
Approvals:
Daniel Erez: Looks good to me, approved
Maor Lipchuk: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55334
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic7a32b30c1c4c407381f93acdf61be4d5daecc60
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months