Change in ovirt-engine[master]: vdsbroker: refactoring: Inject ResourceManager into SpmStopV...
by Code Review
>From Martin Betak <mbetak(a)redhat.com>:
Martin Betak has submitted this change and it was merged.
Change subject: vdsbroker: refactoring: Inject ResourceManager into SpmStopVDSCommand
......................................................................
vdsbroker: refactoring: Inject ResourceManager into SpmStopVDSCommand
Replaced .getInstance() lookup with CDI field injection.
Change-Id: I71cf057478e985ead9368b656c5369ab4975fb9c
Signed-off-by: Martin Betak <mbetak(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/SpmStopVDSCommand.java
1 file changed, 1 insertion(+), 3 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Martin Betak: Verified
Allon Mureinik: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/74778
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I71cf057478e985ead9368b656c5369ab4975fb9c
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: core: EngineExtensionsManager#normalizeName size optimization
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: core: EngineExtensionsManager#normalizeName size optimization
......................................................................
core: EngineExtensionsManager#normalizeName size optimization
The result of normalizeName always has the exact same size as the
input. Thus, the StringBuilder used to construct it can be
initialized to that size in order to avoid a (relatively) costly
extension of its size while appending characters.
Change-Id: I4cc073a53aa1407957c9b932abe37b53627a37bb
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/extensionsmgr/EngineExtensionsManager.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/75037
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4cc073a53aa1407957c9b932abe37b53627a37bb
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: core: EngineExtensionsManager#normalizeName underscore
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: core: EngineExtensionsManager#normalizeName underscore
......................................................................
core: EngineExtensionsManager#normalizeName underscore
normalizeName would produce a "_" character on both branches of the
"if" clause, so the explicit check for "_" can be removed and left to
the else clause to handle, in order to clean up the code.
Change-Id: I79072de51ad269ecde909b10557b1af30129254c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/extensionsmgr/EngineExtensionsManager.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/75036
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I79072de51ad269ecde909b10557b1af30129254c
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: core: EngineExtensionsManager noneMatch
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: core: EngineExtensionsManager noneMatch
......................................................................
core: EngineExtensionsManager noneMatch
Use the easier to read "noneMatch" instead of using "anyMatch" and
then negating the result.
Change-Id: Icafaaec87246e1f73f9e40b873260a19fe71f917
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/extensionsmgr/EngineExtensionsManager.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/75035
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Icafaaec87246e1f73f9e40b873260a19fe71f917
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: core: EngineExtensionsManager type specification
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: core: EngineExtensionsManager type specification
......................................................................
core: EngineExtensionsManager type specification
Use a generic type specification instead of an explicit cast to avoid
a compiler warning.
Change-Id: Ide45d4e671735ca59748c3c52b913170fa0184c3
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/extensionsmgr/EngineExtensionsManager.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/75034
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ide45d4e671735ca59748c3c52b913170fa0184c3
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: core: EngineExtensionsManager type inference
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: core: EngineExtensionsManager type inference
......................................................................
core: EngineExtensionsManager type inference
Change-Id: Id74a9d5884349af0fb6c61e1a8f2c4eb0386d1b2
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/extensionsmgr/EngineExtensionsManager.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
Moti Asayag: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/75033
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id74a9d5884349af0fb6c61e1a8f2c4eb0386d1b2
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-guest-agent[master]: Allow ability to ignore specific NICs in linux guest agent
by Code Review
>From Vinzenz Feenstra <vfeenstr(a)redhat.com>:
Vinzenz Feenstra has submitted this change and it was merged.
Change subject: Allow ability to ignore specific NICs in linux guest agent
......................................................................
Allow ability to ignore specific NICs in linux guest agent
Change-Id: Ifc7cd4e72a72b5133bae7405753046f56036c37f
Signed-off-by: Marcus Young <myoung34(a)my.apsu.edu>
---
M configurations/default.conf
M configurations/ovirt-guest-agent.conf
M ovirt-guest-agent/GuestAgentLinux2.py
M tests/guest_agent_test.py
4 files changed, 18 insertions(+), 11 deletions(-)
Approvals:
Vinzenz Feenstra: Looks good to me, approved; Passed CI tests
myoung34: Verified
--
To view, visit https://gerrit.ovirt.org/74877
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifc7cd4e72a72b5133bae7405753046f56036c37f
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-guest-agent
Gerrit-Branch: master
Gerrit-Owner: myoung34 <myoung34(a)my.apsu.edu>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Michal Skrivanek <michal.skrivanek(a)redhat.com>
Gerrit-Reviewer: Tomas Golembiovsky <tgolembi(a)redhat.com>
Gerrit-Reviewer: Vinzenz Feenstra <vfeenstr(a)redhat.com>
Gerrit-Reviewer: myoung34 <myoung34(a)my.apsu.edu>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: CopyImageGroup/CloneImageGroupVolumesStructure - volume format
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: CopyImageGroup/CloneImageGroupVolumesStructure - volume format
......................................................................
CopyImageGroup/CloneImageGroupVolumesStructure - volume format
CopyImageGroupCommand generates a destination format for the target disk
when performing a disk copy. This format is by the command when copying
a disk with snapshot collapse by passing it to the CopyImage vdsm verb
or when executing the CopyImageGroupWithData command (spdm flow).
The CopyImageGroupWithData command used that format for creating a
collapsed volume, but it passed it to CloneImageGroupVolumesStructure
which is used when cloning the image structure without performing
collapse.
This patch changes CopyImageGroupWithData and
CloneImageGroupVolumesStructure to not use the generated format when
creating the target image without collapse, but use the original volume
format.
Change-Id: Ie70f847a069a80e3c8e5bc45223da51ef957ed30
Bug-Url: https://bugzilla.redhat.com/1437383
Signed-off-by: Liron Aravot <laravot(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/CloneImageGroupVolumesStructureCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/image/CopyImageGroupWithDataCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/CloneImageGroupVolumesStructureCommandParameters.java
3 files changed, 3 insertions(+), 16 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, approved
Maor Lipchuk: Looks good to me, approved
Liron Aravot: Verified
--
To view, visit https://gerrit.ovirt.org/74807
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie70f847a069a80e3c8e5bc45223da51ef957ed30
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: CreateImageVDSCommandParams - adding imageType to appendAttr...
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: CreateImageVDSCommandParams - adding imageType to appendAttributes()
......................................................................
CreateImageVDSCommandParams - adding imageType to appendAttributes()
Change-Id: I1c1f30c1149ad761764d5e720b67caa9a9960c91
Bug-Url: https://bugzilla.redhat.com/1437383
Signed-off-by: Liron Aravot <laravot(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/vdscommands/CreateImageVDSCommandParameters.java
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, approved
Liron Aravot: Verified
--
To view, visit https://gerrit.ovirt.org/74808
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1c1f30c1149ad761764d5e720b67caa9a9960c91
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[ovirt-engine-4.1]: webadmin: import dialog load button
by Code Review
>From Tal Nisan <tnisan(a)redhat.com>:
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: import dialog load button
......................................................................
webadmin: import dialog load button
- The GWT buttons don't like being in a bootstrap grid
layout, and take up the entire width of the container.
This patch fixes the buttons in the import dialog.
Change-Id: Icbc0e3592e3581f4bfc5ac100939228a96334edf
Bug-Url: https://bugzilla.redhat.com/1390271
Signed-off-by: Alexander Wels <awels(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/ImportVmsPopupView.ui.xml
1 file changed, 9 insertions(+), 5 deletions(-)
Approvals:
Alexander Wels: Verified
Jenkins CI: Passed CI tests
Greg Sheremeta: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/74987
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Icbc0e3592e3581f4bfc5ac100939228a96334edf
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.1
Gerrit-Owner: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
7 years, 8 months