Change in ovirt-engine[master]: core: RemoveImageCommand: standardize comparisons
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: RemoveImageCommand: standardize comparisons
......................................................................
core: RemoveImageCommand: standardize comparisons
Make the while loop in removeImageFromDB() compare currentGuid to other
values in a consistent fashion - always use
currentGuid.equals(something) instead of mixing styles.
Change-Id: Ie3498f6dd2f403864487e83bd72b07d9ff572fd8
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveImageCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, but someone else must approve
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6509
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie3498f6dd2f403864487e83bd72b07d9ff572fd8
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: RemoveImageCommand: Extract initializers
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: RemoveImageCommand: Extract initializers
......................................................................
core: RemoveImageCommand: Extract initializers
Moved initialization code that may access the database from the
constructor to init methods so they can be overloaded in unit tests.
Change-Id: I4c7a544f96b3ba157283becc071898ac9d0bee08
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/BaseImagesCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveImageCommand.java
2 files changed, 21 insertions(+), 7 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, but someone else must approve
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6409
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4c7a544f96b3ba157283becc071898ac9d0bee08
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: RemoveImageCommand: remove commented line
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: RemoveImageCommand: remove commented line
......................................................................
core: RemoveImageCommand: remove commented line
Removed a commented out line from the command - no use in leaving it in
there.
Change-Id: Id8be7c123118b4b97fc244b6220a072bb6fcf7aa
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveImageCommand.java
1 file changed, 0 insertions(+), 1 deletion(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, but someone else must approve
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6408
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id8be7c123118b4b97fc244b6220a072bb6fcf7aa
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: RemoveImageCommand: removed DbFacade refs
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: RemoveImageCommand: removed DbFacade refs
......................................................................
core: RemoveImageCommand: removed DbFacade refs
Replaced calls to DbFacade.getInstance() with protected DAO accessors
for better testability.
Change-Id: If2216b6fd9ee76394ad841b219f7eae8b15e7509
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveImageCommand.java
1 file changed, 10 insertions(+), 10 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6407
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If2216b6fd9ee76394ad841b219f7eae8b15e7509
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: RemoveImageCommand: suppress serial
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: RemoveImageCommand: suppress serial
......................................................................
core: RemoveImageCommand: suppress serial
Suppressed the "serial" warning in RemoveImageCommand, since commands are
never serialized, and this warning just adds useless noise to the
compilation process.
Change-Id: I1115ef68705e98db077fa18927bcd66934cf3dac
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveImageCommand.java
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6406
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1115ef68705e98db077fa18927bcd66934cf3dac
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: BaseImagesCommand: use runVdsCommand
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: BaseImagesCommand: use runVdsCommand
......................................................................
core: BaseImagesCommand: use runVdsCommand
Use runVdsCommand instead of Backend static methods for better
readability and testability.
Change-Id: Ic03636bf3335dba28c97578ee062b6815226f887
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/BaseImagesCommand.java
1 file changed, 8 insertions(+), 14 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6405
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic03636bf3335dba28c97578ee062b6815226f887
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: BaseImagesCommand: pull down remove methods
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: BaseImagesCommand: pull down remove methods
......................................................................
core: BaseImagesCommand: pull down remove methods
Moved the RemoveChildren and GetImageChildren from BaseImagesCommand to
RemoveImageCommand, which is the only class that uses them.
Change-Id: Ic26184d0d22813483eb4ec3c71a4eb0da664a7b7
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/BaseImagesCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveImageCommand.java
2 files changed, 30 insertions(+), 28 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6404
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic26184d0d22813483eb4ec3c71a4eb0da664a7b7
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: BaseImagesCommand: non-static setImageStatus
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: BaseImagesCommand: non-static setImageStatus
......................................................................
core: BaseImagesCommand: non-static setImageStatus
Made the setImageStatus method an instance method for better testability
and readability.
Change-Id: I960936e7d759d198b81a86126bc3d38dd2e28f0d
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/BaseImagesCommand.java
1 file changed, 7 insertions(+), 10 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6403
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I960936e7d759d198b81a86126bc3d38dd2e28f0d
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: BaseImagesCommand: Don't use static DbFacade
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: BaseImagesCommand: Don't use static DbFacade
......................................................................
core: BaseImagesCommand: Don't use static DbFacade
Replaced calls to DbFacade.getInstance() to getDbFacade() and extracted
DAO accessors where possible (i.e., for all the instance methods).
Change-Id: I9fca30356f20217cf1334b9b7720bb280e4a1799
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/BaseImagesCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/StorageDomainCommandBase.java
2 files changed, 20 insertions(+), 15 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6402
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9fca30356f20217cf1334b9b7720bb280e4a1799
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: BaseImagesCommand: remove useless null check
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: BaseImagesCommand: remove useless null check
......................................................................
core: BaseImagesCommand: remove useless null check
Removed a couple of null checks of a variable that is clearly not null,
since its methods are used earlier on in the method.
Change-Id: I3c416b1b5d9ee046a63d06d48b4940ecd8f2d875
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/BaseImagesCommand.java
1 file changed, 4 insertions(+), 8 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6401
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3c416b1b5d9ee046a63d06d48b4940ecd8f2d875
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
12 years, 4 months