Change in otopi[master]: packagers: yum: drop the local helper
by Alon Bar-Lev
Alon Bar-Lev has submitted this change and it was merged.
Change subject: packagers: yum: drop the local helper
......................................................................
packagers: yum: drop the local helper
Change-Id: I65e3340bc805811e5e2a41af23bd53386ba340ae
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M po/POTFILES.in
M src/plugins/otopi/packagers/Makefile.am
D src/plugins/otopi/packagers/miniyumlocal.py
M src/plugins/otopi/packagers/yumpackager.py
4 files changed, 65 insertions(+), 103 deletions(-)
Approvals:
Alon Bar-Lev: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/15778
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I65e3340bc805811e5e2a41af23bd53386ba340ae
Gerrit-PatchSet: 1
Gerrit-Project: otopi
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
11 years, 10 months
Change in ovirt-engine[master]: core: cleanup CreateVmVDSCommand
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: cleanup CreateVmVDSCommand
......................................................................
core: cleanup CreateVmVDSCommand
- Refactor CreateVmVDSCommand#ExecuteVdsIdCommand method to be with less
nested levels and to have more readable structure
- Reduce duplicate code at CreateVmVDSCommand#ExecuteVdsIdCommand by
extracting the variability to external method: initCreateVDSCommand
- Rename private methods names in this class to start with lowercase
Change-Id: I8159dbfd351ea460d01c56553cfe3219d960c8b7
Bug-Url: https://bugzilla.redhat.com/960931
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/CreateVmVDSCommand.java
1 file changed, 55 insertions(+), 63 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/15681
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8159dbfd351ea460d01c56553cfe3219d960c8b7
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 10 months
Change in ovirt-engine[master]: core: restore memory from snapshot on run vm
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: restore memory from snapshot on run vm
......................................................................
core: restore memory from snapshot on run vm
If we're going to run a VM which is not suspended and its active
snapshot contains memory, we set the memory volume that the active
snapshot points to as the initial memory state of the VM.
Change-Id: Iee1e4149db44d690726f00d366562df07eb5cacd
Bug-Url: https://bugzilla.redhat.com/960931
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/vdscommands/CreateVmVDSCommandParameters.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/CreateVmVDSCommand.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VmInfoBuilderBase.java
4 files changed, 50 insertions(+), 15 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/15680
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iee1e4149db44d690726f00d366562df07eb5cacd
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 10 months
Change in ovirt-engine[master]: core: memory state handling on preview/commit/undo
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: memory state handling on preview/commit/undo
......................................................................
core: memory state handling on preview/commit/undo
On preview snapshot, add the memory from the previewed snapshot to the
active snapshot that is created, if the 'restoreMemory' flag is set in
the parameters.
On commit/undo, add the memory from the restored snapshot to the active
snapshot that is created.
Change-Id: I42c1b7dd4fcdf12fba1943792a1442984796cf45
Bug-Url: https://bugzilla.redhat.com/960931
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RestoreAllSnapshotsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/TryBackToAllSnapshotsOfVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/SnapshotsManager.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/TryBackToAllSnapshotsOfVmParameters.java
4 files changed, 124 insertions(+), 26 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/15679
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I42c1b7dd4fcdf12fba1943792a1442984796cf45
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 10 months
Change in ovirt-engine[master]: core: remove memory image on remove snapshot
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: remove memory image on remove snapshot
......................................................................
core: remove memory image on remove snapshot
If snapshot contains memory and it is the only one that contains that
memory, remove the memory volumes when removing the snapshot as well.
Note that there might be cases where more than one snapshot contain the
same memory:
1. when preview snapshot, the memory volume is copied from the snapshot
that is being previewed to the active snapshot
2. when running vm in stateless mode, the memory volume is copied to
the active snapshot
3. in the future we might support cloning a VM with its memory
state (clone from snapshot + import as clone) and the memory would be
copied to the cloned VM's snapshots
Change-Id: Ib0b4f5306c23046326c9dbb7ef5589b50c88462d
Bug-Url: https://bugzilla.redhat.com/960931
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/dbscripts/snapshots_sp.sql
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveSnapshotCommand.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/SnapshotDao.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/SnapshotDaoDbFacadeImpl.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/SnapshotDaoTest.java
5 files changed, 150 insertions(+), 25 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/15678
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib0b4f5306c23046326c9dbb7ef5589b50c88462d
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 10 months
Change in ovirt-engine[master]: restapi: fix incorrect compare of different object types
by mpastern@redhat.com
Michael Pasternak has submitted this change and it was merged.
Change subject: restapi: fix incorrect compare of different object types
......................................................................
restapi: fix incorrect compare of different object types
Change-Id: Ib206de5b38d95a90766426692e3185554d9bc249
Signed-off-by: Michael pasternak <mpastern(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendHostHookResource.java
1 file changed, 2 insertions(+), 1 deletion(-)
Approvals:
Michael Pasternak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/15763
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib206de5b38d95a90766426692e3185554d9bc249
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
11 years, 10 months
Change in ovirt-engine[master]: core: RegisterDiskCommand - correct storage domain
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: RegisterDiskCommand - correct storage domain
......................................................................
core: RegisterDiskCommand - correct storage domain
When registering new disk, the disk was saved to the db using the domain
information stored on its metadata - this can cause to failure during
registration or to have incorrect information stored in the engine db.
The domain on which the disk was existed on isn't necessarily the
new one on which the disk is now, so it shouldn't be saved with it.
The following patch set the saved storage domain to the current one and
is part of the complete fix which involves also setting the current id
to the image metadata in vdsm.
Change-Id: I568668fc1a8024ff255754287afbaa5d35b8a2ed
Signed-off-by: Liron Aravot <laravot(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RegisterDiskCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/RegisterDiskParameters.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainDisksResource.java
3 files changed, 7 insertions(+), 3 deletions(-)
Approvals:
Maor Lipchuk: Looks good to me, approved
Liron Ar: Verified
--
To view, visit http://gerrit.ovirt.org/15193
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I568668fc1a8024ff255754287afbaa5d35b8a2ed
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Chris Morrissey <cmorriss(a)netapp.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 10 months
Change in ovirt-engine[master]: restapi : host_id" and "host_name" are not on the autocomple...
by mpastern@redhat.com
Michael Pasternak has submitted this change and it was merged.
Change subject: restapi : host_id" and "host_name" are not on the autocompletion list for 'update storagedomain' (#966661)
......................................................................
restapi : host_id" and "host_name" are not on the autocompletion list for 'update storagedomain' (#966661)
Autocompletion list for 'update storagedomain'
does not show host_id or host_name as one of the
options. But one of host id or name is required
for update.
Change-Id: I676d437597ab8ed2b66ec609d837685d296399ad
Bug-Url: https://bugzilla.redhat.com/966661
Signed-off-by: Ravi Nori <rnori(a)redhat.com>
---
M backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata.yaml
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Michael Pasternak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/15166
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I676d437597ab8ed2b66ec609d837685d296399ad
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
11 years, 10 months
Change in ovirt-engine[master]: restapi: Hook ID Comparison - minor code fix
by mpastern@redhat.com
Michael Pasternak has submitted this change and it was merged.
Change subject: restapi: Hook ID Comparison - minor code fix
......................................................................
restapi: Hook ID Comparison - minor code fix
Change-Id: I61084b7a1854a63f06820f1cb08de5df23ef38ec
Signed-off-by: Ori Liel <oliel(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendHostHookResource.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendHostHookResourceTest.java
2 files changed, 6 insertions(+), 12 deletions(-)
Approvals:
Michael Pasternak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/15298
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I61084b7a1854a63f06820f1cb08de5df23ef38ec
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 10 months
Change in ovirt-engine-cli[master]: cli: list permits format better error when not enough parame...
by mpastern@redhat.com
Michael Pasternak has submitted this change and it was merged.
Change subject: cli: list permits format better error when not enough parameters(#962472)
......................................................................
cli: list permits format better error when not enough parameters(#962472)
list permits when executed at cli gives an improper error
message as shown below
unknown error: not enough arguments for format string
Change-Id: I349eb2719c15c0a5c08a31562597f095fd0cd9d1
Bug-Url: https://bugzilla.redhat.com/962472
Signed-off-by: Ravi Nori <rnori(a)redhat.com>
---
M src/ovirtcli/command/command.py
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Michael Pasternak: Looks good to me, approved
Ravi Nori: Verified
--
To view, visit http://gerrit.ovirt.org/15530
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I349eb2719c15c0a5c08a31562597f095fd0cd9d1
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-cli
Gerrit-Branch: master
Gerrit-Owner: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
11 years, 10 months