Change in ovirt-hosted-engine-setup[ovirt-hosted-engine-setup-2.0]: vm_status: add global maintenance to --json output
by stirabos@redhat.com
Simone Tiraboschi has submitted this change and it was merged.
Change subject: vm_status: add global maintenance to --json output
......................................................................
vm_status: add global maintenance to --json output
This was missed in the previous patch. Poll whether the cluster
is in global maintenance and report it in machine readable output
as well
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1353537
Change-Id: If1ba93ddd53beddca2100c44072bc301e02d8a2a
Signed-off-by: Ryan Barry <rbarry(a)redhat.com>
---
M src/ovirt_hosted_engine_setup/vm_status.py
1 file changed, 4 insertions(+), 0 deletions(-)
Approvals:
Simone Tiraboschi: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/60517
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If1ba93ddd53beddca2100c44072bc301e02d8a2a
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-setup
Gerrit-Branch: ovirt-hosted-engine-setup-2.0
Gerrit-Owner: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: core: Add isShared method for readability
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Add isShared method for readability
......................................................................
core: Add isShared method for readability
Add isShared method for readability reasons.
Change-Id: I4b71b469a4a826a2a06eea6036d9a3c28c80f439
Bug-Url: https://bugzilla.redhat.com/1353137
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/StorageDomain.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/storage/StorageType.java
2 files changed, 8 insertions(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
Allon Mureinik: Looks good to me, but someone else must approve
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/60299
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4b71b469a4a826a2a06eea6036d9a3c28c80f439
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: core: Introduce StorageTypeSharedComparator.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Introduce StorageTypeSharedComparator.
......................................................................
core: Introduce StorageTypeSharedComparator.
When selecting a domain to place memory volumes, there are currently
three comparators that choose the target domain:
* Number of the VM's disks in the domain
* File storage over block storage
* Free space - prefer domains with more free space
To improve resiliency, we should prefer shared domains over local domain
as the second criteria.
Change-Id: I27fd13f2cc97874440671a24d3dc17af6e2d4b66
Bug-Url: https://bugzilla.redhat.com/1353137
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/memory/MemoryStorageHandler.java
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/memory/sdcomparators/StorageTypeSharedComparator.java
A backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/memory/sdcomparators/StorageTypeSharedComparatorTest.java
3 files changed, 54 insertions(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, approved
Maor Lipchuk: Verified
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/60300
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I27fd13f2cc97874440671a24d3dc17af6e2d4b66
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: core: Add a shared domains comparator when reconstruct.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Add a shared domains comparator when reconstruct.
......................................................................
core: Add a shared domains comparator when reconstruct.
When electing a new master, reconstruction is attempted according to an
ascending order of the last time a domain was used as a master.
In a DC that contains both shared and local domains,
we should add a secondary criteria to prefer shared domains over local
domains for resiliency considerations.
Change-Id: Iaaa15e56531c046a45eaf201b0d989dbfc7e8517
Bug-Url: https://bugzilla.redhat.com/1353134
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/StorageDomainCommandBase.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/domain/StorageDomainCommandBaseTest.java
2 files changed, 100 insertions(+), 4 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, approved
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/60301
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iaaa15e56531c046a45eaf201b0d989dbfc7e8517
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: core: Add validation for update shared DC to local DC.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Add validation for update shared DC to local DC.
......................................................................
core: Add validation for update shared DC to local DC.
Local DC should not contain more than one host or more than one cluster.
When the DC is being updated we should block this operation.
Change-Id: If794a97a346e3b87d8444e9067600aaf4caf748b
Bug-Url: https://bugzilla.redhat.com/1302185
Bug-Url: https://bugzilla.redhat.com/1309212
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/pool/UpdateStoragePoolCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/pool/UpdateStoragePoolCommandTest.java
2 files changed, 34 insertions(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, approved
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/60506
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If794a97a346e3b87d8444e9067600aaf4caf748b
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: core: Allow detach of shared SD from local DC
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Allow detach of shared SD from local DC
......................................................................
core: Allow detach of shared SD from local DC
There is no need to block detaching of shared storage domain from a
local Data Center, since it can be used in other shared Data Centers.
Change-Id: I529442ff7f6d95ceaae18de754c5b3b50b0c5567
Bug-Url: https://bugzilla.redhat.com/1302185
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/DetachStorageDomainFromPoolCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/RemoveStorageDomainCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/StorageDomainCommandBase.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/domain/StorageDomainCommandBaseTest.java
4 files changed, 6 insertions(+), 24 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
Allon Mureinik: Looks good to me, but someone else must approve
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/60194
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I529442ff7f6d95ceaae18de754c5b3b50b0c5567
Gerrit-PatchSet: 12
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: core: Remove local DC for shared SD
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Remove local DC for shared SD
......................................................................
core: Remove local DC for shared SD
A local DC can now contain shared SDs and local SDs.
Removing a local DC used to format the master domain
attached to it since local SDs can not be detached.
Shared SDs behave differently, since those can be detached.
Based on that, if a local DC will be removed the master storage domain
will be formatted only if it is a local SD (to keep the previous
behaviour) and if it is a shared SD then this storage domain will only
be detached.
In the future we should have a seperate patch which will let the user
choose whether to format the last local SD or only detach and
remove it so it can be imported later.
Change-Id: I2385ef4a1a8d36761a0359fe420722f7b4a3bf90
Bug-Url: https://bugzilla.redhat.com/1302185
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/pool/RemoveStoragePoolCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
Allon Mureinik: Looks good to me, but someone else must approve
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/60195
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2385ef4a1a8d36761a0359fe420722f7b4a3bf90
Gerrit-PatchSet: 12
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: core: Change attach error message to be suitable for local.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Change attach error message to be suitable for local.
......................................................................
core: Change attach error message to be suitable for local.
Rephrase app error message
ERROR_CANNOT_ATTACH_STORAGE_DOMAIN_STORAGE_TYPE_NOT_MATCH to be
specific for local storage domains.
Change-Id: I2b65567b2577d2f4d399ac4ea06bb7091a3abd96
Bug-Url: https://bugzilla.redhat.com/1302185
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
4 files changed, 4 insertions(+), 4 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, approved
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/60296
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2b65567b2577d2f4d399ac4ea06bb7091a3abd96
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: core: Update storage pool from local to shared and vice versa
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Update storage pool from local to shared and vice versa
......................................................................
core: Update storage pool from local to shared and vice versa
Update storage pool type should be available from local DC to shared DC
and vice versa while there are no local SDs in a shared DC.
Change-Id: I57833964b6e29636a71afe101a4599d0c6f69e23
Bug-Url: https://bugzilla.redhat.com/1302185
Bug-Url: https://bugzilla.redhat.com/1309212
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/pool/UpdateStoragePoolCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/pool/UpdateStoragePoolCommandTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/EngineMessage.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/frontend/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
8 files changed, 37 insertions(+), 12 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, approved
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/60169
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I57833964b6e29636a71afe101a4599d0c6f69e23
Gerrit-PatchSet: 12
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months
Change in ovirt-engine[master]: core: Change shared/local validation on attach SD to DC.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Change shared/local validation on attach SD to DC.
......................................................................
core: Change shared/local validation on attach SD to DC.
A shared data center should not contain local Storage Domain.
All the rest of the combinations should be valid.
Change-Id: I200c00700d6e9f735414267b89736c8dd6f0f5fd
Bug-Url: https://bugzilla.redhat.com/1302185
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/storage/StorageDomainToPoolRelationValidator.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
Allon Mureinik: Looks good to me, but someone else must approve
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/60170
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I200c00700d6e9f735414267b89736c8dd6f0f5fd
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 4 months