Change in ovirt-engine-cli[master]: cli: Support multiline input for ovirt-engine-cli #815684
by mpastern@redhat.com
Michael Pasternak has submitted this change and it was merged.
Change subject: cli: Support multiline input for ovirt-engine-cli #815684
......................................................................
cli: Support multiline input for ovirt-engine-cli #815684
since command has to be constructed before it's get dispatched,
multiline support implemented in shell,
this patch adds support for both multiline and auto-completion
on multiline
https://bugzilla.redhat.com/show_bug.cgi?id=815684
Change-Id: I85688abc7ee104f00ca3bbbb10aa0a90896f9eb6
Signed-off-by: Michael Pasternak <mpastern(a)redhat.com>
---
A src/ovirtcli/prompt.py
M src/ovirtcli/shell/connectcmdshell.py
M src/ovirtcli/shell/disconnectcmdshell.py
M src/ovirtcli/shell/engineshell.py
4 files changed, 105 insertions(+), 10 deletions(-)
Approvals:
Michael Pasternak: Verified; Looks good to me, approved
Ori Liel: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/4361
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I85688abc7ee104f00ca3bbbb10aa0a90896f9eb6
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-cli
Gerrit-Branch: master
Gerrit-Owner: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: api: Changing address to be optional
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: api: Changing address to be optional
......................................................................
api: Changing address to be optional
In order to conform to previous usages of
AddStorageDomain via REST-API, and due to the fact
that NFS is posix FS compliant, the user will be allowed
to use the "Address" and "Path" fields (a mountSpec of
address:path will be passed to VDSM).
However, as mountSpec is not required to have ":"
it will be possible to use path field only.
Change-Id: I52f9c73694952bc7839124e23d74d1b029dc6a6c
Acked-By:
Signed-off-by: Yair Zaslavsk <yzaslavs(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainsResource.java
M backend/manager/modules/restapi/types/src/main/java/org/ovirt/engine/api/restapi/types/StorageDomainMapper.java
2 files changed, 4 insertions(+), 2 deletions(-)
Approvals:
Yair Zaslavsky: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/4422
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I52f9c73694952bc7839124e23d74d1b029dc6a6c
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: Upgrade db from 3.0 to 3.1 fails due to missing suppor...
by emesika@redhat.com
Eli Mesika has submitted this change and it was merged.
Change subject: core: Upgrade db from 3.0 to 3.1 fails due to missing supported_engines
......................................................................
core: Upgrade db from 3.0 to 3.1 fails due to missing supported_engines
Add a supported_engines column to vds_dynamic reolving a 3.0 to 3.1 upgrade issue
This column was probably added to the create_tables.sql and not to the upgrade so
it exists on any 3.1 based DB but is missing from 3.0 based DB that is upgraded to 3.1
Change-Id: I59044a41f6f328daa613e36b5ce5dfb027b52c8f
Signed-off-by: Eli Mesika <emesika(a)redhat.com>
---
M backend/manager/dbscripts/create_tables.sql
M backend/manager/dbscripts/upgrade/pre_upgrade/custom.sql
2 files changed, 6 insertions(+), 1 deletion(-)
Approvals:
Eli Mesika: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/4177
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I59044a41f6f328daa613e36b5ce5dfb027b52c8f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: fix NPE on detach of user from vm pool
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: core: fix NPE on detach of user from vm pool
......................................................................
core: fix NPE on detach of user from vm pool
small fix to a big exception.
use vm sent to the method instead of getVm() which is not set.
Change-Id: I347f84ffceaf3d6f6f9f2b5a00cc9283892251d6
Signed-off-by: Omer Frenkel <ofrenkel(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/DetachUserFromVmFromPoolCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/4368
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I347f84ffceaf3d6f6f9f2b5a00cc9283892251d6
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: Remove JBoss 5 specific login module
by dfediuck@redhat.com
Doron Fediuck has submitted this change and it was merged.
Change subject: core: Remove JBoss 5 specific login module
......................................................................
core: Remove JBoss 5 specific login module
This module is not needed and will not work now that the engine
runs on top of JBoss AS 7.
Change-Id: I215c8bc38f7baa41ec9e40325923d7feae4153a1
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/engineencryptutils/pom.xml
D backend/manager/modules/engineencryptutils/src/main/java/org/ovirt/engine/core/login/EngineSecureIdentityLoginModule.java
M backend/manager/modules/engineencryptutils/src/test/java/org/ovirt/engine/core/engineencryptutils/EncryptionUtilsTest.java
3 files changed, 0 insertions(+), 282 deletions(-)
Approvals:
Doron Fediuck: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/2355
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I215c8bc38f7baa41ec9e40325923d7feae4153a1
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Doron Fediuck <dfediuck(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: Cleanup GetAllAttachableDisksByPoolId
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Cleanup GetAllAttachableDisksByPoolId
......................................................................
core: Cleanup GetAllAttachableDisksByPoolId
Replaced PgSQL "if" with an inline OR statement, for better readability
and maintainability.
Change-Id: I0388390dc638369e9bbe32a571933a85d761f98e
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/dbscripts/all_disks_sp.sql
1 file changed, 5 insertions(+), 10 deletions(-)
Approvals:
Allon Mureinik: Verified
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/4437
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0388390dc638369e9bbe32a571933a85d761f98e
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: Filtering VdsGroupDAO.getAllForStoragePool
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Filtering VdsGroupDAO.getAllForStoragePool
......................................................................
core: Filtering VdsGroupDAO.getAllForStoragePool
Added an (overloaded) filtered verion of
VdsGroupDAO.getAllForStoragePool, to be used by queries in the
User Portal.
This patch includes the postgres implementation, the java DAO that calls
it and a test that proves it functions properly.
Change-Id: I2e1e1063007b57ec3bdaeed0abc832b477f906dc
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/dbscripts/vds_groups_sp.sql
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VdsGroupDAO.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VdsGroupDAODbFacadeImpl.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VdsGroupDAOHibernateImpl.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/VdsGroupDAOTest.java
5 files changed, 73 insertions(+), 6 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, but someone else must approve
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/4365
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2e1e1063007b57ec3bdaeed0abc832b477f906dc
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: Cleanup VdsGroupDAODbFacadeImpl
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Cleanup VdsGroupDAODbFacadeImpl
......................................................................
core: Cleanup VdsGroupDAODbFacadeImpl
Moved row mapper to a static instance as per
http://ovirt.org/wiki/Backend_Coding_Standards.
Change-Id: I54807f9fa1dba40ebed55dfe9e4bf1a656217833
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VdsGroupDAODbFacadeImpl.java
1 file changed, 36 insertions(+), 33 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, but someone else must approve
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/4364
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I54807f9fa1dba40ebed55dfe9e4bf1a656217833
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: Cleanup GetVdsGroupsByStoragePoolIdQuery
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Cleanup GetVdsGroupsByStoragePoolIdQuery
......................................................................
core: Cleanup GetVdsGroupsByStoragePoolIdQuery
General java cleanup: Replaced DbFacade.getInstance() with
getDbFacade(), and replaced * import with a FQCN import.
Change-Id: I5a96b3bec7a42b0f902845e00ff28e8c17600749
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetVdsGroupsByStoragePoolIdQuery.java
1 file changed, 2 insertions(+), 3 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, but someone else must approve
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/4363
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5a96b3bec7a42b0f902845e00ff28e8c17600749
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: GetNextAvailableDiskAliasNameByVM user query
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: GetNextAvailableDiskAliasNameByVM user query
......................................................................
core: GetNextAvailableDiskAliasNameByVM user query
Made GetNextAvailableDiskAliasNameByVMIdQuery a user query so it can be
used in the Power User Portal.
Change-Id: I113115f3e1eff5d08990c7bd8ce6dfc59b145cbe
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetNextAvailableDiskAliasNameByVMIdQuery.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/GetNextAvailableDiskAliasNameByVMIdQueryTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/VdcQueryType.java
3 files changed, 5 insertions(+), 5 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, but someone else must approve
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/4268
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I113115f3e1eff5d08990c7bd8ce6dfc59b145cbe
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 7 months