Change in ovirt-engine[master]: core: Reloadable AutoRecoveryAllowedTypes config
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: core: Reloadable AutoRecoveryAllowedTypes config
......................................................................
core: Reloadable AutoRecoveryAllowedTypes config
Flagged the AutoRecoveryAllowedTypes config value as Reloadable, to
allow changing it in runtime when the Reloadable Configuration feature
is fully supported.
Change-Id: I4ba63a89740aa7f711932734c9cc97b197e8cbd4
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/config/ConfigValues.java
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Yair Zaslavsky: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6918
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4ba63a89740aa7f711932734c9cc97b197e8cbd4
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Muli Salem <msalem(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: comment out tests that depend on powermock
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: core: comment out tests that depend on powermock
......................................................................
core: comment out tests that depend on powermock
There are other tests that needs to be taken care of,
this is a first patch in the series
Change-Id: I9a4433b790ce28da5bfd7861ebb007e9a7bcacb7
Signed-off-by: Yair Zaslavsky <yzaslavs(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/utils/TransactionSupportTest.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AuditLogDirectorTest.java
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/VdsManagerTest.java
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsBrokerObjectBuilderTest.java
4 files changed, 875 insertions(+), 853 deletions(-)
Approvals:
Yair Zaslavsky: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6808
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9a4433b790ce28da5bfd7861ebb007e9a7bcacb7
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: MigrateVmCommand cleanup
by lhornyak@redhat.com
Laszlo Hornyak has submitted this change and it was merged.
Change subject: core: MigrateVmCommand cleanup
......................................................................
core: MigrateVmCommand cleanup
- import java.util
- suppress warning on unused variable in overridden method
Change-Id: I3a8dce43eceb213cb428d25f0cb51eeaf04ee704
Signed-off-by: Laszlo Hornyak <lhornyak(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmCommand.java
1 file changed, 3 insertions(+), 1 deletion(-)
Approvals:
Laszlo Hornyak: Verified; Looks good to me, approved
Allon Mureinik: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/6828
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3a8dce43eceb213cb428d25f0cb51eeaf04ee704
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: engine: Move Gluster host
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: engine: Move Gluster host
......................................................................
engine: Move Gluster host
- Move host vdc command enhanced to support gluster host move between cluster
if cluster supports gluster service.
https://bugzilla.redhat.com/830492
Change-Id: I24bd7d34c2312c34de63371912444c21b2896737
Signed-off-by: Selvasundaram <sesubram(a)redhat.com>
---
A backend/manager/dbscripts/upgrade/03_01_1330_gluster_add_host_event_map.sql
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVdsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ChangeVDSClusterCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveVdsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterCommandBase.java
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/utils/GlusterUtils.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/AuditLogType.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/VdcEventNotificationUtils.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AuditLogDirector.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M backend/manager/modules/dal/src/main/resources/bundles/AuditLogMessages.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/LocalizedEnums.java
M frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/LocalizedEnums.properties
15 files changed, 160 insertions(+), 12 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/5285
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I24bd7d34c2312c34de63371912444c21b2896737
Gerrit-PatchSet: 13
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Selvasundaram <sesubram(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Selvasundaram <sesubram(a)redhat.com>
Gerrit-Reviewer: Shireesh Anjal <sanjal(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: Change audit log sevirity type
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Change audit log sevirity type
......................................................................
core: Change audit log sevirity type
Use warnning instead of normal when audit log
ACTIVATE_STORAGE_DOMAIN_FAILED_ASYNC is being called
Change-Id: I8f29db61e87b806fe23844dddd5056ba3e535007
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/AuditLogDirector.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6389
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8f29db61e87b806fe23844dddd5056ba3e535007
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: webadmin: Make call to backend "more" async (#840388)
by achub@redhat.com
Alexey Chub has submitted this change and it was merged.
Change subject: webadmin: Make call to backend "more" async (#840388)
......................................................................
webadmin: Make call to backend "more" async (#840388)
Change-Id: I12a0b708e61d21b2a6276620d7350e626eb12fd8
Signed-off-by: Alexey Chub <achub(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/Linq.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmSnapshotListModel.java
2 files changed, 45 insertions(+), 23 deletions(-)
Approvals:
Alexey Chub: Verified
Gilad Chaplik: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6899
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I12a0b708e61d21b2a6276620d7350e626eb12fd8
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alexey Chub <achub(a)redhat.com>
Gerrit-Reviewer: Alexey Chub <achub(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: add ability to run shell upgrade steps
by emesika@redhat.com
Eli Mesika has submitted this change and it was merged.
Change subject: core: add ability to run shell upgrade steps
......................................................................
core: add ability to run shell upgrade steps
Up to now, we were able to run only SQL files in upgrade pre_upgrade and
post_upgrade.
This patch adds the ability to add shell scripts as upgrade steps or as
part of the pre/post upgrade.
Shell script files preserve the same naming conventions as regular SQL
upgrade scripts (extension is .sh) and are recorded in the same way to the
schema_version table.
This patch is mandatory to some bugs that requires upgrading the
database via a shell script.
Change-Id: Ia3a88c21c97ebdd9bd35c2b0da87cba1cbde54c7
Signed-off-by: Eli Mesika <emesika(a)redhat.com>
---
M backend/manager/dbscripts/dbfunctions.sh
1 file changed, 30 insertions(+), 9 deletions(-)
Approvals:
Eli Mesika: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6957
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia3a88c21c97ebdd9bd35c2b0da87cba1cbde54c7
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core:Remove multiple columns in group by to use view
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core:Remove multiple columns in group by to use view
......................................................................
core:Remove multiple columns in group by to use view
The following patch removes group by which is used for disks.
The group by is being done to use array for storage for disk, and it is
done on three columns.
Since the view use many columns each time a new column is added we need
to add it to the group by, which cause the views to be large and ugly.
The suggested fix is to use a view specifically for storage which use
those three columns, and use join on it when ever it is used.
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
Change-Id: I273c423009f4718bc527a6155745fda757771303
---
M backend/manager/dbscripts/create_views.sql
1 file changed, 17 insertions(+), 17 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6924
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I273c423009f4718bc527a6155745fda757771303
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: restapi: Allow Pass SD By Name For Disk Creation
by oliel@redhat.com
Ori Liel has submitted this change and it was merged.
Change subject: restapi: Allow Pass SD By Name For Disk Creation
......................................................................
restapi: Allow Pass SD By Name For Disk Creation
Change-Id: Ida6a1bdc83139af945998bb6419ab5dc180bb9ed
Signed-off-by: Ori Liel <oliel(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendDisksResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendVmDisksResource.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/AbstractBackendDisksResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendDisksResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendVmDisksResourceTest.java
5 files changed, 102 insertions(+), 2 deletions(-)
Approvals:
Ori Liel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/6373
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ida6a1bdc83139af945998bb6419ab5dc180bb9ed
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: engine: Replace StringHelper with StringUtils in UpdateSpmHo...
by lhornyak@redhat.com
Laszlo Hornyak has submitted this change and it was merged.
Change subject: engine: Replace StringHelper with StringUtils in UpdateSpmHostNameVDSCommand.
......................................................................
engine: Replace StringHelper with StringUtils in UpdateSpmHostNameVDSCommand.
StringHelper is deprecated.
Change-Id: I41847fc1dc160e8d37682ec4f9419587a6a83ef5
Signed-off-by: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/UpdateSpmHostNameVDSCommand.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Laszlo Hornyak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/5875
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I41847fc1dc160e8d37682ec4f9419587a6a83ef5
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Ryan Harper <ryanh(a)us.ibm.com>
Gerrit-Reviewer: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months