Change in ovirt-engine[master]: engine: Adding gluster volume virt options to configuration
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: engine: Adding gluster volume virt options to configuration
......................................................................
engine: Adding gluster volume virt options to configuration
While optimizing a gluster volume to be used a virt store,
there will be 3 options needs to be set named 'group', 'storage.owner-uid'
and 'storage.owner-gid'.The values for these options will be stored in the configuration.
Default values will be 'group'='virt', 'storage.owner-uid'='36'
and 'storage.owner-gid'='36'.
Here we are representing vdsm uid as 36 and kvm gid as 36,
as these Ids might change in the future, we are keeping them in the configuration.
Change-Id: I4b0bed1fd2d904c7261f547907a1b3ec34c6afcb
Signed-off-by: Kanagaraj M <kmayilsa(a)redhat.com>
---
M backend/manager/dbscripts/upgrade/pre_upgrade/0000_config.sql
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/config/ConfigValues.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/ConfigurationValues.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/volumes/VolumeListModel.java
4 files changed, 81 insertions(+), 12 deletions(-)
Approvals:
Yair Zaslavsky: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7946
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4b0bed1fd2d904c7261f547907a1b3ec34c6afcb
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Shireesh Anjal <sanjal(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: throw canDo if no space for stateless VM snapshots (#8...
by rgolan@redhat.com
Roy Golan has submitted this change and it was merged.
Change subject: core: throw canDo if no space for stateless VM snapshots (#852467)
......................................................................
core: throw canDo if no space for stateless VM snapshots (#852467)
https://bugzilla.redhat.com/852467
For each pluggable disk of stateless VM, check we have enough space to
create a snapshot otherwise throw a canDo.
Change-Id: Ie15cce8ded9172f37be28fd8b3d7b299628ee43e
Signed-off-by: Roy Golan <rgolan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VmRunHandler.java
1 file changed, 49 insertions(+), 0 deletions(-)
Approvals:
Roy Golan: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7929
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie15cce8ded9172f37be28fd8b3d7b299628ee43e
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: webadmin: Adding GlusterStatus to enum translator
by gchaplik@redhat.com
Gilad Chaplik has submitted this change and it was merged.
Change subject: webadmin: Adding GlusterStatus to enum translator
......................................................................
webadmin: Adding GlusterStatus to enum translator
GlusterVolumeStatus and GlusterBricksStatus are refactored
to single enum GlusterStatus. Hence adding translator entry
for it.
Change-Id: Ic57434846edc57f5e75266ec05e4afd96ce9a3f5
Signed-off-by: Kanagaraj M <kmayilsa(a)redhat.com>
---
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/Enums.java
M frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/Enums.properties
2 files changed, 4 insertions(+), 8 deletions(-)
Approvals:
Gilad Chaplik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7843
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic57434846edc57f5e75266ec05e4afd96ce9a3f5
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Shireesh Anjal <sanjal(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: unified code for matching VDS (#855776)
by rgolan@redhat.com
Roy Golan has submitted this change and it was merged.
Change subject: core: unified code for matching VDS (#855776)
......................................................................
core: unified code for matching VDS (#855776)
https://bugzilla.redhat.com/855776
Unified 2 methods which has duplicated code to match a VDS to run VM.
One method was used for canDo and other for execution. The unified code
makes the canDo and Execute be symmetric and easy to log mismatches.
Change-Id: Ic82521368a4f3c3c518c8cf4e5dc460b9e54f381
Signed-off-by: Roy Golan <rgolan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsSelector.java
1 file changed, 38 insertions(+), 35 deletions(-)
Approvals:
Roy Golan: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7921
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic82521368a4f3c3c518c8cf4e5dc460b9e54f381
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Doron Fediuck <dfediuck(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: webadmin: Refactoring Cluster General tab models
by gchaplik@redhat.com
Gilad Chaplik has submitted this change and it was merged.
Change subject: webadmin: Refactoring Cluster General tab models
......................................................................
webadmin: Refactoring Cluster General tab models
The cluster general tab is currently used to show
volume information which is not related to cluster policy.
So a new ClusterGeneralModel is introduced, it will be used
by the Cluster General View and the necessary code refactoring has been done.
Change-Id: I9d9271f34820627333c9eb7f38d1406b01b7d156
Signed-off-by: Kanagaraj M <kmayilsa(a)redhat.com>
---
A frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/clusters/ClusterGeneralModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/clusters/ClusterListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/clusters/ClusterPolicyModel.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/gin/ManagedComponents.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/gin/uicommon/ClusterModule.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/presenter/tab/cluster/SubTabClusterGeneralPresenter.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/tab/cluster/SubTabClusterGeneralView.java
7 files changed, 317 insertions(+), 327 deletions(-)
Approvals:
Gilad Chaplik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7530
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9d9271f34820627333c9eb7f38d1406b01b7d156
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Shireesh Anjal <sanjal(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
12 years, 4 months
Change in ovirt-engine[master]: core: remove unmanaged devices when ...(#846696)
by emesika@redhat.com
Eli Mesika has submitted this change and it was merged.
Change subject: core: remove unmanaged devices when ...(#846696)
......................................................................
core: remove unmanaged devices when ...(#846696)
core: remove unmanaged devices when run-once VM is stopped
https://bugzilla.redhat.com/846696
When a VM that has an attached CD or Floppy is running with run-once a
duplicate unmanaged copy of the CD/Floppy is created.
When running this VM again, both copies of the Cd/Floppy(the original
managed one and the unmanaged one created by the run-once) will be sent
to VDSM causing an exception in libvirt since only one CD/Floppy is
currently supported.
This patch handles removal of managed devices in StopVmCommandBse in the
same manner as stateless VM is handled.
Change-Id: I1a34e93d0c9ef401afdb8eded95782cbf859dda6
Signed-off-by: Eli Mesika <emesika(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/StopVmCommandBase.java
1 file changed, 19 insertions(+), 1 deletion(-)
Approvals:
Eli Mesika: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7947
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1a34e93d0c9ef401afdb8eded95782cbf859dda6
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: add max memory for scheduling VMs as a calculated fiel...
by rgolan@redhat.com
Roy Golan has submitted this change and it was merged.
Change subject: core: add max memory for scheduling VMs as a calculated field to VDS
......................................................................
core: add max memory for scheduling VMs as a calculated field to VDS
This new calculated field is mostly to keep the user informed of the
max amount of memory is free to schedule a new VM. The number reflects
the absolute max which the VM scheduler can't exceed and is subjected to
future scheduling policies, which means the actual number can be lower.
The calculation is:
(getmax_vds_memory_over_commit() * getphysical_mem_mb() / 100.0f) -
(getmem_commited() + getreserved_mem())
Field is added to GUI as Mb and to REST as bytes (traditionally for all
memory fields there)
Change-Id: I8cb338f79682bdc550c4cc6e0667ba1fea50a9c6
Signed-off-by: Roy Golan <rgolan(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VDS.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VdsDAODbFacadeImpl.java
M backend/manager/modules/restapi/interface/definition/src/main/resources/api.xsd
M backend/manager/modules/restapi/types/src/main/java/org/ovirt/engine/api/restapi/types/HostMapper.java
M backend/manager/modules/restapi/types/src/test/java/org/ovirt/engine/api/restapi/types/HostMapperTest.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostGeneralModel.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/ApplicationConstants.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/tab/host/SubTabHostGeneralView.java
8 files changed, 52 insertions(+), 2 deletions(-)
Approvals:
Roy Golan: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7825
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8cb338f79682bdc550c4cc6e0667ba1fea50a9c6
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: core: log flooding if db is down (#854598)
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: core: log flooding if db is down (#854598)
......................................................................
core: log flooding if db is down (#854598)
The following patch relaxes log flooding in case
postgresql DB service is down/inaccessible when
the engine service is started the following way:
a. Fixes the call to sleep between two subsequent calls to
checkDbConnection
b. Increases the interval (I see no point to try and probe
every 1 second).
https://bugzilla.redhat.com/854598
Change-Id: I05680581ff14ac916e4d9d559476dfb4683ed231
Signed-off-by: Yair Zaslavsky <yzaslavs(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/Backend.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/DbFacadeLocator.java
2 files changed, 5 insertions(+), 4 deletions(-)
Approvals:
Yair Zaslavsky: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7928
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I05680581ff14ac916e4d9d559476dfb4683ed231
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 4 months
Change in ovirt-engine[master]: engine: Added new column 'sshKeyFingerprint' in the vds_stat...
by yzaslavs@redhat.com
Yair Zaslavsky has submitted this change and it was merged.
Change subject: engine: Added new column 'sshKeyFingerprint' in the vds_static table
......................................................................
engine: Added new column 'sshKeyFingerprint' in the vds_static table
This fingerprint can be used to verify the server identity during add host.
Done the following changes
- Updated the stored procedures in vds_sp
- Updated the DAO test cases
- Introduced the new member sshKeyFingerprint in the VdsStatic and VDS entities
- Modified view VDS to introduce this new field
- Added entry for the new column in object_column_white_list
Change-Id: I7abe03b62dc15bb135fa02e0a43b763abd8872af
Signed-off-by: Dhandapani <dgopal(a)redhat.com>
---
M backend/manager/dbscripts/create_views.sql
A backend/manager/dbscripts/upgrade/03_01_1380_add_ssh_key_fingerprint_column_to_vds_static.sql
M backend/manager/dbscripts/upgrade/post_upgrade/0010_add_object_column_white_list_table.sql
M backend/manager/dbscripts/vds_sp.sql
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/BusinessEntitiesDefinitions.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VDS.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VdsStatic.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VdsDAODbFacadeImpl.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VdsStaticDAODbFacadeImpl.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/VdsStaticDAOTest.java
M backend/manager/modules/dal/src/test/resources/fixtures.xml
11 files changed, 57 insertions(+), 14 deletions(-)
Approvals:
Dhandapani Gopal: Verified
Yair Zaslavsky: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7171
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7abe03b62dc15bb135fa02e0a43b763abd8872af
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Dhandapani Gopal <dgopal(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Dhandapani Gopal <dgopal(a)redhat.com>
Gerrit-Reviewer: Kanagaraj M <kmayilsa(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Shireesh Anjal <sanjal(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
12 years, 4 months
Change in ovirt-engine[master]: webadmin: Fix message when detaching StorageDomain with floa...
by asaf@redhat.com
Asaf Shakarchi has submitted this change and it was merged.
Change subject: webadmin: Fix message when detaching StorageDomain with floating disks(#848795)
......................................................................
webadmin: Fix message when detaching StorageDomain with floating disks(#848795)
https://bugzilla.redhat.com/848795
Storage Domain may contain only floating disks which are not attached to a VM nor
Template,
The current message:
"Error while executing action: Cannot detach Storage
Domain while VMs/Templates reside on it."
Is inappropriate for the situation described above,
Changed message to:
"Cannot detach a non empty Storage Domain, please remove all VMs /
Templates / Disks and try again".
Change-Id: Ied86df5375bf59f4878764297d395d4a5f29d7d9
Signed-off-by: Asaf Shakarchi <asaf(a)redhat.com>
---
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
4 files changed, 7 insertions(+), 7 deletions(-)
Approvals:
Asaf Shakarchi: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/7883
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ied86df5375bf59f4878764297d395d4a5f29d7d9
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Asaf Shakarchi <asaf(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Asaf Shakarchi <asaf(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
12 years, 4 months