Change in ovirt-engine[master]: core, engine: Get CD interface through osinfo
by rgolan@redhat.com
Roy Golan has submitted this change and it was merged.
Change subject: core, engine: Get CD interface through osinfo
......................................................................
core, engine: Get CD interface through osinfo
This patch allows the specification of the bus used to connect the
virtual CD-ROM (currently either IDE or SCSI). A property to indicate
this was created in the osinfo and the necessary modifications were
made in the VmInfoBuilder class.
Change-Id: I579fdcc0b6bdf7d23bd60efc33fbc4bad1595324
Signed-off-by: Vitor de Lima <vitor.lima(a)eldorado.org.br>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/osinfo/OsRepository.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/OsRepositoryImpl.java
M backend/manager/modules/utils/src/test/java/org/ovirt/engine/core/utils/OsRepositoryImplTest.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VmInfoBuilder.java
M packaging/conf/osinfo-defaults.properties
5 files changed, 41 insertions(+), 9 deletions(-)
Approvals:
Roy Golan: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/20294
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I579fdcc0b6bdf7d23bd60efc33fbc4bad1595324
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vitor de Lima <vitor.lima(a)eldorado.org.br>
Gerrit-Reviewer: Gustavo Frederico Temple Pedrosa <gustavo.pedrosa(a)eldorado.org.br>
Gerrit-Reviewer: Leonardo Bianconi <leonardo.bianconi(a)eldorado.org.br>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Vitor de Lima <vitor.lima(a)eldorado.org.br>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 12 months
Change in ovirt-engine[master]: ui: rename EventsArgs.Empty to EMPTY and make final
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: ui: rename EventsArgs.Empty to EMPTY and make final
......................................................................
ui: rename EventsArgs.Empty to EMPTY and make final
Make it final and rename to be a constant.
Solves 2 findbugs warnings of types:
UWF_UNWRITTEN_PUBLIC_OR_PROTECTED_FIELD
NM_FIELD_NAMING_CONVENTION
Change-Id: Iff1f2de7e8aaaeb7869864d35da1b4892ad807f5
Signed-off-by: Alissa Bonas <abonas(a)redhat.com>
---
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/Frontend.java
M frontend/webadmin/modules/frontend/src/test/java/org/ovirt/engine/ui/frontend/FrontendTest.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/uicommon/AbstractSpice.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/uicommon/TimerImpl.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/dataprovider/AsyncDataProvider.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/CommonModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/EntityModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/ListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/LoginModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/SearchableListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/SystemTreeModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/bookmarks/BookmarkListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/configure/ChangeCDModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/configure/scheduling/NewClusterPolicyModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/events/EventListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/gluster/VolumeBrickListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostGeneralModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostInterfaceListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostSetupNetworksModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/pools/PoolGeneralModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/reports/ReportsListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/NfsStorageModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/SanTargetModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/tags/TagListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/tags/TagModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/templates/TemplateStorageListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/UserPortalBasicListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/UserPortalListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/UserPortalLoginModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/PoolModelBehaviorBase.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmAppListModel.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/Enlistment.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/EventArgs.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/PreparingEnlistment.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/ReversibleFlow.java
35 files changed, 58 insertions(+), 58 deletions(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/22799
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iff1f2de7e8aaaeb7869864d35da1b4892ad807f5
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 12 months
Change in ovirt-engine[master]: core, engine: Architecture dependent commands
by rgolan@redhat.com
Roy Golan has submitted this change and it was merged.
Change subject: core, engine: Architecture dependent commands
......................................................................
core, engine: Architecture dependent commands
This patch introduces a basic set of classes to isolate part of the
code that must behave differently on each supported CPU architecture.
The change #18622 has an example of how it can be used to keep
architecture dependent code maintainable and separated from the rest
of the main logic of each class.
Change-Id: Id930154a05107e94b14710b7e343951b21f00e28
Signed-off-by: Vitor de Lima <vitor.lima(a)eldorado.org.br>
---
A backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/archstrategy/ArchCommand.java
A backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/archstrategy/ArchStrategy.java
A backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/archstrategy/ArchStrategyFactory.java
A backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/archstrategy/PPC64Strategy.java
A backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/archstrategy/X86_64Strategy.java
5 files changed, 74 insertions(+), 0 deletions(-)
Approvals:
Roy Golan: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/21503
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id930154a05107e94b14710b7e343951b21f00e28
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vitor de Lima <vitor.lima(a)eldorado.org.br>
Gerrit-Reviewer: Gustavo Frederico Temple Pedrosa <gustavo.pedrosa(a)eldorado.org.br>
Gerrit-Reviewer: Leonardo Bianconi <leonardo.bianconi(a)eldorado.org.br>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Vitor de Lima <vitor.lima(a)eldorado.org.br>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 12 months
Change in ovirt-reports[master]: reports: fixed br18 known vs unknown os detection
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: reports: fixed br18 known vs unknown os detection
......................................................................
reports: fixed br18 known vs unknown os detection
Change-Id: I00ae4b98bd1469211b16d5170405b4a5dd24ede9
Bug-Url: https://bugzilla.redhat.com/1031612
Signed-off-by: Yaniv Dary <ydary(a)redhat.com>
---
M reports/repository_files/resources/Reports/Executive/active_vms_by_os_br18_files/active_vms_by_os_br18_jrxml.data
1 file changed, 17 insertions(+), 17 deletions(-)
Approvals:
Yaniv Dary: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/22820
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I00ae4b98bd1469211b16d5170405b4a5dd24ede9
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
10 years, 12 months
Change in ovirt-engine[master]: webadmin: fix findbugs warning on ProviderModel
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: webadmin: fix findbugs warning on ProviderModel
......................................................................
webadmin: fix findbugs warning on ProviderModel
This patch fixes a findbugs warning in ProviderModel, as we case a
variable that's known to be null.
The fix just passes null, and in order to be able to address the
ambiguity, the method name was renamed according to the use-case.
Change-Id: I94c5ff1cde5c76a89ea0c56022e306a264905066
Signed-off-by: Oved Ourfali <oourfali(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/providers/ProviderModel.java
1 file changed, 1 insertion(+), 15 deletions(-)
Approvals:
Oved Ourfali: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/22805
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I94c5ff1cde5c76a89ea0c56022e306a264905066
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 12 months
Change in ovirt-engine[master]: ui: exclude a findbugs warning in AsyncQuery
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: ui: exclude a findbugs warning in AsyncQuery
......................................................................
ui: exclude a findbugs warning in AsyncQuery
Warning of type UWF_NULL_FIELD was produced on converterCallback
field, though it is initialized by other classes, hence it's a false
warning.
Change-Id: I562f96123aea747c76e37fabde0a51fdd36dbbbb
Signed-off-by: Alissa Bonas <abonas(a)redhat.com>
---
M frontend/webadmin/modules/frontend/exclude-filters.xml
1 file changed, 6 insertions(+), 0 deletions(-)
Approvals:
Alissa Bonas: Verified
Oved Ourfali: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/22808
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I562f96123aea747c76e37fabde0a51fdd36dbbbb
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 12 months
Change in ovirt-engine[master]: ui: fix findbugs exclude filter.
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: ui: fix findbugs exclude filter.
......................................................................
ui: fix findbugs exclude filter.
The numbering of anonymous classes changed
due to a refactoring, and hence the exclude filter
didn't mask the warnings properly.
Change-Id: If96b5a6214dcefe47fae37fd7c1ccdd364166e33
Signed-off-by: Alissa Bonas <abonas(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/exclude-filters.xml
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Oved Ourfali: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/22791
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If96b5a6214dcefe47fae37fd7c1ccdd364166e33
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 12 months
Change in ovirt-engine[master]: ui: rename member to start with lowercase in ProvideProperty...
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: ui: rename member to start with lowercase in ProvidePropertyChangedEvent
......................................................................
ui: rename member to start with lowercase in ProvidePropertyChangedEvent
Change-Id: If06684743e7563bd39fdfa86ba853b9cd903894a
Signed-off-by: Alissa Bonas <abonas(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/EntityModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/ListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/Model.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostInterfaceListModel.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/ProvidePropertyChangedEvent.java
5 files changed, 6 insertions(+), 6 deletions(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/22790
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If06684743e7563bd39fdfa86ba853b9cd903894a
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 12 months
Change in ovirt-engine[master]: ui: rename members to start with lowercase
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: ui: rename members to start with lowercase
......................................................................
ui: rename members to start with lowercase
Change-Id: I361a44bf1f418a78ee7679bae6083dcfae70830e
Signed-off-by: Alissa Bonas <abonas(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/AsyncIteratorCallback.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/ReversibleFlow.java
2 files changed, 6 insertions(+), 6 deletions(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/22759
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I361a44bf1f418a78ee7679bae6083dcfae70830e
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 12 months
Change in ovirt-engine[master]: ui: rename members to start with lowercase in *Model classes
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: ui: rename members to start with lowercase in *Model classes
......................................................................
ui: rename members to start with lowercase in *Model classes
Solves findbugs warnings.
Change-Id: I6f2f8d44e3d210f3ae7d39cac3515314a2632ac6
Signed-off-by: Alissa Bonas <abonas(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/UserPortalBasicListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/UserPortalListModel.java
2 files changed, 6 insertions(+), 6 deletions(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/22758
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6f2f8d44e3d210f3ae7d39cac3515314a2632ac6
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 12 months