Change in ovirt-engine[ovirt-engine-3.5]: aaa: Fix UserGroups list model
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: aaa: Fix UserGroups list model
......................................................................
aaa: Fix UserGroups list model
The previous code populated the groups sub tab of users
by using information from the user entity (namespace and
group names), but the namespace may vary between user
and the groups it belongs to
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1120720
Change-Id: I39387d68687d530008a2114057d30fc04f27f0ce
Signed-off-by: Yair Zaslavsky <yzaslavs(a)redhat.com>
---
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetDbGroupsByUserIdQuery.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/VdcQueryType.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/DbGroupDAO.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/DbGroupDAODbFacadeImpl.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/dataprovider/AsyncDataProvider.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/users/UserGroupListModel.java
M packaging/dbscripts/ad_groups_sp.sql
7 files changed, 72 insertions(+), 7 deletions(-)
Approvals:
Alon Bar-Lev: Verified
Yair Zaslavsky: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/34105
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I39387d68687d530008a2114057d30fc04f27f0ce
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[ovirt-engine-3.5]: aaa: remove group should not depend on existence of provider
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: aaa: remove group should not depend on existence of provider
......................................................................
aaa: remove group should not depend on existence of provider
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1120720
Change-Id: Idd8a5a35816a530dbb7405eedefe4936b7e91c4f
Topic: AAA
Signed-off-by: Yair Zaslavsky <yzaslavs(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/aaa/AdGroupsHandlingCommandBase.java
M backend/manager/modules/dal/src/main/resources/bundles/AuditLogMessages.properties
2 files changed, 19 insertions(+), 40 deletions(-)
Approvals:
Alon Bar-Lev: Verified
Yair Zaslavsky: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/34104
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idd8a5a35816a530dbb7405eedefe4936b7e91c4f
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[ovirt-engine-3.5]: core: dont copy old num of sockets on hotplug
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: dont copy old num of sockets on hotplug
......................................................................
core: dont copy old num of sockets on hotplug
when editing running vm, all fields that are not editable, are copied
from the old vm to new vm, as they are saved in the running snapshot,
and db reflect the actual running config.
when user select to do hot-set to cpu, the number of sockets should not
be copied with the old value, as it is used in the hot-set command.
this is fixed by sending to the copy method, if this is a hot-set flow,
and it will check it when doing copy of the old value, for hot-set allowed fields.
Change-Id: I57bcd2287350c3146f06fe2a5c9a583c88dded04
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1151827
Signed-off-by: Omer Frenkel <ofrenkel(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VmHandler.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ObjectIdentityChecker.java
3 files changed, 19 insertions(+), 8 deletions(-)
Approvals:
Omer Frenkel: Verified
Arik Hadas: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/34084
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I57bcd2287350c3146f06fe2a5c9a583c88dded04
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[ovirt-engine-3.5]: restapi: Add ballooning to RSDL metadata
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: restapi: Add ballooning to RSDL metadata
......................................................................
restapi: Add ballooning to RSDL metadata
This patch adds the documentation of the ballooning parameter to the
RSDL metadata.
Change-Id: Idc73af8bc7b2dc74196f247f464dd31622b8797d
Bug-Url: https://bugzilla.redhat.com/1149188
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
(cherry picked from commit 62ca41b21207496f8d1b7f7cbbbd8eca1da61caa)
---
M backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata.yaml
1 file changed, 4 insertions(+), 0 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Gilad Chaplik: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/34064
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idc73af8bc7b2dc74196f247f464dd31622b8797d
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 2 months
Change in ovirt-engine[master]: webadmin: Fix alignment issues in Cluster Detail popup
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: webadmin: Fix alignment issues in Cluster Detail popup
......................................................................
webadmin: Fix alignment issues in Cluster Detail popup
Fixes alignment issues in Cluster Detail popup caused by the length of
text in French translation.
Change-Id: I34048f9485bffe2066e527e710bf9f3eff687e07
Bug-Url: https://bugzilla.redhat.com/1150599
Signed-off-by: Martin Perina <mperina(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/cluster/ClusterPopupView.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tomas Jelinek: Looks good to me, approved
Martin Peřina: Verified
--
To view, visit http://gerrit.ovirt.org/34035
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I34048f9485bffe2066e527e710bf9f3eff687e07
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[master]: core: revert xmlrpc fallback
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core: revert xmlrpc fallback
......................................................................
core: revert xmlrpc fallback
Previous commit (Change-Id: Ie6f48bec60b520c089f326f8c5e79aec288ff3d6)
introduced a fallback mechanism to support getting
the proper non-operational reason when adding old hosts to 3.5 cluster.
I encountered some issues with the fix, so reverting the Install logic
until further examination.
Change-Id: Ib45a6e828e459f982c0c77ca778f2b83e97a881b
Signed-off-by: Oved Ourfali <oourfali(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/InstallVdsInternalCommand.java
1 file changed, 0 insertions(+), 20 deletions(-)
Approvals:
Oved Ourfali: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/34117
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib45a6e828e459f982c0c77ca778f2b83e97a881b
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 2 months
Change in ovirt-engine[master]: frontend: do not use AddVmFromScratch
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: frontend: do not use AddVmFromScratch
......................................................................
frontend: do not use AddVmFromScratch
The UI doesn't provide disks to the AddVmFromScratch command so it
should use AddVm instead.
Change-Id: Ibd7f9cf4e6a9bcb2b336b34c785c09221068a915
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/UserPortalListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmListModel.java
2 files changed, 54 insertions(+), 116 deletions(-)
Approvals:
Tomas Jelinek: Looks good to me, approved
Arik Hadas: Verified
--
To view, visit http://gerrit.ovirt.org/33142
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibd7f9cf4e6a9bcb2b336b34c785c09221068a915
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[master]: userportal: cleanup - extract method
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: userportal: cleanup - extract method
......................................................................
userportal: cleanup - extract method
Extract the code that adds new VM to separate method:
UserPortalListModel#saveNewVm.
Change-Id: Ia28f695d93d0e26858b140e172fe5b4267b5bbf7
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/UserPortalListModel.java
1 file changed, 44 insertions(+), 44 deletions(-)
Approvals:
Tomas Jelinek: Looks good to me, approved
Arik Hadas: Verified
--
To view, visit http://gerrit.ovirt.org/33147
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia28f695d93d0e26858b140e172fe5b4267b5bbf7
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine[master]: frontend: remove unneeded query for template's disks
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: frontend: remove unneeded query for template's disks
......................................................................
frontend: remove unneeded query for template's disks
Change-Id: Ib4e29db112befaf2fdbeef18e3971c71f159840c
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/userportal/UserPortalListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmListModel.java
2 files changed, 21 insertions(+), 45 deletions(-)
Approvals:
Tomas Jelinek: Looks good to me, approved
Arik Hadas: Verified
--
To view, visit http://gerrit.ovirt.org/33145
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib4e29db112befaf2fdbeef18e3971c71f159840c
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 2 months
Change in ovirt-engine-cli[master]: cli: Add support for Kerberos authentication
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: cli: Add support for Kerberos authentication
......................................................................
cli: Add support for Kerberos authentication
This patch adds a --kerberos option that enables Kerberos
authentication.
Change-Id: I973db40adec102da95bb605cb7db6e7854ee4343
Bug-Url: https://bugzilla.redhat.com/1145239
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M src/cli/context.py
M src/ovirtcli/command/connect.py
M src/ovirtcli/infrastructure/context.py
M src/ovirtcli/infrastructure/options.py
M src/ovirtcli/infrastructure/settings.py
M src/ovirtcli/shell/connectcmdshell.py
6 files changed, 40 insertions(+), 24 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/33417
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I973db40adec102da95bb605cb7db6e7854ee4343
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine-cli
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mishka8520(a)yahoo.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 2 months