Change in ovirt-node-plugin-vdsm[master]: packaging: add version information
by dougsland@redhat.com
Douglas Schilling Landgraf has submitted this change and it was merged.
Change subject: packaging: add version information
......................................................................
packaging: add version information
add /etc/default/version.$(PACKAGE) as:
PACKAGE=@PACKAGE_NAME@
VERSION=@PACKAGE_RPM_VERSION@
RELEASE=@PACKAGE_RPM_RELEASE@
to enable software to detect plugin version while running on node.
Change-Id: I3743ef37e804137e2a3517180a67c5fb1a6cecbc
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M .gitignore
M Makefile.am
M configure.ac
M ovirt-node-plugin-vdsm.spec.in
A version.ovirt-node-plugin-vdsm.in
5 files changed, 24 insertions(+), 5 deletions(-)
Approvals:
Douglas Schilling Landgraf: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/29562
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3743ef37e804137e2a3517180a67c5fb1a6cecbc
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-node-plugin-vdsm
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Fabian Deutsch <fabiand(a)fedoraproject.org>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: userportal, webadmin: fixed badly formed multi-line values.
by lvernia@redhat.com
Lior Vernia has submitted this change and it was merged.
Change subject: userportal, webadmin: fixed badly formed multi-line values.
......................................................................
userportal, webadmin: fixed badly formed multi-line values.
few multi-line values were invalid, which caused that only
substring was presented to the user.
Bug-Url: https://bugzilla.redhat.com/1075509
Change-Id: I58f14efbc29ea7a8ba9f741175b17a62ee320f86
Signed-off-by: Martin Mucha <mmucha(a)redhat.com>
---
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
3 files changed, 4 insertions(+), 9 deletions(-)
Approvals:
Lior Vernia: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/25657
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I58f14efbc29ea7a8ba9f741175b17a62ee320f86
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Einav Cohen <ecohen(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: restapi: Support generic types for "add"
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Support generic types for "add"
......................................................................
restapi: Support generic types for "add"
Currently the RSDL builder doesn't support generic types as parameters
to the "add" operation. As a result the generation of the Java SDK
doesn't work correctly.
Change-Id: I60d4b44c183eaaa4a42737382bcc6ad33a5ff989
Bug-Url: https://bugzilla.redhat.com/1115610
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/interface/definition/src/main/java/org/ovirt/engine/api/rsdl/RsdlBuilder.java
1 file changed, 36 insertions(+), 23 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Gilad Chaplik: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/29527
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I60d4b44c183eaaa4a42737382bcc6ad33a5ff989
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: core: use updated storage allocation validation
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: use updated storage allocation validation
......................................................................
core: use updated storage allocation validation
StorageDomainValidator.hasSpaceForClonedDisks() was introduced to the
system in commit 53b5eba699a695edc5b2e963e28b43ea5290b299 in order to
align all storage allocation checks throughout the system. This patch
applies above validation instead of the existing one
LiveMigrateVmDisksCommand.
Change-Id: I886967b7c2dadbbd301eadbea0c7eac9992aba08
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/lsm/LiveMigrateVmDisksCommand.java
1 file changed, 8 insertions(+), 5 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/28945
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I886967b7c2dadbbd301eadbea0c7eac9992aba08
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: core: LSM without context
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: LSM without context
......................................................................
core: LSM without context
LiveMigrateVmDisksCommand did not have a c'tor without CommandContext,
which made it impossible to use LSM.
Change-Id: I55ac1cc3b234a56a5d269ab4ebaeac528a3190de
Bug-Url: http://bugzilla.redhat.com/1116031
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/lsm/LiveMigrateVmDisksCommand.java
1 file changed, 4 insertions(+), 0 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/29507
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I55ac1cc3b234a56a5d269ab4ebaeac528a3190de
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: core: simplify isSameSourceAndDest
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: simplify isSameSourceAndDest
......................................................................
core: simplify isSameSourceAndDest
Simplified LiveMigrateVmDisksCommand.isSameSourceAndDest() 's implementation.
Change-Id: Ie5c32734d517f27230efd7ea67d4841d55d2c8ec
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/lsm/LiveMigrateVmDisksCommand.java
1 file changed, 1 insertion(+), 3 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/28964
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie5c32734d517f27230efd7ea67d4841d55d2c8ec
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: core: changed method call for readability
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: changed method call for readability
......................................................................
core: changed method call for readability
In LiveMigrateVmDisksCommand, changed calls to parameters.getStorageDomainId
to paramaters.getTargetStorageDomainId for readability.
The latter's impelementation only calls the former.
Change-Id: Id1c95635d602094a7d5babb532f4e79038c43039
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/lsm/LiveMigrateVmDisksCommand.java
1 file changed, 6 insertions(+), 6 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/28963
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id1c95635d602094a7d5babb532f4e79038c43039
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: core: AddLSM source sd allocation validation
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AddLSM source sd allocation validation
......................................................................
core: AddLSM source sd allocation validation
In LiveMigrateVmDisksCommand - added space allocation validation in the
source domains. A snapshot is taken on the source domain before actual migration.
Therefore source domains should have enough space for a new active image,
a fact verified by this patch.
Also changed relevant error message to not contain the word "target" to
suggest target storage domain since the same validation message is set for both
source and target storage domains. Note the message includes the name of
the specific storage domain, so this should do.
Change-Id: I1914f5efe50d2f5a4fb9debf0c0bde4ffc9e32eb
Bug-Url: https://bugzilla.redhat.com/1099894
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/lsm/LiveMigrateVmDisksCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/StorageDomainValidator.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AddDiskToVmCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AddVmCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AddVmFromSnapshotCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AddVmFromTemplateCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AddVmPoolWithVmsCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/CreateAllSnapshotsFromVmCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ImportVmCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ImportVmTemplateCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/MoveOrCopyDiskCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/lsm/LiveMigrateVmDisksCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/validator/MultipleStorageDomainsValidatorTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/validator/StorageDomainValidatorTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/VdcBllMessages.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
19 files changed, 65 insertions(+), 39 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/28961
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1914f5efe50d2f5a4fb9debf0c0bde4ffc9e32eb
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: webadmin: Add the option to create Posix/Gluster export domains
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Add the option to create Posix/Gluster export domains
......................................................................
webadmin: Add the option to create Posix/Gluster export domains
In the new storage domain dialog, added the option to add a Posix export
domain and a Gluster export domain
Change-Id: I4f39ed43026292011ae000f30806e02db9468d99
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
Bug-Url: https://bugzilla.redhat.com/1065963
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/dataprovider/AsyncDataProvider.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageListModel.java
2 files changed, 18 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Verified
Daniel Erez: Looks good to me, approved
Allon Mureinik: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/29408
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4f39ed43026292011ae000f30806e02db9468d99
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months
Change in ovirt-engine[master]: ui: Adding base class for external entity objects
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: ui: Adding base class for external entity objects
......................................................................
ui: Adding base class for external entity objects
Change-Id: Ieedfa9efcd062c3a4a41250fee0a8b1a22844ff6
Signed-off-by: Yaniv Bronhaim <ybronhei(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/ExternalComputeResource.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/ExternalDiscoveredHost.java
A backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/ExternalEntityBase.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/ExternalHostGroup.java
M frontend/webadmin/modules/gwt-common/src/main/resources/org/ovirt/engine/core/Common.gwt.xml
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostModel.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/host/HostPopupView.java
7 files changed, 68 insertions(+), 94 deletions(-)
Approvals:
Yaniv Bronhaim: Verified
Daniel Erez: Looks good to me, but someone else must approve
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/29372
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ieedfa9efcd062c3a4a41250fee0a8b1a22844ff6
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yaniv Bronhaim <ybronhei(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: Yaniv Bronhaim <ybronhei(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 5 months