Change in ovirt-engine[master]: webadmin: RM useless TaskListModel#removeSingleTask
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: RM useless TaskListModel#removeSingleTask
......................................................................
webadmin: RM useless TaskListModel#removeSingleTask
Change-Id: I7008882821d2e28b35e7f1bb53b211850604baa3
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/events/TaskListModel.java
1 file changed, 0 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52319
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7008882821d2e28b35e7f1bb53b211850604baa3
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: webadmin: Remove redundant initializer
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: Remove redundant initializer
......................................................................
webadmin: Remove redundant initializer
Change-Id: Icb13baaa6eb64f9d44b17d867ef858152d56f2db
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/events/TaskListModel.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52318
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Icb13baaa6eb64f9d44b17d867ef858152d56f2db
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: MarshalingTestCase static access
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: MarshalingTestCase static access
......................................................................
core: MarshalingTestCase static access
Use HashMap.class instead of new HashMap<>().getClass() to save the
redundant creation of a HashMap instance.
Change-Id: Ic86667e5b7aa5f7002e2b45ac27daf33e4b34ede
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/jsonrpc/MarshallingTestCase.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52302
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic86667e5b7aa5f7002e2b45ac27daf33e4b34ede
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: IsoDomainListSyncronizer#refreshVdsmFileList reference
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: IsoDomainListSyncronizer#refreshVdsmFileList reference
......................................................................
core: IsoDomainListSyncronizer#refreshVdsmFileList reference
Used a Java 8 style method reference instead of an anonymous
implementation to improve the code's readability.
Change-Id: Iae7da33a9bf3bda7587132c544e2cc83625fe809
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/IsoDomainListSyncronizer.java
1 file changed, 1 insertion(+), 7 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52299
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iae7da33a9bf3bda7587132c544e2cc83625fe809
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: webadmin: InternalNetworksPanel boolean logic
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: InternalNetworksPanel boolean logic
......................................................................
webadmin: InternalNetworksPanel boolean logic
Simplified boolean logic to make the code more readable.
Change-Id: I926e04836874ba5741ca00e7e2d33c9bc8b3ccdf
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/host/panels/InternalNetworksPanel.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52298
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I926e04836874ba5741ca00e7e2d33c9bc8b3ccdf
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: webadmin: ImportVmsModel null check
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: ImportVmsModel null check
......................................................................
webadmin: ImportVmsModel null check
Removed redundant null check - dataCenters is initialized at the
beginning of the method with the new operator and not overwritten in any
path. It can never be null.
Change-Id: Ibf59d2d76263cc9d9ad2c2a4ef12323f3b2464b0
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/ImportVmsModel.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52297
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibf59d2d76263cc9d9ad2c2a4ef12323f3b2464b0
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: webadmin: ImportVmFromExternalProviderPopupView static access
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: ImportVmFromExternalProviderPopupView static access
......................................................................
webadmin: ImportVmFromExternalProviderPopupView static access
Access static members via the class reference, not an instance, as per
Java's best practices.
Change-Id: If46dd857e3eb427bca025582b9a42bab82e4c463
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/vm/ImportVmFromExternalProviderPopupView.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52296
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If46dd857e3eb427bca025582b9a42bab82e4c463
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: webadmin: rm ImportVmFromExternalProviderPopupView unused field
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: rm ImportVmFromExternalProviderPopupView unused field
......................................................................
webadmin: rm ImportVmFromExternalProviderPopupView unused field
Change-Id: I50bc4c4f482d2a4c70a3c9d43a2d570df16be3d4
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/vm/ImportVmFromExternalProviderPopupView.java
1 file changed, 0 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, but someone else must approve
Alexander Wels: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52295
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I50bc4c4f482d2a4c70a3c9d43a2d570df16be3d4
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: webadmin: ImportVmFromExportDomainPopupView double comment
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: ImportVmFromExportDomainPopupView double comment
......................................................................
webadmin: ImportVmFromExportDomainPopupView double comment
Replace doubly commented comments (////) with regular comments (//).
Change-Id: Ib0931e91e04cf2bfe10c28e96fb851b83b176871
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/storage/backup/ImportVmFromExportDomainPopupView.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52294
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib0931e91e04cf2bfe10c28e96fb851b83b176871
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: MarshallingTestCase exceptions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: MarshallingTestCase exceptions
......................................................................
core: MarshallingTestCase exceptions
Changed all test methods to just throw Exception - there's no need for
this bravity in a test case, and it in facts makes the code harder to
understand.
Change-Id: I4db0668962c822d6a77341914a2249ecdbefb158
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/jsonrpc/MarshallingTestCase.java
1 file changed, 13 insertions(+), 34 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/52301
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4db0668962c822d6a77341914a2249ecdbefb158
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months