Change in ovirt-reports[master]: build: build reports for 3.6.2.3
by sradco@redhat.com
Shirly Radco has submitted this change and it was merged.
Change subject: build: build reports for 3.6.2.3
......................................................................
build: build reports for 3.6.2.3
Change-Id: If5d086e95f39e1313165d228061c3b2d9c1a4b5b
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M ovirt-engine-reports.spec.in
M version.mak
2 files changed, 7 insertions(+), 3 deletions(-)
Approvals:
Shirly Radco: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/51699
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If5d086e95f39e1313165d228061c3b2d9c1a4b5b
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: rename saveVmsToDb to flush
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: rename saveVmsToDb to flush
......................................................................
core: rename saveVmsToDb to flush
Rename VmsMonitoring#saveVmsToDb to flush and extract
the call to addUnmanagedVms from it since it is not
really part of the flush into the database.
Change-Id: I0e4380ecaeb1d4ae039ae1af500ee4d245389692
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VmsMonitoring.java
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Arik Hadas: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/51691
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0e4380ecaeb1d4ae039ae1af500ee4d245389692
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: replace fields with variables in vms-monitoring
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: replace fields with variables in vms-monitoring
......................................................................
core: replace fields with variables in vms-monitoring
The collections of identifiers of highly available VMs to
rerun and those that were shut down as part of cold reboot
and need to run are used only within one method. Therefore
changing them from fields in VmsMonitoring class to
variable in the afterVMsRefreshTreatment.
Change-Id: Ib3300823b5d5ecb1f99b62034e201f1764801e06
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VmsMonitoring.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Shahar Havivi: Looks good to me, approved
Jenkins CI: Passed CI tests
Arik Hadas: Verified
--
To view, visit https://gerrit.ovirt.org/51690
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib3300823b5d5ecb1f99b62034e201f1764801e06
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[master]: core: hosted-engine: Lock the sd import exclusively
by rgolan@redhat.com
Roy Golan has submitted this change and it was merged.
Change subject: core: hosted-engine: Lock the sd import exclusively
......................................................................
core: hosted-engine: Lock the sd import exclusively
Add an exclusive lock on the hosted engine domain import to prevent it
from interleaving. There is a race where the domain might be added but
the TX isn't closed yet and another import can enter and pass the
command validation.
Small clean-up made to remove the redundant getBackend() and
runVdsCommand(..) methods.
Change-Id: I2b67db78433f3c0847e118ccb279d63a65986b34
Bug-Url: https://bugzilla.redhat.com/1293928
Bug-Url: https://bugzilla.redhat.com/1290518
Signed-off-by: Roy Golan <rgolan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/AddExistingBlockStorageDomainCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/AddExistingFileStorageDomainCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/AddNFSStorageDomainCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/AddStorageDomainCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/AddStorageDomainCommon.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/ImportHostedEngineStorageDomainCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/StorageDomainManagementCommandBase.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/domain/ImportHostedEngineStorageDomainCommandTest.java
8 files changed, 143 insertions(+), 58 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Roy Golan: Verified
Maor Lipchuk: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/51033
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2b67db78433f3c0847e118ccb279d63a65986b34
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[ovirt-engine-3.6.2]: build: post ovirt-engine-3.6.2.5
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: build: post ovirt-engine-3.6.2.5
......................................................................
build: post ovirt-engine-3.6.2.5
Change-Id: Ie95eab63afa8e06beba580b254bea53b5cbe8b11
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M automation/build-artifacts.sh
M backend/manager/dependencies/common/pom.xml
M backend/manager/dependencies/pom.xml
M backend/manager/dependencies/tools/pom.xml
M backend/manager/extensions-tool/pom.xml
M backend/manager/modules/aaa/pom.xml
M backend/manager/modules/auth-plugin/pom.xml
M backend/manager/modules/bll/pom.xml
M backend/manager/modules/branding/pom.xml
M backend/manager/modules/builtin-extensions/pom.xml
M backend/manager/modules/common/pom.xml
M backend/manager/modules/compat/pom.xml
M backend/manager/modules/dal/pom.xml
M backend/manager/modules/docs/pom.xml
M backend/manager/modules/extensions-api-root/extensions-api/pom.xml
M backend/manager/modules/extensions-api-root/pom.xml
M backend/manager/modules/extensions-manager/pom.xml
M backend/manager/modules/logger/pom.xml
M backend/manager/modules/pom.xml
M backend/manager/modules/restapi/interface/common/jaxrs/pom.xml
M backend/manager/modules/restapi/interface/common/pom.xml
M backend/manager/modules/restapi/interface/definition/pom.xml
M backend/manager/modules/restapi/interface/pom.xml
M backend/manager/modules/restapi/jaxrs/pom.xml
M backend/manager/modules/restapi/pom.xml
M backend/manager/modules/restapi/types/pom.xml
M backend/manager/modules/restapi/webapp/pom.xml
M backend/manager/modules/root/pom.xml
M backend/manager/modules/scheduler/pom.xml
M backend/manager/modules/searchbackend/pom.xml
M backend/manager/modules/services/pom.xml
M backend/manager/modules/utils/pom.xml
M backend/manager/modules/uutils/pom.xml
M backend/manager/modules/vdsbroker/pom.xml
M backend/manager/modules/welcome/pom.xml
M backend/manager/pom.xml
M backend/manager/tools/pom.xml
M backend/pom.xml
M build-tools-root/checkstyles/pom.xml
M build-tools-root/jboss-modules-maven-plugin/pom.xml
M build-tools-root/ovirt-checkstyle-extension/pom.xml
M build-tools-root/pom.xml
M build/validations/pom.xml
M ear/pom.xml
M frontend/pom.xml
M frontend/webadmin/modules/frontend-symbols/pom.xml
M frontend/webadmin/modules/frontend/pom.xml
M frontend/webadmin/modules/gwt-common/pom.xml
M frontend/webadmin/modules/gwt-extension/pom.xml
M frontend/webadmin/modules/pom.xml
M frontend/webadmin/modules/uicommonweb/pom.xml
M frontend/webadmin/modules/uicompat/pom.xml
M frontend/webadmin/modules/userportal-gwtp/pom.xml
M frontend/webadmin/modules/webadmin/pom.xml
M frontend/webadmin/pom.xml
M mavenmake/pom.xml
M pom.xml
M version.mak
58 files changed, 65 insertions(+), 62 deletions(-)
Approvals:
Tal Nisan: Passed CI tests
Sandro Bonazzola: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/51687
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie95eab63afa8e06beba580b254bea53b5cbe8b11
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.2
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
8 years, 11 months
Change in ovirt-engine[ovirt-engine-3.6.2]: webadmin: 'passthrough' checkbox must be disabled for clust...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: 'passthrough' checkbox must be disabled for clusters less than 3.6
......................................................................
webadmin: 'passthrough' checkbox must be disabled for clusters less than 3.6
In UI, for clusters less than 3.6 - sriov checkboxes(passthrough) should be disabled
in the vNIC profile dialog and shouldn't appear in the vNICs type list(pci-passthrough)
Change-Id: Ia8ba807900f15410f3ab43831b5cf965621dd0ef
Bug-Url: https://bugzilla.redhat.com/1282441
Signed-off-by: Marcin Mirecki <mmirecki(a)redhat.com>
Signed-off-by: Alona Kaplan <alkaplan(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/profiles/VnicProfileModel.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/UIMessages.java
2 files changed, 18 insertions(+), 1 deletion(-)
Approvals:
Alona Kaplan: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/51663
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia8ba807900f15410f3ab43831b5cf965621dd0ef
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.2
Gerrit-Owner: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Marcin Mirecki <mmirecki(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
8 years, 11 months
Change in ovirt-engine[ovirt-engine-3.6]: webadmin: 'passthrough' checkbox must be disabled for clust...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: 'passthrough' checkbox must be disabled for clusters less than 3.6
......................................................................
webadmin: 'passthrough' checkbox must be disabled for clusters less than 3.6
In UI, for clusters less than 3.6 - sriov checkboxes(passthrough) should be disabled
in the vNIC profile dialog and shouldn't appear in the vNICs type list(pci-passthrough)
Change-Id: Ia8ba807900f15410f3ab43831b5cf965621dd0ef
Bug-Url: https://bugzilla.redhat.com/1282441
Signed-off-by: Marcin Mirecki <mmirecki(a)redhat.com>
Signed-off-by: Alona Kaplan <alkaplan(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/profiles/VnicProfileModel.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/UIMessages.java
2 files changed, 18 insertions(+), 1 deletion(-)
Approvals:
Alona Kaplan: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/51661
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia8ba807900f15410f3ab43831b5cf965621dd0ef
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Marcin Mirecki <mmirecki(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[ovirt-engine-3.6.2]: network:fix invalid regexp syntax
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: network:fix invalid regexp syntax
......................................................................
network:fix invalid regexp syntax
Change-Id: Id3f0c2cb02854017de734c1197d4fc2c2c0712e4
Bug-Url: https://bugzilla.redhat.com/1286132
Bug-Url: https://bugzilla.redhat.com/1297701
Signed-off-by: emesika <emesika(a)redhat.com>
---
M packaging/dbscripts/upgrade/03_06_1980_fix_invalid_macs.sql
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Alona Kaplan: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/51694
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id3f0c2cb02854017de734c1197d4fc2c2c0712e4
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.2
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine[ovirt-engine-3.6]: network:fix invalid regexp syntax
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: network:fix invalid regexp syntax
......................................................................
network:fix invalid regexp syntax
Change-Id: Id3f0c2cb02854017de734c1197d4fc2c2c0712e4
Bug-Url: https://bugzilla.redhat.com/1286132
Bug-Url: https://bugzilla.redhat.com/1297701
Signed-off-by: emesika <emesika(a)redhat.com>
---
M packaging/dbscripts/upgrade/03_06_1980_fix_invalid_macs.sql
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Eli Mesika: Verified
Alona Kaplan: Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/51693
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id3f0c2cb02854017de734c1197d4fc2c2c0712e4
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months
Change in ovirt-engine-sdk[sdk_3.6]: sdk: Prepare for next development iteration
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: sdk: Prepare for next development iteration
......................................................................
sdk: Prepare for next development iteration
In preparation for the next development iteration this patch increases
the version number and sets the RPM relase number to 0.1.
Change-Id: I0970d2cec0182f577e02f76229c906a953092638
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M Makefile
M setup.py
2 files changed, 3 insertions(+), 3 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me; Passed CI tests; Ready for merge
--
To view, visit https://gerrit.ovirt.org/51697
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0970d2cec0182f577e02f76229c906a953092638
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-sdk
Gerrit-Branch: sdk_3.6
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 11 months