Change in ovirt-engine-sdk[sdk_4.0]: Avoid duplicate symbols in Mac OS X
by omachace@redhat.com
Ondra Machacek has submitted this change and it was merged.
Change subject: Avoid duplicate symbols in Mac OS X
......................................................................
Avoid duplicate symbols in Mac OS X
The C compiler used in Mac OS X, clang, is more strict than the one used in
Linux, gcc. It detects that some symbols are duplicated, and the build fails.
This patch fixes the error that causes that failure, declaring the symbols as
'extern' in the .h file, and re-declaring them in the corresponding .c file.
Change-Id: Ice0331395266b05f963c334e14d7c9448301655b
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
(cherry picked from commit 1363be1e5db37ef7523088815a6fe0cb3e935570)
---
M sdk/ext/ov_xml_module.c
M sdk/ext/ov_xml_module.h
2 files changed, 4 insertions(+), 1 deletion(-)
Approvals:
Ondra Machacek: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/65775
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ice0331395266b05f963c334e14d7c9448301655b
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-sdk
Gerrit-Branch: sdk_4.0
Gerrit-Owner: Ondra Machacek <omachace(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Ondra Machacek <omachace(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 2 months
Change in ovirt-engine-sdk[master]: Avoid duplicate symbols in Mac OS X
by omachace@redhat.com
Ondra Machacek has submitted this change and it was merged.
Change subject: Avoid duplicate symbols in Mac OS X
......................................................................
Avoid duplicate symbols in Mac OS X
The C compiler used in Mac OS X, clang, is more strict than the one used in
Linux, gcc. It detects that some symbols are duplicated, and the build fails.
This patch fixes the error that causes that failure, declaring the symbols as
'extern' in the .h file, and re-declaring them in the corresponding .c file.
Change-Id: Ice0331395266b05f963c334e14d7c9448301655b
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M sdk/ext/ov_xml_module.c
M sdk/ext/ov_xml_module.h
2 files changed, 4 insertions(+), 1 deletion(-)
Approvals:
Ondra Machacek: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/65746
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ice0331395266b05f963c334e14d7c9448301655b
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine-sdk
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Ondra Machacek <omachace(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 2 months
Change in ovirt-engine[ovirt-engine-4.0.5]: webadmin: Don't clean upload model on dialog closing.
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: webadmin: Don't clean upload model on dialog closing.
......................................................................
webadmin: Don't clean upload model on dialog closing.
Patch I363d06219af83bd21e6384840bf9a969331a9959 introduced a better
handling of model objects, which makes the dialogs in the system to
clean up their related models.
In UploadImageModel, the model is still alive as it is used to upload
the user's file- so it shouldn't be cleaned while the upload dialog is
closed.
This patch removes the cleaning of the model in UploadImagePopupView.
Change-Id: I91b40d5a78d190c16d78e950c892638ea839580e
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1368101
Signed-off-by: Amit Aviram <aaviram(a)redhat.com>
Signed-off-by: Alexander Wels <awels(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/storage/UploadImagePopupView.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/65770
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I91b40d5a78d190c16d78e950c892638ea839580e
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.0.5
Gerrit-Owner: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 2 months
Change in ovirt-engine[master]: core: MigrateVmToServerCommand#init()
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: MigrateVmToServerCommand#init()
......................................................................
core: MigrateVmToServerCommand#init()
Apparently, setDestinationVdsId performs a DAO call. Its confusing name
caused it to be missed in 6188d4.
This patch extracts it from the constructor and moves it to the init()
method where it belongs.
Change-Id: Ic9ded0d6ac7efe2bc1877822da55a5825500092c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmToServerCommand.java
1 file changed, 5 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/65768
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic9ded0d6ac7efe2bc1877822da55a5825500092c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 2 months
Change in ovirt-engine[master]: webadmin: Refactoring of AddRemoveRowWidget, remove juggling...
by mbetak@redhat.com
Martin Betak has submitted this change and it was merged.
Change subject: webadmin: Refactoring of AddRemoveRowWidget, remove juggling with iterator
......................................................................
webadmin: Refactoring of AddRemoveRowWidget, remove juggling with
iterator
Former code excelled in optimizing LOC metric and getting everything
done via Iterator manipulation. Which is unreadable, full of
side-effects (code smell), and it's pointless.
Changes:
• items.listIterator(items.size()).hasPrevious() ≈ !items.isEmpty()
• mysterious first part of if statement "item == last.previous()"
comparison makes sure, that we're adding plus button only if last item
is removed. I made this fact more obvious.
• mysterious second part of if statement "last.hasPrevious()" makes
sure, that after item removal, the items collection won't be
empty, thus we have something to add plus button to. I made this fact
more obvious.
• adding of plus button before removing last item is (in priciple)
wrong. Adding plus symbol only after removal is a) easier to write
code b) it is required by follow-up patch.
Change-Id: Ib563b43cf7e7cd4a71ff51f615ebfb8ff074e79c
Signed-off-by: Martin Mucha <mmucha(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/AddRemoveRowWidget.java
1 file changed, 15 insertions(+), 6 deletions(-)
Approvals:
Tomas Jelinek: Looks good to me, approved
Martin Mucha: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/65571
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib563b43cf7e7cd4a71ff51f615ebfb8ff074e79c
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Jakub Niedermertl <jniederm(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 2 months
Change in ovirt-engine[ovirt-engine-4.0]: core: move guest memory related fields to statistics
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: move guest memory related fields to statistics
......................................................................
core: move guest memory related fields to statistics
The information related to the memory within the guest used to be
stored in VmDynamic. This is wrong. First, conceptually it is more
'statistics' then 'runtime' info. Second, it is updated frequenty
and therefore leads to many updates of VM dynamic data by the VMs
monitoring.
This patch moves these fields to VmStatistics instead.
Change-Id: If9944576a3283d77ad6c46c14f366efdf536b816
Bug-Url: https://bugzilla.redhat.com/1340722
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VM.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VmDynamic.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VmStatistics.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VmDynamicDaoImpl.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VmStatisticsDaoImpl.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsBrokerObjectsBuilder.java
M packaging/dbscripts/create_dwh_views.sql
M packaging/dbscripts/create_views.sql
A packaging/dbscripts/upgrade/04_00_0960_move_guest_mem_fields_to_statistics.sql
M packaging/dbscripts/vms_sp.sql
10 files changed, 117 insertions(+), 91 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Shmuel Leib Melamud: Looks good to me, but someone else must approve
Arik Hadas: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/65758
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If9944576a3283d77ad6c46c14f366efdf536b816
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.0
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 2 months
Change in ovirt-engine[ovirt-engine-4.0]: core: fix inconsistency with empty cd-rom value
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: fix inconsistency with empty cd-rom value
......................................................................
core: fix inconsistency with empty cd-rom value
By default, the CD-ROM attached to the VM is NULL.
VDSM also reports NULL value in case no CD-ROM is attached.
Recently RunVmCommand was changed to persist the CD-ROM
that is attached to a VM as well, however, it is then set
to an empty string if no CD-ROM is attached. Therefore, the
monitoring gets empty string from the DB and NULL value
from VDSM and decides to update VM dynamic data because of
this change. But later on, the NULL value from VDSM is
ignored and thus, this flow will happen on every monitoring
cycle, leading to many redundant updates of VM dynamic daa.
Change-Id: I5e2afff36f3ee02b57a43760ab88f0a9c3176f37
Bug-Url: https://bugzilla.redhat.com/1340722
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java
A packaging/dbscripts/upgrade/04_00_0950_empty_current_cd_to_null.sql
2 files changed, 3 insertions(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Martin Betak: Looks good to me, but someone else must approve
Arik Hadas: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/65757
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5e2afff36f3ee02b57a43760ab88f0a9c3176f37
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.0
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 2 months
Change in ovirt-engine[ovirt-engine-4.0]: core: do not compare hash of guest agent nics in vms monitoring
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: do not compare hash of guest agent nics in vms monitoring
......................................................................
core: do not compare hash of guest agent nics in vms monitoring
The hash of the network interfaces reported by the guest agent is computed
by the engine (rather than reported by VDSM) and therefore should not be a
part of the comparison of the dynamic data from the database and the data
reported by VDSM in VMs monitoring that leads to redundant updates of the
dynamic data of VMs.
Change-Id: I01629b006525cd30be5d7cdf6e6ccd398131d50a
Bug-Url: https://bugzilla.redhat.com/1340722
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VmDynamic.java
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Shmuel Leib Melamud: Looks good to me, but someone else must approve
Arik Hadas: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/65756
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I01629b006525cd30be5d7cdf6e6ccd398131d50a
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.0
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 2 months
Change in ovirt-engine[ovirt-engine-4.0]: core: do not compare hash in vms monitoring
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: do not compare hash in vms monitoring
......................................................................
core: do not compare hash in vms monitoring
The devices hash is now processed by VmDevicesMonitoring so no
need to compare it against the value in the database as part
of the analysis of VmAnalyzer.
Change-Id: Ib080211a9ecf52d4b63b102d6255f27109b92113
Bug-Url: https://bugzilla.redhat.com/1340722
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VmDynamic.java
1 file changed, 2 insertions(+), 0 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Shmuel Leib Melamud: Looks good to me, but someone else must approve
Arik Hadas: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/65755
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib080211a9ecf52d4b63b102d6255f27109b92113
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-4.0
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 2 months
Change in ovirt-engine[master]: webadmin: refactoring of AddRemoveRowWidget, split overgrown...
by mbetak@redhat.com
Martin Betak has submitted this change and it was merged.
Change subject: webadmin: refactoring of AddRemoveRowWidget, split overgrown method.
......................................................................
webadmin: refactoring of AddRemoveRowWidget, split overgrown
method.
usualy everytime a method accepts boolean flag, this method is
overgrown, worsening maintenance and readability.
Change-Id: I396a048d696ae12773d9ae2b93b17036b8b2b10b
Signed-off-by: Martin Mucha <mmucha(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/AddRemoveRowWidget.java
1 file changed, 52 insertions(+), 34 deletions(-)
Approvals:
Tomas Jelinek: Looks good to me, approved
Martin Mucha: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/65570
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I396a048d696ae12773d9ae2b93b17036b8b2b10b
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Jakub Niedermertl <jniederm(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 2 months