Change in ovirt-engine[master]: core: MaintenanceVdsCommand type inference
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: MaintenanceVdsCommand type inference
......................................................................
core: MaintenanceVdsCommand type inference
Change-Id: I5c3aaf6f44ce49c84096bc3a2eeee2353649623a
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MaintenanceVdsCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/68582
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5c3aaf6f44ce49c84096bc3a2eeee2353649623a
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years
Change in ovirt-engine[master]: core: MaintenanceVdsCommand sorting
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: MaintenanceVdsCommand sorting
......................................................................
core: MaintenanceVdsCommand sorting
Replaces the outdated Collections.sort(Collection, Comparator) and
Collections.reverseOrder(Comparator) syntax by the modern
List.sort(Comparator) and Comparator.reversed().
At the very least, calling these methods cleans up the code and makes it
easier to read while retaining the same performance. It may, however
improve performance in some list and/or comparator implementations, if
they choose to override these methods.
Change-Id: I6110eaca36da3980c99e039a9356d4bb0916d715
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MaintenanceVdsCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/68583
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6110eaca36da3980c99e039a9356d4bb0916d715
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years
Change in ovirt-engine[master]: core: MaintenanceVdsCommand redundant brackets
by Code Review
>From Allon Mureinik <amureini(a)redhat.com>:
Allon Mureinik has submitted this change and it was merged.
Change subject: core: MaintenanceVdsCommand redundant brackets
......................................................................
core: MaintenanceVdsCommand redundant brackets
Change-Id: Ic580e436fc3c4b3e592b8c836cb81b44b0bdabc2
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MaintenanceVdsCommand.java
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/68584
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic580e436fc3c4b3e592b8c836cb81b44b0bdabc2
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years
Change in jenkins[master]: ovirt-live: add 4.1 branch jobs
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: ovirt-live: add 4.1 branch jobs
......................................................................
ovirt-live: add 4.1 branch jobs
Change-Id: Ibda7e86a9f23efb95c9eddcfebfc0936d03b4802
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M jobs/confs/projects/ovirt-live/ovirt-live_build-artifacts.yaml
M jobs/confs/projects/ovirt/publish-rpms-nightly-4.1.yaml
2 files changed, 5 insertions(+), 1 deletion(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved; Ready for merge
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/68608
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibda7e86a9f23efb95c9eddcfebfc0936d03b4802
Gerrit-PatchSet: 1
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years
Change in ovirt-live[master]: packaging: spec: fix for CentOS 7.3
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: spec: fix for CentOS 7.3
......................................................................
packaging: spec: fix for CentOS 7.3
In CentOS 7.3 the unversioned doc directory need to
be listed explicitly or rpmbuild will fail.
Change-Id: I1eb370a9bbd8672feeaf7b5453a28e4015755ed1
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
(cherry picked from commit bb66c83bbaf624fc4d03b4034e8aff4bd424fdae)
---
M ovirt-engine-setup-plugin-live/ovirt-engine-setup-plugin-live.spec.in
M ovirt-live-artwork/ovirt-live-artwork.spec.in
2 files changed, 2 insertions(+), 1 deletion(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/68604
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1eb370a9bbd8672feeaf7b5453a28e4015755ed1
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-live
Gerrit-Branch: master
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years
Change in ovirt-live[ovirt-live-4.0]: packaging: spec: fix for CentOS 7.3
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: spec: fix for CentOS 7.3
......................................................................
packaging: spec: fix for CentOS 7.3
In CentOS 7.3 the unversioned doc directory need to
be listed explicitly or rpmbuild will fail.
Change-Id: I1eb370a9bbd8672feeaf7b5453a28e4015755ed1
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M ovirt-engine-setup-plugin-live/ovirt-engine-setup-plugin-live.spec.in
M ovirt-live-artwork/ovirt-live-artwork.spec.in
2 files changed, 2 insertions(+), 1 deletion(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/68602
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1eb370a9bbd8672feeaf7b5453a28e4015755ed1
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-live
Gerrit-Branch: ovirt-live-4.0
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years
Change in ovirt-hosted-engine-ha[v2.0.z]: Improve logging of migration failure transition
by Code Review
>From Martin Sivák <msivak(a)redhat.com>:
Martin Sivák has submitted this change and it was merged.
Change subject: Improve logging of migration failure transition
......................................................................
Improve logging of migration failure transition
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1399766
Change-Id: Id10c8a4d804555a158bd66bd28047ef051cf7f4e
Signed-off-by: Martin Sivak <msivak(a)redhat.com>
---
M ovirt_hosted_engine_ha/agent/states.py
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Martin Sivák: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/68597
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id10c8a4d804555a158bd66bd28047ef051cf7f4e
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: v2.0.z
Gerrit-Owner: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years
Change in jenkins[master]: repos-check-closure: add 4.1 repos
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: repos-check-closure: add 4.1 repos
......................................................................
repos-check-closure: add 4.1 repos
Added 4.1 repositories to closure checking jobs
Change-Id: I35f9d268562bee353c8fcdbd28bc3de42efea294
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M jobs/confs/projects/repos-check-closure/repos-check-closure.yaml
1 file changed, 5 insertions(+), 0 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved; Ready for merge
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/68592
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I35f9d268562bee353c8fcdbd28bc3de42efea294
Gerrit-PatchSet: 1
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Anton Marchukov <amarchuk(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years
Change in ovirt-release[ovirt-4.0]: packaging: gpg key update
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: gpg key update
......................................................................
packaging: gpg key update
The shipped key expired in April 2016
$ gpg --import RPM-GPG-ovirt
$ gpg --list-keys
------------------------------------
pub 2048R/FE590CB7 2014-03-30 [expired: 2016-04-02]
uid oVirt <infra(a)ovirt.org>
the key validity has been extended already.
updating the gpg key:
$ gpg --recv-keys FE590CB7
$ gpg --list-keys
------------------------------------
pub 2048R/FE590CB7 2014-03-30 [expires: 2021-04-03]
uid oVirt <infra(a)ovirt.org>
sub 2048R/004BC303 2014-03-30 [expires: 2021-04-03]
$ gpg --armor --export FE590CB7 >/tmp/RPM-GPG-ovirt-v2
Change-Id: I4ad10781743ea6baff2fb9193b9922b6e339c803
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
(cherry picked from commit 16eac17d44d02b9f634833c1adba196cc46b3c80)
---
D RPM-GPG-ovirt
A RPM-GPG-ovirt-v2
M ovirt-release40.spec.in
3 files changed, 43 insertions(+), 31 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/68586
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4ad10781743ea6baff2fb9193b9922b6e339c803
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-release
Gerrit-Branch: ovirt-4.0
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Fabian Deutsch <fabiand(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years
Change in jenkins[master]: repo_closure_check: fix el7 repos for metrics
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: repo_closure_check: fix el7 repos for metrics
......................................................................
repo_closure_check: fix el7 repos for metrics
Added opstools repo to el7 for metrics.
Fixes false positive on missing fluentd and co.
Change-Id: Ibefdf83580d3054b51e94bd40655631ae5be7a6a
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M jobs/packaging/repo_closure_check.sh
1 file changed, 4 insertions(+), 1 deletion(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved; Ready for merge
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/68590
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibefdf83580d3054b51e94bd40655631ae5be7a6a
Gerrit-PatchSet: 1
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Anton Marchukov <amarchuk(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years