Change in ovirt-hosted-engine-ha[master]: text typo th -> to
by msivak@redhat.com
Martin Sivák has submitted this change and it was merged.
Change subject: text typo th -> to
......................................................................
text typo th -> to
Change-Id: I428e77ed028cfca93d93a4af0ec187b24156218d
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
---
M ovirt_hosted_engine_ha/lib/upgrade.py
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Martin Sivák: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53904
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I428e77ed028cfca93d93a4af0ec187b24156218d
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: master
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: AttachStorageDomainToPoolCommand collections
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AttachStorageDomainToPoolCommand collections
......................................................................
core: AttachStorageDomainToPoolCommand collections
Use Collections.singletonList instead of Arrays.asList for a single-item
"constant" list in order to improve performance.
Change-Id: Iefe7f57ec4abfec24ef971999a009e73dcaa2caf
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/AttachStorageDomainToPoolCommand.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/53869
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iefe7f57ec4abfec24ef971999a009e73dcaa2caf
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: AttachStorageDomainToPoolCommand null check
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AttachStorageDomainToPoolCommand null check
......................................................................
core: AttachStorageDomainToPoolCommand null check
Removed the getStorageDomain() null check from the executeCommand()
method - this is already verified by the validate() method.
Change-Id: Iff575202a88a8d8fa7ce8a72827498156c59e72b
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/AttachStorageDomainToPoolCommand.java
1 file changed, 105 insertions(+), 107 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/53870
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iff575202a88a8d8fa7ce8a72827498156c59e72b
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: AttachStorageDomainToPoolCommand NPE
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AttachStorageDomainToPoolCommand NPE
......................................................................
core: AttachStorageDomainToPoolCommand NPE
Commit a2c09b0e67a4cef8f6b4c4c09d23892349d2a7f6, which refactored the
validate() method to use a StorageDomainToPoolRelationValidator,
introduced a potential NullPointerException to this flow as it attempted
to access getStorageDomain().getStorageStaticData() before verifying
that getStorageDomain() does not return null.
This patch solves the issue by moving this access to a later stage,
where it is actually needed.
Change-Id: Ib59778af3683983c7d841028ee6bb7912dd2e7de
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/AttachStorageDomainToPoolCommand.java
1 file changed, 7 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/53868
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib59778af3683983c7d841028ee6bb7912dd2e7de
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: AttachStorageDomainToPoolCommand early return
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AttachStorageDomainToPoolCommand early return
......................................................................
core: AttachStorageDomainToPoolCommand early return
Refactor the validate() method to use the early return pattern in order
to improve the code's readability.
Change-Id: I83fcf24e7e16bf3c522c4d38b9fb5ff9eb46f83c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/AttachStorageDomainToPoolCommand.java
1 file changed, 11 insertions(+), 11 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/53867
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I83fcf24e7e16bf3c522c4d38b9fb5ff9eb46f83c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Amit Aviram <aaviram(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: AttachStorageDomainToPoolCommand ctor location
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AttachStorageDomainToPoolCommand ctor location
......................................................................
core: AttachStorageDomainToPoolCommand ctor location
Moved the two constructors to be together, at the top of the class, as
per Java's recommended style.
Change-Id: Ia4da0af86c73a7d2975b08fcc1b22456ebaa2420
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/AttachStorageDomainToPoolCommand.java
1 file changed, 7 insertions(+), 8 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/53866
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia4da0af86c73a7d2975b08fcc1b22456ebaa2420
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: AttachStorageDomainToPoolCommand comment
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AttachStorageDomainToPoolCommand comment
......................................................................
core: AttachStorageDomainToPoolCommand comment
Remove useless, misplaced comment from the code.
Change-Id: I9959145c709b378bfb8ea616fe90f1983f94f9b0
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/domain/AttachStorageDomainToPoolCommand.java
1 file changed, 0 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/53865
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9959145c709b378bfb8ea616fe90f1983f94f9b0
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[ovirt-engine-3.6]: core: Remove condition for AsyncTaskType.notSupported.
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Remove condition for AsyncTaskType.notSupported.
......................................................................
core: Remove condition for AsyncTaskType.notSupported.
In some cases the engine calls commands which
have async calls to VDSM but in some scenarios,
those async calls, eventually are not getting called.
In case that the async calls are not getting called,
the engine should set the command as succeeded since
there are no tasks it should wait for to determine
the command's status.
Change-Id: I49b7f506dc1142c3a559d0e6f64813e2ade02254
Bug-Url: https://bugzilla.redhat.com/1310390
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommandBase.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, approved
Maor Lipchuk: Verified
--
To view, visit https://gerrit.ovirt.org/53887
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I49b7f506dc1142c3a559d0e6f64813e2ade02254
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: webadmin: reorder quota list when creating disk or template
by rgolan@redhat.com
Roy Golan has submitted this change and it was merged.
Change subject: webadmin: reorder quota list when creating disk or template
......................................................................
webadmin: reorder quota list when creating disk or template
In disk and template creation dialogs reorder quota lists so that selected VM's
quota is first.
Change-Id: I77909c725f3e6eeecb7682035808133a700dc9a5
Bug-Url: https://bugzilla.redhat.com/922748
Signed-off-by: Andrej Krejcir <akrejcir(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/comparators/QuotaComparator.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/dataprovider/AsyncDataProvider.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/DisksAllocationModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/ImportExportRepoImageBaseModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/RegisterEntityModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/AbstractDiskModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/InstanceImageLineModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/NewTemplateVmModelBehavior.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmModelBehaviorBase.java
9 files changed, 173 insertions(+), 110 deletions(-)
Approvals:
Tomas Jelinek: Looks good to me, but someone else must approve
Daniel Erez: Looks good to me, approved
Jenkins CI: Passed CI tests
Andrej Krejcir: Verified
--
To view, visit https://gerrit.ovirt.org/49109
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I77909c725f3e6eeecb7682035808133a700dc9a5
Gerrit-PatchSet: 15
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Andrej Krejcir <akrejcir(a)redhat.com>
Gerrit-Reviewer: Andrej Krejcir <akrejcir(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Roman Mohr <rmohr(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tomas Jelinek <tjelinek(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: Remove condition for AsyncTaskType.notSupported.
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core: Remove condition for AsyncTaskType.notSupported.
......................................................................
core: Remove condition for AsyncTaskType.notSupported.
In some cases the engine calls commands which
have async calls to VDSM but in some scenarios,
those async calls, eventually are not getting called.
In case that the async calls are not getting called,
the engine should set the command as succeeded since
there are no tasks it should wait for to determined
the command's status.
Change-Id: I49b7f506dc1142c3a559d0e6f64813e2ade02254
Bug-Url: https://bugzilla.redhat.com/1310390
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommandBase.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Daniel Erez: Looks good to me, but someone else must approve
Maor Lipchuk: Verified
Liron Aravot: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/53877
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I49b7f506dc1142c3a559d0e6f64813e2ade02254
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months