Change in ovirt-engine[master]: core: SerialChildCommandsExecutionCallback - support continu...
by laravot@redhat.com
Liron Aravot has submitted this change and it was merged.
Change subject: core: SerialChildCommandsExecutionCallback - support continuation after child failure
......................................................................
core: SerialChildCommandsExecutionCallback - support continuation after child failure
Currently SerialChildCommandsExecutionCallback will call performNextOperation() only
if all the child commands were ended successfully.
In some flows, we might want to perform the next operation also in case
of failure of the child commands.
Change-Id: I06b80b62529e477127af3517493a2c7be65c1aa0
Signed-off-by: Liron Aravot <laravot(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/SerialChildCommandsExecutionCallback.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/SerialChildExecutingCommand.java
2 files changed, 9 insertions(+), 1 deletion(-)
Approvals:
Jenkins CI: Passed CI tests
Moti Asayag: Looks good to me, approved
Liron Aravot: Verified
--
To view, visit https://gerrit.ovirt.org/53903
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I06b80b62529e477127af3517493a2c7be65c1aa0
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: Handle exception if calling VDSM fails
by laravot@redhat.com
Liron Aravot has submitted this change and it was merged.
Change subject: core: Handle exception if calling VDSM fails
......................................................................
core: Handle exception if calling VDSM fails
When updating image data, we call VDSM to get image info.
If this call fails, the flow breaks and potentially leaving
database with incorrect data. This patch handles exception thrown
when calling VDSM.
Change-Id: Ia1aa477555cfb624724a5cc948120ea113f3f6ff
Bug-Url: https://bugzilla.redhat.com/1309294
Signed-off-by: Ala Hino <ahino(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/RemoveSnapshotSingleDiskCommandBase.java
1 file changed, 14 insertions(+), 7 deletions(-)
Approvals:
Ala Hino: Verified
Liron Aravot: Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53606
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia1aa477555cfb624724a5cc948120ea113f3f6ff
Gerrit-PatchSet: 17
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Greg Padgett <gpadgett(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: Move getImageInfo call outside of transaction boundary
by laravot@redhat.com
Liron Aravot has submitted this change and it was merged.
Change subject: core: Move getImageInfo call outside of transaction boundary
......................................................................
core: Move getImageInfo call outside of transaction boundary
Currently, when syncing db records, we call vdsm to get volume info.
This call is performed inside db transaction which could lead to failure
regardless of the db performance. This could happen if storage is slow or
network connection is slow.
To fix this behavior, the call to vdsm moved outside of the transaction.
Change-Id: Ifac1ab925afd448d149fecc286d361a797c9d57b
Signed-off-by: Ala Hino <ahino(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/RemoveSnapshotSingleDiskCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/RemoveSnapshotSingleDiskCommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/RemoveSnapshotSingleDiskLiveCommand.java
3 files changed, 22 insertions(+), 14 deletions(-)
Approvals:
Ala Hino: Verified
Liron Aravot: Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53605
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifac1ab925afd448d149fecc286d361a797c9d57b
Gerrit-PatchSet: 13
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Greg Padgett <gpadgett(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: packaging: setup: dockerc: fix usage of ovirt_setup_lib.host...
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: setup: dockerc: fix usage of ovirt_setup_lib.hostname
......................................................................
packaging: setup: dockerc: fix usage of ovirt_setup_lib.hostname
Bug-Url: https://bugzilla.redhat.com/1310705
Change-Id: I606fccdd93d16b111f4c5db8ab8f7ddc5bb29b3d
Signed-off-by: Rafael Martins <rmartins(a)redhat.com>
---
M packaging/setup/plugins/ovirt-engine-setup/dockerc/config.py
1 file changed, 2 insertions(+), 15 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Simone Tiraboschi: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Rafael Martins: Verified
--
To view, visit https://gerrit.ovirt.org/53838
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I606fccdd93d16b111f4c5db8ab8f7ddc5bb29b3d
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Rafael Martins <rmartins(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Rafael Martins <rmartins(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: core: Wrap syncDbRecords code in a transaction
by laravot@redhat.com
Liron Aravot has submitted this change and it was merged.
Change subject: core: Wrap syncDbRecords code in a transaction
......................................................................
core: Wrap syncDbRecords code in a transaction
'syncDbRecords' method performs multiple updates to
the database. While 'onFailed' method manages transaction,
'onSucceeded' method does not. This patch changes 'syncDbRecords'
logic to run inside a transaction.
Change-Id: Id4e045c3971817a878d836b56d75e253eb67171f
Signed-off-by: Ala Hino <ahino(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/RemoveSnapshotSingleDiskLiveCommand.java
1 file changed, 31 insertions(+), 31 deletions(-)
Approvals:
Greg Padgett: Looks good to me, but someone else must approve
Ala Hino: Verified
Liron Aravot: Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53604
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id4e045c3971817a878d836b56d75e253eb67171f
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Greg Padgett <gpadgett(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[master]: refactor: Split syncDbRecords code
by laravot@redhat.com
Liron Aravot has submitted this change and it was merged.
Change subject: refactor: Split syncDbRecords code
......................................................................
refactor: Split syncDbRecords code
Split syncDbRecords code to apprpriate methods to make the
code more readable.
Change-Id: Ib4dc633b0f4dbaa7e805f16082d19b846255c499
Signed-off-by: Ala Hino <ahino(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/RemoveSnapshotSingleDiskLiveCommand.java
1 file changed, 64 insertions(+), 56 deletions(-)
Approvals:
Greg Padgett: Looks good to me, but someone else must approve
Ala Hino: Verified
Liron Aravot: Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53641
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib4dc633b0f4dbaa7e805f16082d19b846255c499
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Ala Hino <ahino(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Greg Padgett <gpadgett(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-hosted-engine-ha[ovirt-hosted-engine-ha-1.3]: text typo th -> to
by msivak@redhat.com
Martin Sivák has submitted this change and it was merged.
Change subject: text typo th -> to
......................................................................
text typo th -> to
Change-Id: I428e77ed028cfca93d93a4af0ec187b24156218d
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
(cherry picked from commit d815a599369d966c90b78f2dfc7ff3ad8473c233)
---
M ovirt_hosted_engine_ha/lib/upgrade.py
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Martin Sivák: Looks good to me, approved; Passed CI tests
Simone Tiraboschi: Looks good to me, but someone else must approve
Yedidyah Bar David: Verified
--
To view, visit https://gerrit.ovirt.org/53905
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I428e77ed028cfca93d93a4af0ec187b24156218d
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-hosted-engine-ha
Gerrit-Branch: ovirt-hosted-engine-ha-1.3
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-hosted-engine-setup[ovirt-hosted-engine-setup-1.3]: build: post ovirt-hosted-engine-setup-1.3.3.4
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: build: post ovirt-hosted-engine-setup-1.3.3.4
......................................................................
build: post ovirt-hosted-engine-setup-1.3.3.4
Change-Id: I3ee67c4fbf16523a3fac9433de9174c4ca674051
Signed-off-by: Rafael Martins <rmartins(a)redhat.com>
---
M configure.ac
M ovirt-hosted-engine-setup.spec.in
2 files changed, 9 insertions(+), 6 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/53880
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3ee67c4fbf16523a3fac9433de9174c4ca674051
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-hosted-engine-setup
Gerrit-Branch: ovirt-hosted-engine-setup-1.3
Gerrit-Owner: Rafael Martins <rmartins(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-hosted-engine-setup[ovirt-hosted-engine-setup-1.3]: build: ovirt-hosted-engine-setup-1.3.3.4
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: build: ovirt-hosted-engine-setup-1.3.3.4
......................................................................
build: ovirt-hosted-engine-setup-1.3.3.4
Change-Id: I3d79f843626fd9a83abf8e32a8d039c5c8389696
Signed-off-by: Rafael Martins <rmartins(a)redhat.com>
---
M configure.ac
M ovirt-hosted-engine-setup.spec.in
2 files changed, 12 insertions(+), 9 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Jenkins CI: Passed CI tests
Rafael Martins: Verified
--
To view, visit https://gerrit.ovirt.org/53879
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3d79f843626fd9a83abf8e32a8d039c5c8389696
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-hosted-engine-setup
Gerrit-Branch: ovirt-hosted-engine-setup-1.3
Gerrit-Owner: Rafael Martins <rmartins(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Rafael Martins <rmartins(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 10 months
Change in ovirt-engine[ovirt-engine-3.6]: core: Added Roles and groups for cpu profiling
by piotr.kliczewski@gmail.com
Piotr Kliczewski has submitted this change and it was merged.
Change subject: core: Added Roles and groups for cpu profiling
......................................................................
core: Added Roles and groups for cpu profiling
The following CPU Profiles were added in order to prevent unauthorized
access to cpu profiles:
CpuProfileOperator - Will have the ability to Assign CPU Profile to VMs.
CpuProfileCreator - Will have the ability to Create/Update/Delete and
Assign CPU Profile to VMs.
Action groups that were added to engine and REST API:
Create CPU Profile, Update CPU Profile, Remove CPU Profile,
Assign CPU Profile.
Roles that were granted Create/Update/Delete and Assign permissions for
cpu profiles (Same as CpuProfileCreator + CpuProfileOperator):
SuperUser, PowerUser, ClusterAdmin, DataCenterAdmin.
Other roles that were granted permission same as the ones for
CpuProfileOperator:
CpuProfileCreator, UserVmManager, VmPoolAdmin, VmCreator,
UserTemplateBasedVm and UserVmRuntimeManager.
Before this patch, any user that had permissions for the cluster
associated with the CPU Profile, could Create/Update/Delete and Assign
it.
The Data Access Objects tests(DAO tests) were changed inorder to comply
with the new behaviour.
Change-Id: I8217f0146d83afe3ae740bd1d1e37825091ed206
Bug-Url: https://bugzilla.redhat.com/1143869
Bug-Url: https://bugzilla.redhat.com/1310541
Signed-off-by: Tomer Saban <tsaban(a)redhat.com>
Signed-off-by: Martin Sivak <msivak(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/PredefinedRoles.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/ActionGroup.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/FixturesTool.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/RoleDaoTest.java
M backend/manager/modules/dal/src/test/resources/fixtures.xml
M backend/manager/modules/restapi/interface/definition/src/main/java/org/ovirt/engine/api/model/PermitType.java
M packaging/dbscripts/cpu_profiles_sp.sql
M packaging/dbscripts/create_views.sql
A packaging/dbscripts/upgrade/03_06_2040_attach_cpu_profile_permissions.sql
A packaging/dbscripts/upgrade/03_06_2050_create_index_cpu_profiles.sql
10 files changed, 249 insertions(+), 26 deletions(-)
Approvals:
Martin Sivák: Verified
Jenkins CI: Passed CI tests
Roy Golan: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/53885
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8217f0146d83afe3ae740bd1d1e37825091ed206
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Tomer Saban <tsaban(a)redhat.com>
8 years, 10 months