Change in ovirt-engine[master]: engine: Fetch AuditLog only once from DB
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Fetch AuditLog only once from DB
......................................................................
engine: Fetch AuditLog only once from DB
In the same command, there were 3 accesses to retrieve the exact
audit-log entity from the DB.
We can cachae and reuse it instead.
Change-Id: Ie218126845c178cf882d1539a0e46f369ae92204
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveAuditLogByIdCommand.java
1 file changed, 13 insertions(+), 6 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76054
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie218126845c178cf882d1539a0e46f369ae92204
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: engine: Avoid injection in logging of InstallerMessages
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Avoid injection in logging of InstallerMessages
......................................................................
engine: Avoid injection in logging of InstallerMessages
In this context, it is enough to set the host ID and host name in order
to be able to present the event under the entity which is associated with.
Change-Id: I3dc8ffd8f824f46c481990fb8870e4f4b30db714
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/hostdeploy/InstallerMessages.java
1 file changed, 5 insertions(+), 3 deletions(-)
Approvals:
Martin Peřina: Looks good to me, approved
Jenkins CI: Passed CI tests
Moti Asayag: Verified
--
To view, visit https://gerrit.ovirt.org/76049
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3dc8ffd8f824f46c481990fb8870e4f4b30db714
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-engine[master]: engine: Extract Event Key creation to its own class
by Code Review
>From Moti Asayag <masayag(a)redhat.com>:
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Extract Event Key creation to its own class
......................................................................
engine: Extract Event Key creation to its own class
Change-Id: Id8786330990e731d2fabcf2700ce8107e5b6cb4a
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/EventFloodRegulator.java
A backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/auditloghandling/EventKeyComposer.java
2 files changed, 60 insertions(+), 42 deletions(-)
Approvals:
Jenkins CI: Passed CI tests
Moti Asayag: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/75980
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id8786330990e731d2fabcf2700ce8107e5b6cb4a
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Yevgeny Zaspitsky <yzaspits(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-log-collector[master]: inventory: Validate vms: Paused, ImageIllegal or ImageLocked
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: inventory: Validate vms: Paused, ImageIllegal or ImageLocked
......................................................................
inventory: Validate vms: Paused, ImageIllegal or ImageLocked
Add additional validation for vms status.
Change-Id: Ife1a341ea2ab8270527859b96fa3dbb6b7ee00fa
Signed-off-by: Douglas Schilling Landgraf <dougsland(a)redhat.com>
---
M src/inventory_report/produceReport.sh
M src/inventory_report/sqls/cleanup.sql
A src/inventory_report/sqls/vms_create_related_lookup_tables.sql
A src/inventory_report/sqls/vms_query_health.sql
4 files changed, 72 insertions(+), 0 deletions(-)
Approvals:
Douglas Schilling Landgraf: Verified
Sandro Bonazzola: Looks good to me, approved
Martin Mucha: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Yedidyah Bar David: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/76019
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ife1a341ea2ab8270527859b96fa3dbb6b7ee00fa
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-log-collector
Gerrit-Branch: master
Gerrit-Owner: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Ido Rosenzwig <irosenzw(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Rafael Martins <rafael(a)rafaelmartins.eng.br>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-log-collector[master]: inventory - move storage create tablet to sql file
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: inventory - move storage create tablet to sql file
......................................................................
inventory - move storage create tablet to sql file
Splitting the logic helps the code readability.
Change-Id: I51397016d18293dc37c9161f5f6d67709f9cdc30
Signed-off-by: Douglas Schilling Landgraf <dougsland(a)redhat.com>
---
M src/inventory_report/produceReport.sh
M src/inventory_report/sqls/cleanup.sql
A src/inventory_report/sqls/storage_create_related_lookup_tables.sql
3 files changed, 34 insertions(+), 22 deletions(-)
Approvals:
Douglas Schilling Landgraf: Verified
Sandro Bonazzola: Looks good to me, approved
Jenkins CI: Passed CI tests
Yedidyah Bar David: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/76018
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I51397016d18293dc37c9161f5f6d67709f9cdc30
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-log-collector
Gerrit-Branch: master
Gerrit-Owner: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Ido Rosenzwig <irosenzw(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Rafael Martins <rafael(a)rafaelmartins.eng.br>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in ovirt-log-collector[master]: produceReport.sh: Add validation for third party certificates
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: produceReport.sh: Add validation for third party certificates
......................................................................
produceReport.sh: Add validation for third party certificates
If users set different path for ENGINE_PKI_TRUST_STORE to
load third party certificates, let's identify it.
Change-Id: Ie37650b82aea135d83d0a3b24cba1b9cc5ca6ce9
Signed-off-by: Douglas Schilling Landgraf <dougsland(a)redhat.com>
---
M src/inventory_report/produceReport.sh
1 file changed, 33 insertions(+), 1 deletion(-)
Approvals:
Douglas Schilling Landgraf: Verified
Sandro Bonazzola: Looks good to me, approved
Jenkins CI: Passed CI tests
Yedidyah Bar David: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/75347
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie37650b82aea135d83d0a3b24cba1b9cc5ca6ce9
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-log-collector
Gerrit-Branch: master
Gerrit-Owner: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken(a)redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsland(a)redhat.com>
Gerrit-Reviewer: Ido Rosenzwig <irosenzw(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Rafael Martins <rafael(a)rafaelmartins.eng.br>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in jenkins[master]: Add a packages file for fc26
by Code Review
>From Sandro Bonazzola <sbonazzo(a)redhat.com>:
Sandro Bonazzola has submitted this change and it was merged.
Change subject: Add a packages file for fc26
......................................................................
Add a packages file for fc26
We mostly need it to install Python3 packages
Change-Id: I663b2a7a5a1455f26a3412e28d213c9894013117
Signed-off-by: Barak Korren <bkorren(a)redhat.com>
---
A automation/check-patch.packages.fc26
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved; Ready for merge
Barak Korren: Verified; Ready for review
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/76095
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I663b2a7a5a1455f26a3412e28d213c9894013117
Gerrit-PatchSet: 2
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Barak Korren <bkorren(a)redhat.com>
Gerrit-Reviewer: Anton Marchukov <amarchuk(a)redhat.com>
Gerrit-Reviewer: Barak Korren <bkorren(a)redhat.com>
Gerrit-Reviewer: Daniel Belenky <dbelenky(a)redhat.com>
Gerrit-Reviewer: Evgheni Dereveanchin <ederevea(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Gil Shinar <gshinar(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Nadav Goldin <ngoldin(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Shlomo Ben David <sbendavi(a)redhat.com>
7 years, 8 months
Change in ovirt-host-deploy[master]: metrics: Make collectd/fluentd packages optional
by Code Review
>From Yedidyah Bar David <didi(a)redhat.com>:
Yedidyah Bar David has submitted this change and it was merged.
Change subject: metrics: Make collectd/fluentd packages optional
......................................................................
metrics: Make collectd/fluentd packages optional
Emit a warning if they are missing but do not fail deploy.
Change-Id: Ic2df4e82c92cfbf6c7df15c1ceca0600626e4385
Bug-Url: https://bugzilla.redhat.com/1443508
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
---
M src/plugins/ovirt-host-deploy/collectd/packages.py
M src/plugins/ovirt-host-deploy/fluentd/packages.py
2 files changed, 34 insertions(+), 12 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Yedidyah Bar David: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/75989
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic2df4e82c92cfbf6c7df15c1ceca0600626e4385
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-host-deploy
Gerrit-Branch: master
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Ido Rosenzwig <irosenzw(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Rafael Martins <rafael(a)rafaelmartins.eng.br>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
7 years, 8 months
Change in jenkins[master]: Build Python SDK 4.1 for Fedora 25
by Code Review
>From Barak Korren <bkorren(a)redhat.com>:
Barak Korren has submitted this change and it was merged.
Change subject: Build Python SDK 4.1 for Fedora 25
......................................................................
Build Python SDK 4.1 for Fedora 25
This patch enables buiding the Python SDK from branch 4.1, for Fedora 25.
Change-Id: Ied796b01373d305979270fae006bf5c1062cfd75
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M jobs/confs/projects/ovirt-engine-sdk/ovirt-engine-sdk_build-artifacts.yaml
1 file changed, 0 insertions(+), 6 deletions(-)
Approvals:
Barak Korren: Verified; Looks good to me, approved; Ready for merge
Jenkins CI: Passed CI tests
Yedidyah Bar David: Looks good to me
--
To view, visit https://gerrit.ovirt.org/76074
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ied796b01373d305979270fae006bf5c1062cfd75
Gerrit-PatchSet: 2
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Anton Marchukov <amarchuk(a)redhat.com>
Gerrit-Reviewer: Barak Korren <bkorren(a)redhat.com>
Gerrit-Reviewer: Daniel Belenky <dbelenky(a)redhat.com>
Gerrit-Reviewer: Evgheni Dereveanchin <ederevea(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Gil Shinar <gshinar(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Nadav Goldin <ngoldin(a)redhat.com>
Gerrit-Reviewer: Ondra Machacek <omachace(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Shlomo Ben David <sbendavi(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
7 years, 8 months
Change in ovirt-log-collector[master]: src: Remove dot from the end of the generated file
by Code Review
>From Lev Veyde <lveyde(a)redhat.com>:
Lev Veyde has submitted this change and it was merged.
Change subject: src: Remove dot from the end of the generated file
......................................................................
src: Remove dot from the end of the generated file
Change-Id: I05562f722553d9efdf16c306a2294a3f3dfcc0d1
Bug-Url: https://bugzilla.redhat.com/1441258
Signed-off-by: Ido Rosenzwig <irosenzw(a)redhat.com>
---
M src/__main__.py
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Lev Veyde: Looks good to me, approved
Ido Rosenzwig: Verified
Jenkins CI: Passed CI tests
Yedidyah Bar David: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/76056
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I05562f722553d9efdf16c306a2294a3f3dfcc0d1
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-log-collector
Gerrit-Branch: master
Gerrit-Owner: Ido Rosenzwig <irosenzw(a)redhat.com>
Gerrit-Reviewer: Ido Rosenzwig <irosenzw(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
7 years, 8 months