Change in ovirt-engine-sdk[master]: sdk: rebase to latest api
by mpastern@redhat.com
Michael Pasternak has submitted this change and it was merged.
Change subject: sdk: rebase to latest api
......................................................................
sdk: rebase to latest api
- added /current argument to VmCdRom.update() acorrding to #869257
- implemented support for #869257
- added /async argument to VmCdRom.update()
- added /async argument to ClusterNetworks.update()
- removed Disk.update() method
- added parameters overload for adding direct-lun disk
- added vm/template.display.smartcard_enabled
- added correlation_id to VMDisk.activate()/deactivate()
- added correlation_id to VMNic.activate()/deactivate()
- added certificate property to vm
- Disk.lunStorage renamed to Disk.lun_storage
Change-Id: Ic25c7a166698a28b22350f9988e418b2aef5b199
Signed-off-by: Michael Pasternak <mpastern(a)redhat.com>
---
M src/codegen/subcollection/subresource.py
M src/codegen/utils/paramutils.py
M src/ovirtsdk/infrastructure/brokers.py
M src/ovirtsdk/infrastructure/errors.py
M src/ovirtsdk/xml/params.py
5 files changed, 288 insertions(+), 110 deletions(-)
Approvals:
Michael Pasternak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9079
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic25c7a166698a28b22350f9988e418b2aef5b199
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine-sdk
Gerrit-Branch: master
Gerrit-Owner: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
12 years, 1 month
Change in ovirt-engine-sdk[master]: sdk: Cannot create simultaneous connections to multiple serv...
by mpastern@redhat.com
Michael Pasternak has submitted this change and it was merged.
Change subject: sdk: Cannot create simultaneous connections to multiple servers #853947
......................................................................
sdk: Cannot create simultaneous connections to multiple servers #853947
https://bugzilla.redhat.com/show_bug.cgi?id=853947
Change-Id: I53272bec94b5cd19a32fdd793d2b6786581a85f1
Signed-off-by: Michael Pasternak <mpastern(a)redhat.com>
---
M src/codegen/collection/collection.py
M src/codegen/collection/collectionexceptions.py
M src/codegen/collection/resource.py
M src/codegen/entrypoint/entrypoint.py
M src/codegen/imp/imprt.py
M src/codegen/main.py
M src/codegen/subcollection/subcollection.py
M src/codegen/subcollection/subresource.py
M src/ovirtsdk/api.py
M src/ovirtsdk/infrastructure/brokers.py
A src/ovirtsdk/infrastructure/cache.py
M src/ovirtsdk/infrastructure/common.py
M src/ovirtsdk/infrastructure/connectionspool.py
A src/ovirtsdk/infrastructure/context.py
M src/ovirtsdk/infrastructure/contextmanager.py
M src/ovirtsdk/utils/parsehelper.py
M src/ovirtsdk/web/connection.py
17 files changed, 3,215 insertions(+), 1,591 deletions(-)
Approvals:
Michael Pasternak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/8645
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I53272bec94b5cd19a32fdd793d2b6786581a85f1
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine-sdk
Gerrit-Branch: master
Gerrit-Owner: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: engine: Clean up of exceptions
by mkublin@redhat.com
Michael Kublin has submitted this change and it was merged.
Change subject: engine: Clean up of exceptions
......................................................................
engine: Clean up of exceptions
The following patch is removing unneeded exceptions, unneeded catch of exceptions,
unneeded code inside of catch block.
Also contains some small clean ups of IrsBrokerCommand
Change-Id: I27352290878620e922b1ba263172267ec9001aa0
Signed-off-by: Michael Kublin <mkublin(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/GetStoragePoolInfoVDSCommand.java
D backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/IRSNetworkException.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/IrsBrokerCommand.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/GetVGListVDSCommand.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/HSMGetStorageDomainInfoVDSCommand.java
5 files changed, 78 insertions(+), 178 deletions(-)
Approvals:
Michael Kublin: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9267
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I27352290878620e922b1ba263172267ec9001aa0
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Barak Azulay <bazulay(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: engine: Removed duplicate retrieve of vdsm task, during SPM ...
by mkublin@redhat.com
Michael Kublin has submitted this change and it was merged.
Change subject: engine: Removed duplicate retrieve of vdsm task, during SPM election
......................................................................
engine: Removed duplicate retrieve of vdsm task, during SPM election
The following fix will remove unneeded cal for vdsm tasks during SPM election.
At case that we choose a new spm, no need for additional retrieve of tasks from vdsm,
a call for tasks is done inside of AsyncTaskManager.getInstance().StopStoragePoolTasks(storagePool)
Change-Id: Idfd42b80ca241010cda578433b4365478c071334
Signed-off-by: Michael Kublin <mkublin(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsEventListener.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Michael Kublin: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9266
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idfd42b80ca241010cda578433b4365478c071334
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Barak Azulay <bazulay(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: engine: Fail Import Vm on MAC Address (#872100)
by msalem@redhat.com
Muli Salem has submitted this change and it was merged.
Change subject: engine: Fail Import Vm on MAC Address (#872100)
......................................................................
engine: Fail Import Vm on MAC Address (#872100)
This patch changes the VmInterfaceManager to throw
a VdcBllExpection when trying to add a interface with
a used MAC address.
It also adds a new VdcBllError for this case, and changes
the VmInterfaceManagerTest according to the change in
behavior.
Change-Id: I68d37ed183adb4adf8abf8b11332f6c822f8c4c0
Bug-Url: https://bugzilla.redhat.com/872100
Signed-off-by: Muli Salem <msalem(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/VmInterfaceManager.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/snapshots/SnapshotsManager.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/network/VmInterfaceManagerTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/VdcBllErrors.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M backend/manager/modules/dal/src/main/resources/bundles/AuditLogMessages.properties
M backend/manager/modules/utils/src/test/resources/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
11 files changed, 74 insertions(+), 69 deletions(-)
Approvals:
Muli Salem: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9144
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I68d37ed183adb4adf8abf8b11332f6c822f8c4c0
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Muli Salem <msalem(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Muli Salem <msalem(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: core: Adding support for installing functions ...
by emesika@redhat.com
Eli Mesika has submitted this change and it was merged.
Change subject: core: Adding support for installing functions ...
......................................................................
core: Adding support for installing functions ...
Adding support for installing functions that are needed for an
upgrade script Consider the following You are writing an upgrade script
that is doing lot of data manipulations using local functionsThose
functions should be called also after upgrade completed when data in the
system is modified
Now , those functions are dependant on a new object created lets say
,table T which was added in a prev upgrade script.You can not add those
functions to the common_sp.sql since it runs before the upgrade scripts
and at that point table T is not valid yet.
You can duplicate the functions and handle a local copy in the upgrade
script and another in the *_sp.sql file but this code duplication is a
mess and may lead to problems.You can install the functions only from
the upgrade script and not drop then at the end, but then, if you have
some fixes to the functions , they will not run again after the upgrade
script is executed and the refreshstoredprocedure s script will not
refresh the code.
The solution that I suggest here is to enable adding one or more lines
at the start of the upgrade script with
the format:
--#source sql_file
for example :
--#source myfunctions_sp.sql
This will run myfunctions_sp.sql and install its functions before the
upgrade script is running and keep functions (that are not temporary) in
the *_sp.sql files so we can fix a function and refreshstoredprocedures
will install the fixed code.
Change-Id: I91de335159a6c87c0f9d7f1383da25bb93b4a684
Signed-off-by: Eli Mesika <emesika(a)redhat.com>
---
M backend/manager/dbscripts/dbfunctions.sh
M backend/manager/dbscripts/upgrade.sh
2 files changed, 32 insertions(+), 0 deletions(-)
Approvals:
Eli Mesika: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/1214
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I91de335159a6c87c0f9d7f1383da25bb93b4a684
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: webadmin: NPE fix when adding a domain (#856583)
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: webadmin: NPE fix when adding a domain (#856583)
......................................................................
webadmin: NPE fix when adding a domain (#856583)
When trying to add a storage domain with a not-supported format there
was an NPE causing a bad error message instead of the correct one.
This was caused since the StorageModel in StorageListModel
wasn't set to the selected item. It is now.
Change-Id: I07cb27ce4c50410840032cdda06deb3b20a5aa8b
Bug-Url: https://bugzilla.redhat.com/856583
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/storage/StorageListModel.java
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9259
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I07cb27ce4c50410840032cdda06deb3b20a5aa8b
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: webadmin: disks main-tab - disable prefix localization
by ecohen@redhat.com
Einav Cohen has submitted this change and it was merged.
Change subject: webadmin: disks main-tab - disable prefix localization
......................................................................
webadmin: disks main-tab - disable prefix localization
Extract disks search prefix strings to NON-NLS constants.
[disksSearchPrefix("Disks:"), diskTypeSearchPrefix("disk_type = "),
searchConjunctionAnd(" and" ), searchRegexAll("(.)*")]
Since these string are part of the search query,
they should be declared as NON-NLS (Non-National Language Support).
Change-Id: I47b6986b47f6ddca036580310a64716c4519675b
Signed-off-by: Daniel Erez <derez(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/CommonApplicationConstants.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/tab/MainTabDiskView.java
2 files changed, 22 insertions(+), 27 deletions(-)
Approvals:
Daniel Erez: Verified
Einav Cohen: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9296
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I47b6986b47f6ddca036580310a64716c4519675b
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Einav Cohen <ecohen(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: core: Fix log message in VdsInstaller
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: core: Fix log message in VdsInstaller
......................................................................
core: Fix log message in VdsInstaller
The current code uses {1} in a log message with only one parameter, it
should use {0} instead.
Change-Id: Iba1bfd6a35076c9e51cff1959b5a3ea87ed41120
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsInstaller.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Alon Bar-Lev: Looks good to me, but someone else must approve
Juan Hernandez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9291
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iba1bfd6a35076c9e51cff1959b5a3ea87ed41120
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: core:Do not force fencing proxy to be ...(#876235)
by emesika@redhat.com
Eli Mesika has submitted this change and it was merged.
Change subject: core:Do not force fencing proxy to be ...(#876235)
......................................................................
core:Do not force fencing proxy to be ...(#876235)
Do not force fencing proxy to be in UP status
Currently when a host is non-responsive and has Power Management
configured, we are looking for a proxy host in the same cluster to carry
out the fencing commands that will actually reboot the problematic host.
The algorithm of finding such a proxy was up to now to find the first
host that is in UP status in the host DC.
This patch modified the algorithm of proxy finding to
1) Look for a Host in the problematic Host DC which is UP
2) If 1) fails, try to use any other Host in the same DC as a proxy
skipping Hosts is non-operational status with NETWORK_UNREACHABLE reason.
This is done because there is no connection between the Host status and
its ability to carry out proxy commands (which can be done if Host has
network connectivity) although we can assume that a Host that is in UP
status is connected to the network and its chance to succeed in carrying
out the fencing operations is the best.
Change-Id: I437e9b2bb0300f8d71cc8f0c50aaff1b253a63bb
Signed-off-by: Eli Mesika <emesika(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/FencingExecutor.java
1 file changed, 33 insertions(+), 3 deletions(-)
Approvals:
Eli Mesika: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9251
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I437e9b2bb0300f8d71cc8f0c50aaff1b253a63bb
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 1 month