Change in ovirt-engine[master]: webadmin: layout: fix layout in new storage domain - iscsi u...
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: webadmin: layout: fix layout in new storage domain - iscsi username
......................................................................
webadmin: layout: fix layout in new storage domain - iscsi username
Change-Id: I881bb2bf6d79a5c04d87313dd038167db3c1ea5e
Bug-url: https://bugzilla.redhat.com/867428
Signed-off-by: Shahar Havivi <shavivi(a)redhat.com>
---
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/storage/IscsiDiscoverTargetsView.ui.xml
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/storage/StoragePopupView.ui.xml
2 files changed, 15 insertions(+), 12 deletions(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9185
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I881bb2bf6d79a5c04d87313dd038167db3c1ea5e
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Einav Cohen <ecohen(a)redhat.com>
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: core:Force flag should be set from parameters
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core:Force flag should be set from parameters
......................................................................
core:Force flag should be set from parameters
When import VM or VM Template, we should set the force flag in the REST,
and also set the parameter in the engine before calling
MoveOrCopyImageGroupCommand.
Change-Id: Ie3a8de587e9a9384a2cf51dc7435967d46d3d9fd
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
Bug-Url: https://bugzilla.redhat.com/876139
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
M backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata_v-3.1.yaml
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainTemplateResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainVmResource.java
5 files changed, 6 insertions(+), 4 deletions(-)
Approvals:
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9224
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie3a8de587e9a9384a2cf51dc7435967d46d3d9fd
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: engine: Correct migration related events
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: engine: Correct migration related events
......................................................................
engine: Correct migration related events
The misleading events:
"Migration of VM xp_desktop from Host knight failed. Error:
Migration succeeded"
"VM oo is down. Exit message: Migration succeeded"
are no longer printed when the migration process succeeds
Change-Id: I0b92611b423ee3f2336816873505566c41a17b0b
Bug-Url: https://bugzilla.redhat.com/836780
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsUpdateRunTimeInfo.java
1 file changed, 26 insertions(+), 11 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9199
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0b92611b423ee3f2336816873505566c41a17b0b
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: webadmin, engine: Add validation for snapshot description le...
by masayag@redhat.com
Moti Asayag has submitted this change and it was merged.
Change subject: webadmin, engine: Add validation for snapshot description length
......................................................................
webadmin, engine: Add validation for snapshot description length
Add validation which checks that the length of the snapshot
description does not exceed 4000 (GENERAL_MAX_SIZE) characters
at the webadmin dialog for creating snapshot
Add validation which checks that the length of the
snapshot description does not exceed GENERAL_MAX_SIZE
for CreateAllSnapshhotsFromVmCommand in the engine
Change-Id: I780eec76b6eb576d28b3650f4d34384594a8044d
Bug-Url: https://bugzilla.redhat.com/871029
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/CreateAllSnapshotsFromVmParameters.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/gwt-common/src/main/resources/org/ovirt/engine/core/Common.gwt.xml
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/SnapshotModel.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
7 files changed, 15 insertions(+), 1 deletion(-)
Approvals:
Moti Asayag: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9011
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I780eec76b6eb576d28b3650f4d34384594a8044d
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: webadmin: exception on remove network from main tab.
by alkaplan@redhat.com
Alona Kaplan has submitted this change and it was merged.
Change subject: webadmin: exception on remove network from main tab.
......................................................................
webadmin: exception on remove network from main tab.
ClassCastException when removing network from Network Main tab.
Tried to cast NetworkView to Network.
Change-Id: I43cea740c8d3c104b7c3ae43772b7fad473ad7fe
Signed-off-by: Alona Kaplan <alkaplan(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/datacenters/RemoveNetworksModel.java
1 file changed, 27 insertions(+), 12 deletions(-)
Approvals:
Alona Kaplan: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9210
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I43cea740c8d3c104b7c3ae43772b7fad473ad7fe
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: core:Hosts from another data center ...(#874660)
by emesika@redhat.com
Eli Mesika has submitted this change and it was merged.
Change subject: core:Hosts from another data center ...(#874660)
......................................................................
core:Hosts from another data center ...(#874660)
Hosts from another data center displayed when clicked on Hosts in tree view for cluster names with a single difference.
Search Engine is using currently the ILIKE keyword to enable
case-insensitive searches. Postgres treats the character '_' in a value
when using LIKE/ILIKE teh same way as '?' is used for regular
expressions. (i.e. match any single value)
This patch looks for the character '_' in values passed to the search
engine and proceed then with a backslash such that they will be treated
as a regular character and Search Engine will return the correct result.
Change-Id: I2a5e9946f7795827d1abd50f05e641d90802e1e8
Signed-off-by: Eli Mesika <emesika(a)redhat.com>
---
M backend/manager/modules/searchbackend/src/main/java/org/ovirt/engine/core/searchbackend/SyntaxChecker.java
1 file changed, 3 insertions(+), 0 deletions(-)
Approvals:
Eli Mesika: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9207
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2a5e9946f7795827d1abd50f05e641d90802e1e8
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: engine: fix in GlusterManager
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: engine: fix in GlusterManager
......................................................................
engine: fix in GlusterManager
A parallel change in the GlusterServersListVDSCommand had changed the
return type from Set to List. Changing GlusterManager accordingly.
Change-Id: Iefd20756dee267592dfb70754d14f60938973fe6
Signed-off-by: Shireesh Anjal <sanjal(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterManager.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GlusterManagerTest.java
2 files changed, 11 insertions(+), 13 deletions(-)
Approvals:
Omer Frenkel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9135
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iefd20756dee267592dfb70754d14f60938973fe6
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shireesh Anjal <sanjal(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: Shireesh Anjal <sanjal(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: engine: Refactor statements with ternary operators
by masayag@redhat.com
Moti Asayag has submitted this change and it was merged.
Change subject: engine: Refactor statements with ternary operators
......................................................................
engine: Refactor statements with ternary operators
Re-format complex statements with ternary operators in
MigrateVmCommand#getAuditLogTypeValue and
RunVmCommand#getAuditLogTypeValue methods so that they would be
more readable.
Change-Id: I3d28bd2813a69ab4968ac76927f892fccad20164
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java
2 files changed, 20 insertions(+), 11 deletions(-)
Approvals:
Moti Asayag: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9186
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3d28bd2813a69ab4968ac76927f892fccad20164
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
12 years, 1 month
Change in ovirt-engine[master]: core:Fix NPE when import VM with clone
by mlipchuk@redhat.com
Maor Lipchuk has submitted this change and it was merged.
Change subject: core:Fix NPE when import VM with clone
......................................................................
core:Fix NPE when import VM with clone
The following patch should fix an NPE which occurs when importing a
cloned VM or a cloned VM template, which does not exists in the Data
Center.
This exception is caused when trying to copy each disk, and use
the property WipeAfterDelete from the image in the DB,
since the disk does not exists in the DB, we get an NPE.
The proposed fix is to use getDestinationDiskImage to get the
WipeAfterDelete value, instead use the original image with getImage().
Change-Id: I47b8f82a2bd19320d9953df54f9aa16e4ef9200f
Signed-off-by: Maor Lipchuk <mlipchuk(a)redhat.com>
Related to Bug-Url: https://bugzilla.redhat.com/862303
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MoveOrCopyImageGroupCommand.java
1 file changed, 3 insertions(+), 3 deletions(-)
Approvals:
Daniel Erez: Looks good to me, approved
Maor Lipchuk: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9176
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I47b8f82a2bd19320d9953df54f9aa16e4ef9200f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: packaging: Added version dependency for webadmin-portal pack...
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: packaging: Added version dependency for webadmin-portal package
......................................................................
packaging: Added version dependency for webadmin-portal package
Change-Id: I5876c46e9709703f8ae3ff76ef0df9d608d8f45c
Signed-off-by: Alex Lourie <alourie(a)redhat.com>
---
M packaging/fedora/spec/ovirt-engine.spec.in
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9127
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5876c46e9709703f8ae3ff76ef0df9d608d8f45c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alex Lourie <alourie(a)redhat.com>
Gerrit-Reviewer: Alex Lourie <alourie(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Kiril Nesenko <knesenko(a)redhat.com>
Gerrit-Reviewer: Moran Goldboim <mgoldboi(a)redhat.com>
Gerrit-Reviewer: Ofer Schreiber <oschreib(a)redhat.com>
12 years, 1 month