Change in ovirt-engine[master]: core: Cleanup SetupNetworksVDSCommand part 2
by mkolesni@redhat.com
Mike Kolesnik has submitted this change and it was merged.
Change subject: core: Cleanup SetupNetworksVDSCommand part 2
......................................................................
core: Cleanup SetupNetworksVDSCommand part 2
1. Extract putIfNotEmpty method.
2. Cleanup boolean & int handling which could've been done better.
3. Extract constants for bonding keys.
Change-Id: I38b4dba9afd340e05173a21107a69216d8439bcd
Signed-off-by: Mike Kolesnik <mkolesni(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/SetupNetworksVDSCommand.java
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/vdsbroker/SetupNetworksVDSCommandTest.java
2 files changed, 18 insertions(+), 21 deletions(-)
Approvals:
Mike Kolesnik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/5087
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I38b4dba9afd340e05173a21107a69216d8439bcd
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Livnat Peer <lpeer(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: Code cleanup SetupNetworksVDSCommand part 1
by mkolesni@redhat.com
Mike Kolesnik has submitted this change and it was merged.
Change subject: core: Code cleanup SetupNetworksVDSCommand part 1
......................................................................
core: Code cleanup SetupNetworksVDSCommand part 1
Simple cleanup - extracted to methods instead of using comments.
Also removeObj was changed to a contant field.
Change-Id: I5ac56a3c68dc7ecc7fa6f3449c0b7990ce3e5350
Signed-off-by: Mike Kolesnik <mkolesni(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/SetupNetworksVDSCommand.java
1 file changed, 21 insertions(+), 15 deletions(-)
Approvals:
Mike Kolesnik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/5086
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5ac56a3c68dc7ecc7fa6f3449c0b7990ce3e5350
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Livnat Peer <lpeer(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: restapi: Remove redundant field: 'disk-type'
by oliel@redhat.com
Ori Liel has submitted this change and it was merged.
Change subject: restapi: Remove redundant field: 'disk-type'
......................................................................
restapi: Remove redundant field: 'disk-type'
Change-Id: I4d92c15cbfaebf634159692fdc8c445bf5bab85d
Signed-off-by: Ori Liel <oliel(a)redhat.com>
---
M backend/manager/modules/restapi/interface/definition/src/main/resources/api.xsd
M backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata_v-3.1.yaml
2 files changed, 2 insertions(+), 5 deletions(-)
Approvals:
Ori Liel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/4982
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4d92c15cbfaebf634159692fdc8c445bf5bab85d
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: restapi: Fix Vm Display Type Mapping
by oliel@redhat.com
Ori Liel has submitted this change and it was merged.
Change subject: restapi: Fix Vm Display Type Mapping
......................................................................
restapi: Fix Vm Display Type Mapping
Change-Id: I0c26214f97e2b18055bf9504869c6f3ef174eeda
Signed-off-by: Ori Liel <oliel(a)redhat.com>
---
M backend/manager/modules/restapi/types/src/main/java/org/ovirt/engine/api/restapi/types/VmMapper.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Ori Liel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/5101
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0c26214f97e2b18055bf9504869c6f3ef174eeda
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: Cleanup in VdsUpdateRunTimeInfo flow
by lhornyak@redhat.com
Laszlo Hornyak has submitted this change and it was merged.
Change subject: core: Cleanup in VdsUpdateRunTimeInfo flow
......................................................................
core: Cleanup in VdsUpdateRunTimeInfo flow
Cleaned up (some of) the flow of
VdsUpdateRunTimeInfo.checkVdsInterfaces().
This improvement was originally part of
http://gerrit.ovirt.org/#/c/5203, and was separated out of it as per
yzaslavs' comment in gerrit.
Change-Id: I91e6890cb030470d244120254abbc0a986695fbe
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsUpdateRunTimeInfo.java
1 file changed, 11 insertions(+), 10 deletions(-)
Approvals:
Laszlo Hornyak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/5217
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I91e6890cb030470d244120254abbc0a986695fbe
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: Cleanup VdsUpdateRunTimeInfo
by lhornyak@redhat.com
Laszlo Hornyak has submitted this change and it was merged.
Change subject: core: Cleanup VdsUpdateRunTimeInfo
......................................................................
core: Cleanup VdsUpdateRunTimeInfo
Did some cleanup on VdsUpdateRunTimeInfo:
1. Replaced concrete classes with interfaces where possible
2. Replaced FQCNs with imports, including inner classes
3. Added static modifiers to private methods where possible
4. Some indentation issues (auto-fixed by Eclipse IDE)
5. Solved (some) warnings detected by Eclipse IDE
Change-Id: Ief76350281768ceb327b046d526e5450bb3c2bdd
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsUpdateRunTimeInfo.java
1 file changed, 66 insertions(+), 66 deletions(-)
Approvals:
Laszlo Hornyak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/5203
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ief76350281768ceb327b046d526e5450bb3c2bdd
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: restapi: Restore Snapshot Race Condition
by oliel@redhat.com
Ori Liel has submitted this change and it was merged.
Change subject: restapi: Restore Snapshot Race Condition
......................................................................
restapi: Restore Snapshot Race Condition
Change-Id: Icb9d0cc5afb2735fd1228a74ec703073d3ef352c
Signed-off-by: Ori Liel <oliel(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/job/ExecutionHandler.java
1 file changed, 1 insertion(+), 0 deletions(-)
Approvals:
Ori Liel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/4866
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Icb9d0cc5afb2735fd1228a74ec703073d3ef352c
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: Fix VdsUpdateRunTimeInfoTest's package
by lhornyak@redhat.com
Laszlo Hornyak has submitted this change and it was merged.
Change subject: core: Fix VdsUpdateRunTimeInfoTest's package
......................................................................
core: Fix VdsUpdateRunTimeInfoTest's package
Moved VdsUpdateRunTimeInfoTest from
org.ovirt.engine.core.vdsbroker.vdsbroker to
org.ovirt.engine.core.vdsbroker, like VdsUpdateRunTimeInfo.
Change-Id: Idde3f8fa3a18a288605744b548064987278b31a8
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
R backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/VdsUpdateRunTimeInfoTest.java
1 file changed, 1 insertion(+), 4 deletions(-)
Approvals:
Laszlo Hornyak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/5195
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Idde3f8fa3a18a288605744b548064987278b31a8
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: UnPowerMock VdsUpdateRunTimeInfoTest
by lhornyak@redhat.com
Laszlo Hornyak has submitted this change and it was merged.
Change subject: core: UnPowerMock VdsUpdateRunTimeInfoTest
......................................................................
core: UnPowerMock VdsUpdateRunTimeInfoTest
Remover PowerMock depedency from VdsUpdateRunTimeInfoTest.
In order to acheive this improvement, some refactoring was required in
EjbUtils and VdsUpdateRunTimeInfo intself.
EjbUtils is mocked by setting the inner strategy object and returning it
back to the original obejct after the test is done. If this method is
deemed acceptable, perhaps it would be a good idea to extrat it to its
own @Rule.
Change-Id: I5519a02c197b0ef09a9cabd37e6fa90dbecc0897
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ejb/EjbUtils.java
M backend/manager/modules/vdsbroker/pom.xml
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsUpdateRunTimeInfo.java
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsUpdateRunTimeInfoTest.java
4 files changed, 116 insertions(+), 70 deletions(-)
Approvals:
Laszlo Hornyak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/5194
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5519a02c197b0ef09a9cabd37e6fa90dbecc0897
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 7 months
Change in ovirt-engine[master]: core: Minor cleanup in VdsUpdateRunTimeInfoTest
by lhornyak@redhat.com
Laszlo Hornyak has submitted this change and it was merged.
Change subject: core: Minor cleanup in VdsUpdateRunTimeInfoTest
......................................................................
core: Minor cleanup in VdsUpdateRunTimeInfoTest
Replaced assertTrue with assertEquals, for more readable output, and
removed a call to System.out.println.
Change-Id: Ib4a091ee596a03e7710df59de1f1cea95a9b53a9
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsUpdateRunTimeInfoTest.java
1 file changed, 2 insertions(+), 4 deletions(-)
Approvals:
Laszlo Hornyak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/5193
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib4a091ee596a03e7710df59de1f1cea95a9b53a9
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 7 months