Change in ovirt-engine[master]: webadmin: rm Version.OpEquality from DC model
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: webadmin: rm Version.OpEquality from DC model
......................................................................
webadmin: rm Version.OpEquality from DC model
Replaced a call to Version.OpEquality with version.equals(version2),
as it's the standard Java way of doing things, and is easier to read.
This can be done since all the versions in getVersion().getItems()
are ultimately retrieved from
GetAvailableClusterVersionsByStoragePoolQuery, which is guaranteed to
return a List<Version> of non-null elements.
note that this also has a slight theoretical performance benefit, as
nullability is no longer checked on the first operand, but it's
doubtful that this will be be noticeable.
Change-Id: I9a02b827e4c2d1165cb7bdc69cb681df323d4c6f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/datacenters/DataCenterModel.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/21395
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9a02b827e4c2d1165cb7bdc69cb681df323d4c6f
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 5 months
Change in ovirt-engine[master]: core: Version.Op[In]Equality in UpdateStoragePool
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Version.Op[In]Equality in UpdateStoragePool
......................................................................
core: Version.Op[In]Equality in UpdateStoragePool
Replaced calls to Version.OpEquality and Version.OpInequality with
version.equals(version2), as it's the standard Java way of doing
things, and is easier to read.
This can be done since oldSpmVersion is known to be not null be the
following logic:
1. It's retrieved from _oldStoragePool, which is assumed to be
not-null under the CURRENT implementation.
2. This member is retrieved from the database, where the storage_pool
table has a NOT NULL constraint on the compatibility_version
column.
note that this also has a slight theoretical performance benefit, as
nullability is no longer checked on the first operand, but it's
doubtful that this will be be noticeable.
Change-Id: Id36fc037c3597bb01c041850c4eb231a366f79da
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/UpdateStoragePoolCommand.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/21394
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id36fc037c3597bb01c041850c4eb231a366f79da
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 5 months
Change in ovirt-engine[master]: core: Don't use Version.OpEquality in RunVmCommand
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Don't use Version.OpEquality in RunVmCommand
......................................................................
core: Don't use Version.OpEquality in RunVmCommand
In all the (three) places Version.OpEquality is used in RunVmCommand, at
least one of the Version's can be deduced to be non-null.
Under these circumstances, using version.equals(version2) is better, as
it's the standard Java way of doing things, and is easier to read.
Also, note it has a slight theoretical performance benefit, as
nullability is no longer checked on the first operand, but it's doubtful
that this will be be noticeable.
Change-Id: I1e77770ace7f0e6fd06dcea502c427cb202c0f66
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommand.java
1 file changed, 4 insertions(+), 5 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/21393
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1e77770ace7f0e6fd06dcea502c427cb202c0f66
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 5 months
Change in ovirt-engine[master]: core: Rename members in XML-handling classes
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Rename members in XML-handling classes
......................................................................
core: Rename members in XML-handling classes
Renamed methods and data members to start with lower case, as per the
proper Java convention.
Change-Id: I0c42b439c6482650dadb40d08ab5fbf737e0fbdf
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/InstallerMessages.java
M backend/manager/modules/compat/exclude-filters.xml
M backend/manager/modules/compat/src/main/java/org/ovirt/engine/core/compat/backendcompat/XmlDocument.java
M backend/manager/modules/compat/src/main/java/org/ovirt/engine/core/compat/backendcompat/XmlNamespaceManager.java
M backend/manager/modules/compat/src/main/java/org/ovirt/engine/core/compat/backendcompat/XmlNode.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/XmlUtils.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ovf/OvfParser.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ovf/OvfReader.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ovf/OvfTemplateReader.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ovf/OvfVmReader.java
10 files changed, 224 insertions(+), 224 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/21401
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0c42b439c6482650dadb40d08ab5fbf737e0fbdf
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 5 months
Change in ovirt-engine[master]: core: TypeCompat: GetProperties -> getProperties
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: TypeCompat: GetProperties -> getProperties
......................................................................
core: TypeCompat: GetProperties -> getProperties
Renamed method to adhere to proper Java conventions.
Change-Id: If9f2069c43cad0233f2f9e4fbbad01b2bfb39e47
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/compat/src/main/java/org/ovirt/engine/core/compat/backendcompat/TypeCompat.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ObjectIdentityChecker.java
2 files changed, 2 insertions(+), 2 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/21400
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If9f2069c43cad0233f2f9e4fbbad01b2bfb39e47
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 5 months
Change in ovirt-engine[master]: core: char literals in Version
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: char literals in Version
......................................................................
core: char literals in Version
Use char literals instead of string literals in the Version class
wherever possible to (slightly) improve performance.
Change-Id: I57b19b57f405cf83b219715f111f5167a4ffa3fb
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/compat/src/main/java/org/ovirt/engine/core/compat/Version.java
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/21399
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I57b19b57f405cf83b219715f111f5167a4ffa3fb
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 5 months
Change in ovirt-engine[master]: core, webadmin: Remove Version.Op[In]Equality
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core,webadmin: Remove Version.Op[In]Equality
......................................................................
core,webadmin: Remove Version.Op[In]Equality
Removed the useless Version.OpEquality and Version.OpInequality methods
and replaced them with calls to the oVirt-engine standard
OjbectUtils.objectsEqual.
Change-Id: I7d911057368ca19e5ee82b76c23a4bc989433c8b
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/compat/src/main/java/org/ovirt/engine/core/compat/Version.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostGeneralModel.java
2 files changed, 4 insertions(+), 14 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/21398
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7d911057368ca19e5ee82b76c23a4bc989433c8b
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 5 months
Change in ovirt-engine[master]: restapi: Rename glusterhooks --> gluster_hooks
by oliel@redhat.com
Ori Liel has submitted this change and it was merged.
Change subject: restapi: Rename glusterhooks --> gluster_hooks
......................................................................
restapi: Rename glusterhooks --> gluster_hooks
Change-Id: I3964537176980bd009f9fb5cff918d1b8833afc2
Signed-off-by: Ori Liel <oliel(a)redhat.com>
---
M backend/manager/modules/restapi/interface/definition/src/main/resources/api.xsd
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Ori Liel: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/18601
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3964537176980bd009f9fb5cff918d1b8833afc2
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 5 months
Change in ovirt-engine[master]: webadmin: ignore findbug warning regarding GWTBridge
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: webadmin: ignore findbug warning regarding GWTBridge
......................................................................
webadmin: ignore findbug warning regarding GWTBridge
Ignore because this is a class taken from gwt as is.
Change-Id: I6edc24562ed20ade3dc151c3a86d16dca0e6d387
Signed-off-by: Alissa Bonas <abonas(a)redhat.com>
---
M frontend/webadmin/modules/frontend/exclude-filters.xml
1 file changed, 4 insertions(+), 0 deletions(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/21360
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I6edc24562ed20ade3dc151c3a86d16dca0e6d387
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 5 months
Change in ovirt-engine[master]: ui: removed unused member from DataCenterNetworkQosListModel
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: ui: removed unused member from DataCenterNetworkQosListModel
......................................................................
ui: removed unused member from DataCenterNetworkQosListModel
Change-Id: Ia3fef904d66b8febf1bfa462357638e3727144bf
Signed-off-by: Alissa Bonas <abonas(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/datacenters/DataCenterNetworkQoSListModel.java
1 file changed, 4 insertions(+), 5 deletions(-)
Approvals:
Daniel Erez: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/21384
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia3fef904d66b8febf1bfa462357638e3727144bf
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
11 years, 5 months