Change in ovirt-engine[master]: engine: Enable read of current CD via REST
by ofrenkel@redhat.com
Omer Frenkel has submitted this change and it was merged.
Change subject: engine: Enable read of current CD via REST
......................................................................
engine: Enable read of current CD via REST
Added tracking of the current CD for VM (the value resulting from
ChangeDisk).
- On REST side we check for the 'current' matrix param in the GET
request and if present we return the currentCd of the VM instead of
the persistent isoPath.
- Added 'current_cd' to vm_dynamic table to store this value in
VdsBrokerObjectsBuilder.
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1014039
Change-Id: Ifd6c80984143b7d953b6d76b9863465aabce0917
Signed-off-by: Martin Betak <mbetak(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ChangeDiskCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VM.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VmDynamic.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VmDAODbFacadeImpl.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VmDynamicDAODbFacadeImpl.java
M backend/manager/modules/dal/src/test/resources/fixtures.xml
M backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata.yaml
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendCdRomResource.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/AbstractBackendCdRomsResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendCdRomResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendCdRomsResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendReadOnlyCdRomResourceTest.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsBrokerObjectsBuilder.java
M packaging/dbscripts/create_views.sql
A packaging/dbscripts/upgrade/03_04_0600_add_current_cd_to_vm_dynamic.sql
M packaging/dbscripts/vms_sp.sql
16 files changed, 193 insertions(+), 67 deletions(-)
Approvals:
Martin Betak: Verified
Omer Frenkel: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/20368
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifd6c80984143b7d953b6d76b9863465aabce0917
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Martin Betak <mbetak(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mishka8520(a)yahoo.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 11 months
Change in ovirt-log-collector[ovirt-log-collector-3.4]: HyperVisorData: Run ssh with -n
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: HyperVisorData: Run ssh with -n
......................................................................
HyperVisorData: Run ssh with -n
The fix to https://bugzilla.redhat.com/1010472 was to add '-t' to
provide a controlling tty to the remote ausearch. This caused the
tty to be garbled under certain conditions.
A comment in that bug mentions that this is due to ausearch expecting a
log file path on stdin if stdin is a pipe. So this change makes ssh run
with '-n' thus not providing an stdin to the remote command.
Change-Id: Id3e65b5564eb34e72e57f824fb86f9c50acfa1c5
Bug-Url: https://bugzilla.redhat.com/1041749
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
(cherry picked from commit 6de9a18ddcf88d21acc1687fd7bc7e3ac50017b7)
---
M src/__main__.py
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/23796
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id3e65b5564eb34e72e57f824fb86f9c50acfa1c5
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-log-collector
Gerrit-Branch: ovirt-log-collector-3.4
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Kiril Nesenko <knesenko(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 11 months
Change in ovirt-dwh[master]: etl: fixed minimal version check
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: etl: fixed minimal version check
......................................................................
etl: fixed minimal version check
- etl now checks version correctly
- support versions that are more than single digit
Change-Id: I2a5e86d87d0f59abfad7c82b40c5695545b86e1d
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M etl_export/src/ovirt_engine_dwh/minimalversioncheck_3_4/MinimalVersionCheck.java
M tos_project/process/MinimalVersionCheck_3.4.item
M tos_project/process/MinimalVersionCheck_3.4.properties
3 files changed, 107 insertions(+), 32 deletions(-)
Approvals:
Shirly Radco: Verified; Looks good to me, but someone else must approve
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/22831
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2a5e86d87d0f59abfad7c82b40c5695545b86e1d
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-dwh
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
10 years, 11 months
Change in ovirt-engine[master]: findbugs: Dereference after null check in CloudInitHandler
by shavivi@redhat.com
Shahar Havivi has submitted this change and it was merged.
Change subject: findbugs: Dereference after null check in CloudInitHandler
......................................................................
findbugs: Dereference after null check in CloudInitHandler
Bug-Url: https://bugzilla.redhat.com/1051041
Change-Id: Ib49a16302d0d135d1839f64e1e0b79fb8ffe2f39
Signed-off-by: Shahar Havivi <shavivi(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/CloudInitHandler.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Shahar Havivi: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/23728
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib49a16302d0d135d1839f64e1e0b79fb8ffe2f39
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Itamar Heim <iheim(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Shahar Havivi <shavivi(a)redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 11 months
Change in ovirt-engine[master]: core: fix stateless flow in RestoreAllSnapshots
by derez@redhat.com
Daniel Erez has submitted this change and it was merged.
Change subject: core: fix stateless flow in RestoreAllSnapshots
......................................................................
core: fix stateless flow in RestoreAllSnapshots
RestoreAllSnapshotsCommand -> restoreSnapshotAndRemoveObsoleteSnapshots:
* Global member 'imagesToRestore' should be assigned in STATELESS
case as well.
* Decoupled PREVIEW and STATELESS cases for readability and
easier maintenance.
Change-Id: I9aeb6ac37b511e0cd39b290f9571d0a73c7a5717
Bug-Uril: https://bugzilla.redhat.com/1057221
Signed-off-by: Daniel Erez <derez(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RestoreAllSnapshotsCommand.java
1 file changed, 3 insertions(+), 0 deletions(-)
Approvals:
Daniel Erez: Verified
Allon Mureinik: Looks good to me, approved
Arik Hadas: Looks good to me, but someone else must approve
Liron Ar: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/23789
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9aeb6ac37b511e0cd39b290f9571d0a73c7a5717
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Ar <laravot(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
10 years, 11 months
Change in ovirt-reports[ovirt-3.3]: packaging: setup: only ask remote db password once
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: packaging: setup: only ask remote db password once
......................................................................
packaging: setup: only ask remote db password once
Change-Id: Ice74b0179c98071732445b52828f8c4bf9ade17b
Bug-Url: https://bugzilla.redhat.com/1057277
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
---
M packaging/common_utils.py
M packaging/ovirt-engine-reports-setup.py
2 files changed, 30 insertions(+), 33 deletions(-)
Approvals:
Yedidyah Bar David: Verified
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/23775
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ice74b0179c98071732445b52828f8c4bf9ade17b
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-reports
Gerrit-Branch: ovirt-3.3
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
10 years, 11 months
Change in ovirt-reports[master]: packaging: setup: ssl2jkstrust: read chain from connection a...
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: packaging: setup: ssl2jkstrust: read chain from connection and not from context
......................................................................
packaging: setup: ssl2jkstrust: read chain from connection and not from context
this provides the entire chain in more cases, although should be the
other way around.
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1058016
Change-Id: I7e0ae4735cc1ef772e3c703d9bb04e6a01c07532
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M packaging/legacy-setup/ssl2jkstrust.py
1 file changed, 9 insertions(+), 28 deletions(-)
Approvals:
Alon Bar-Lev: Verified
Sandro Bonazzola: Looks good to me, but someone else must approve
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/23735
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7e0ae4735cc1ef772e3c703d9bb04e6a01c07532
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
10 years, 11 months
Change in ovirt-reports[master]: packaging: setup: ssl2jkstrust: do not try to rename if no s...
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: packaging: setup: ssl2jkstrust: do not try to rename if no source
......................................................................
packaging: setup: ssl2jkstrust: do not try to rename if no source
Related-To: https://bugzilla.redhat.com/show_bug.cgi?id=1058016
Change-Id: Ibae6aaff3cff8f056a80ad96494b06f5a70e3f54
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M packaging/legacy-setup/ssl2jkstrust.py
1 file changed, 2 insertions(+), 1 deletion(-)
Approvals:
Alon Bar-Lev: Verified
Sandro Bonazzola: Looks good to me, but someone else must approve
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/23734
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibae6aaff3cff8f056a80ad96494b06f5a70e3f54
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
10 years, 11 months
Change in ovirt-dwh[ovirt-3.3]: packaging: setup: update remote DB interactive messages
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: packaging: setup: update remote DB interactive messages
......................................................................
packaging: setup: update remote DB interactive messages
Was Change-Id I79cd3479c7a16de011e637bd3395b6af99d14b88 but it was
abandoned so can't push an update.
Change-Id: Iae62bd71c7d8ab534b786fb92f977bfe0b77ea27
Bug-Url: https://bugzilla.redhat.com/1057281
Signed-off-by: Alex Lourie <alourie(a)redhat.com>
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
---
M packaging/common_utils.py
M packaging/ovirt-engine-dwh-setup.py
2 files changed, 24 insertions(+), 17 deletions(-)
Approvals:
Yaniv Dary: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/23781
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iae62bd71c7d8ab534b786fb92f977bfe0b77ea27
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-dwh
Gerrit-Branch: ovirt-3.3
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
10 years, 11 months
Change in ovirt-dwh[ovirt-3.3]: packaging: setup: validate read-only user after input
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: packaging: setup: validate read-only user after input
......................................................................
packaging: setup: validate read-only user after input
Do not output "Error: user name cannot be empty" before asking for a
username.
Change-Id: Ia740c9ca659adc4b8ac7d80baad26312db61423c
Bug-Url: https://bugzilla.redhat.com/1057280
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
---
M packaging/ovirt-engine-dwh-setup.py
1 file changed, 3 insertions(+), 1 deletion(-)
Approvals:
Yedidyah Bar David: Verified
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/23777
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia740c9ca659adc4b8ac7d80baad26312db61423c
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-dwh
Gerrit-Branch: ovirt-3.3
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
10 years, 11 months