Change in ovirt-engine[master]: core: log exception when OVF is corrupted
by rgolan@redhat.com
Roy Golan has submitted this change and it was merged.
Change subject: core: log exception when OVF is corrupted
......................................................................
core: log exception when OVF is corrupted
log to error the exception when failing to read the OVF
* move the responsibility for logging error deeper
* throw only 1 checked exception and with the obvious type
* simplify exception stucture
* add debug in case one wants to peek to OVF
Change-Id: Ibc25b6544a698df013fc6d6b2677d798408289a6
Bug-Url: https://bugzilla.redhat.com/1039468
Signed-off-by: Roy Golan <rgolan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetVmFromConfigurationQuery.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/InstallerMessages.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/OvfHelper.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/GetTemplatesFromExportDomainQuery.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/GetVmsFromExportDomainQuery.java
M backend/manager/modules/compat/src/main/java/org/ovirt/engine/core/compat/backendcompat/XmlDocument.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ovf/OvfManager.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ovf/OvfParser.java
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/ovf/OvfReaderException.java
9 files changed, 78 insertions(+), 57 deletions(-)
Approvals:
Roy Golan: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26087
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibc25b6544a698df013fc6d6b2677d798408289a6
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-engine[master]: core: Disallow domains of mixed subtype (file/block) in <3.4...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Disallow domains of mixed subtype (file/block) in <3.4 storage pool
......................................................................
core: Disallow domains of mixed subtype (file/block) in <3.4 storage pool
Disallow adding domains of a different subtype (file/block) that the
domains alread contained in the pool with a compatibility version lower
than 3.4 which contains domain
Change-Id: I8226c29e6c34ab6434d0a5ec07aa7fa1d4d00306
Bug-Url: https://bugzilla.redhat.com/1083560
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/StorageHandlingCommandBase.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/StorageHandlingCommandBaseTest.java
2 files changed, 37 insertions(+), 13 deletions(-)
Approvals:
Tal Nisan: Verified
Allon Mureinik: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26366
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8226c29e6c34ab6434d0a5ec07aa7fa1d4d00306
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Federico Simoncelli <fsimonce(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-engine[master]: core: Add config values for mixed domain types in data center
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Add config values for mixed domain types in data center
......................................................................
core: Add config values for mixed domain types in data center
Change-Id: I9dd924bd1e53136fc5a1b6195700c7920658dde0
Bug-Url: https://bugzilla.redhat.com/1083560
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/FeatureSupported.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/config/ConfigValues.java
M packaging/dbscripts/upgrade/pre_upgrade/0000_config.sql
3 files changed, 19 insertions(+), 0 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26467
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9dd924bd1e53136fc5a1b6195700c7920658dde0
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Federico Simoncelli <fsimonce(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-reports[ovirt-3.3]: packaging: setup: less strict parsing of pg_hba.conf
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: packaging: setup: less strict parsing of pg_hba.conf
......................................................................
packaging: setup: less strict parsing of pg_hba.conf
When checking the 'local' line, do not check exact spaces.
Code partially copied from engine.
Bug-Url: https://bugzilla.redhat.com/1085374
Change-Id: I25124c36de491de9aad0917f60b8f420168aa316
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
---
M packaging/common_utils.py
1 file changed, 19 insertions(+), 16 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, but someone else must approve
Yedidyah Bar David: Verified
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26529
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I25124c36de491de9aad0917f60b8f420168aa316
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-reports
Gerrit-Branch: ovirt-3.3
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 8 months
Change in ovirt-engine[master]: restapi: Remove dynamic queries from storage REST API
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Remove dynamic queries from storage REST API
......................................................................
restapi: Remove dynamic queries from storage REST API
Dynamic search is extremely slow. This patch removes the usage of
dynamic search from the Storage Rest API.
Change-Id: I501058a88005df117a492ce8ece3f16ddbbd1e66
Signed-off-by: lzelkha(a)redhat.com <lzelkha(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainsResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendStorageServerConnectionResource.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendStorageDomainsResourceTest.java
4 files changed, 43 insertions(+), 24 deletions(-)
Approvals:
Juan Hernandez: Looks good to me, approved
Liran Zelkha: Verified
--
To view, visit http://gerrit.ovirt.org/26303
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I501058a88005df117a492ce8ece3f16ddbbd1e66
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Liran Zelkha <lzelkha(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Liran Zelkha <lzelkha(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-dwh[ovirt-3.3]: packaging: setup: less strict parsing of pg_hba.conf
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: packaging: setup: less strict parsing of pg_hba.conf
......................................................................
packaging: setup: less strict parsing of pg_hba.conf
When checking the 'local' line, do not check exact spaces.
Code partially copied from engine.
Bug-Url: https://bugzilla.redhat.com/1084760
Change-Id: I374d578735c910451bc7698444a446728b33fd58
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
---
M packaging/common_utils.py
1 file changed, 19 insertions(+), 16 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, but someone else must approve
Yedidyah Bar David: Verified
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26528
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I374d578735c910451bc7698444a446728b33fd58
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-dwh
Gerrit-Branch: ovirt-3.3
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 8 months
Change in ovirt-release[master]: Update nightly repos
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: Update nightly repos
......................................................................
Update nightly repos
Change-Id: I7ae65d840e4d2553dc72c85e63f2c8a03a9038d8
Signed-off-by: Kiril Nesenko <knesenko(a)redhat.com>
---
M configure.ac
M ovirt-nightly.repo.in
M ovirt-release.spec.in
3 files changed, 11 insertions(+), 8 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Kiril Nesenko: Verified
Yedidyah Bar David: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/26502
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7ae65d840e4d2553dc72c85e63f2c8a03a9038d8
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-release
Gerrit-Branch: master
Gerrit-Owner: Kiril Nesenko <knesenko(a)redhat.com>
Gerrit-Reviewer: David Caro <dcaroest(a)redhat.com>
Gerrit-Reviewer: Eyal Edri <eedri(a)redhat.com>
Gerrit-Reviewer: Kiril Nesenko <knesenko(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months
Change in ovirt-reports[master]: reports: edited ic query-only_hosts_is_deleted
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: reports: edited ic query-only_hosts_is_deleted
......................................................................
reports: edited ic query-only_hosts_is_deleted
I edited the, only_hosts_is_deleted, input control query,
so it will be more readable and added comments.
Change-Id: I364d942e143cb70cdc1b2ccf10800241282cf8ac
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M packaging/ovirt-reports/resources/reports_resources/JDBC/Input_Controls/Regular_Input_Controls/Only_Hosts/active_hosts_select.xml
1 file changed, 64 insertions(+), 19 deletions(-)
Approvals:
Shirly Radco: Verified; Looks good to me, but someone else must approve
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26286
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I364d942e143cb70cdc1b2ccf10800241282cf8ac
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 8 months
Change in ovirt-reports[master]: reports: br46 report - added comments to queries
by ydary@redhat.com
Yaniv Dary has submitted this change and it was merged.
Change subject: reports: br46 report - added comments to queries
......................................................................
reports: br46 report - added comments to queries
Changed the code structure so it will be more readable
and added commets.
Change-Id: Icbd9d94d77dc3c890adf57fe64fe934de09e537f
Signed-off-by: Shirly Radco <sradco(a)redhat.com>
---
M packaging/ovirt-reports/resources/Reports/Service_level/VMs/single_vm_uptime_br46_files/full details.jrxml.data
M packaging/ovirt-reports/resources/Reports/Service_level/VMs/single_vm_uptime_br46_files/single_vm_uptime_br46_jrxml.data
2 files changed, 713 insertions(+), 547 deletions(-)
Approvals:
Shirly Radco: Verified; Looks good to me, but someone else must approve
Yaniv Dary: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/26354
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Icbd9d94d77dc3c890adf57fe64fe934de09e537f
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-reports
Gerrit-Branch: master
Gerrit-Owner: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Shirly Radco <sradco(a)redhat.com>
Gerrit-Reviewer: Yaniv Dary <ydary(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 8 months
Change in ovirt-engine[master]: restapi: Remove dynamic searches from BackendVmPoolResource
by emesika@redhat.com
Eli Mesika has submitted this change and it was merged.
Change subject: restapi: Remove dynamic searches from BackendVmPoolResource
......................................................................
restapi: Remove dynamic searches from BackendVmPoolResource
Dynamic search is extremely slow. This patch removes the usage of
dynamic search from the BackendVmPoolResource class.
Change-Id: I0a9c1c31865849bce8a32c75842ebf99a387795d
Signed-off-by: lzelkha(a)redhat.com <lzelkha(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendVmPoolResource.java
1 file changed, 5 insertions(+), 2 deletions(-)
Approvals:
Juan Hernandez: Looks good to me, approved
Liran Zelkha: Verified
--
To view, visit http://gerrit.ovirt.org/26067
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0a9c1c31865849bce8a32c75842ebf99a387795d
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Liran Zelkha <lzelkha(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Liran Zelkha <lzelkha(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 8 months