Change in ovirt-engine[master]: core: introduce AddStorageDomainCommonTest
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: introduce AddStorageDomainCommonTest
......................................................................
core: introduce AddStorageDomainCommonTest
An initial test case for AddStorageDomainCommon, focusing mainly
on its canDoAction() method.
Change-Id: I5e07f7fe5988dab9f37ecc040cdf3d839d776e23
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
A backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/AddStorageDomainCommonTest.java
1 file changed, 198 insertions(+), 0 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/30950
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5e07f7fe5988dab9f37ecc040cdf3d839d776e23
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[master]: core: AddStorageDomainCommand javadoc cleanup
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AddStorageDomainCommand javadoc cleanup
......................................................................
core: AddStorageDomainCommand javadoc cleanup
Removed useless javadoc for class' constructor.
Change-Id: I7efbe13e83c978d0eb8eb71f543adec2aef69406
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/AddStorageDomainCommand.java
1 file changed, 0 insertions(+), 6 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/30956
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7efbe13e83c978d0eb8eb71f543adec2aef69406
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[master]: core: AddStorageDomainCommand use of HashMap
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AddStorageDomainCommand use of HashMap
......................................................................
core: AddStorageDomainCommand use of HashMap
Weaken HashMap declarations to Maps wherever possible.
Change-Id: Ifcbecd38ef12b6f42c99c55a79dc6c3eb39886fb
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/AddStorageDomainCommand.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/30957
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifcbecd38ef12b6f42c99c55a79dc6c3eb39886fb
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[master]: core: AddStorageDomainCommand constructor
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AddStorageDomainCommand constructor
......................................................................
core: AddStorageDomainCommand constructor
Made the constructor protected, as per Java's conventions for abstract
classes.
Change-Id: If08def362e0797de3b2acfe1ee917ff09abcdf8e
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/AddStorageDomainCommand.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/30955
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If08def362e0797de3b2acfe1ee917ff09abcdf8e
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[master]: core: AddStorageDomainCommand singleton list
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AddStorageDomainCommand singleton list
......................................................................
core: AddStorageDomainCommand singleton list
Use Collections.singletonList instead of Arrays.asList wherever possible
to improve readability and increase performance.
Change-Id: Ic973514f0545256238725f7aba17ad9cc850318e
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/AddStorageDomainCommand.java
1 file changed, 2 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/30954
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic973514f0545256238725f7aba17ad9cc850318e
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[master]: core: AddStorageDomainCommand.getTargetStoragePool
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AddStorageDomainCommand.getTargetStoragePool
......................................................................
core: AddStorageDomainCommand.getTargetStoragePool
Extracted AddStorageDomainCommand.getTargetStoragePool for later use
(not to mention the increased readability).
Change-Id: I3776beb5a7426e010f05ca0b4f3dffb128346ed7
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/AddStorageDomainCommand.java
1 file changed, 11 insertions(+), 5 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified
--
To view, visit http://gerrit.ovirt.org/30959
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3776beb5a7426e010f05ca0b4f3dffb128346ed7
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
10 years, 4 months
Change in ovirt-engine[master]: core: Enable single-entry MAC range in engine-config
by lvernia@redhat.com
Lior Vernia has submitted this change and it was merged.
Change subject: core: Enable single-entry MAC range in engine-config
......................................................................
core: Enable single-entry MAC range in engine-config
This was previously wrongly blocked. It also seems like the utility
class blocking this had another logical issue - in cases where
multiple ranges need to be handled (I don't see that this can happen
at the moment but the code seems to take that into consideration),
true would be returned if at least one of the ranges were valid -
instead of false being returned if at least one of the ranges were
invalid.
Change-Id: I0e439d1b60cc15792ad7e3ce6596f65a78c81b48
Bug-Url: https://bugzilla.redhat.com/1126181
Signed-off-by: Lior Vernia <lvernia(a)redhat.com>
---
M backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/MacAddressRangeUtils.java
M backend/manager/tools/src/test/java/org/ovirt/engine/core/config/entity/helper/MacAddressPoolRangesValueHelperTest.java
2 files changed, 4 insertions(+), 3 deletions(-)
Approvals:
Lior Vernia: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/30965
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0e439d1b60cc15792ad7e3ce6596f65a78c81b48
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Lior Vernia <lvernia(a)redhat.com>
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[master]: core: avoid failover on setVolumeDescription default fail
by laravot@redhat.com
Liron Aravot has submitted this change and it was merged.
Change subject: core: avoid failover on setVolumeDescription default fail
......................................................................
core: avoid failover on setVolumeDescription default fail
failues when executing setVolumeDescription shouldn't
trigger the spm failover.
Change-Id: I1db19b03e53ddaa17a941c373668f157b75665b9
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1126782
Signed-off-by: Liron Aravot <laravot(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/SetVolumeDescriptionVDSCommand.java
1 file changed, 6 insertions(+), 0 deletions(-)
Approvals:
Allon Mureinik: Looks good to me, approved
Liron Aravot: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/31014
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1db19b03e53ddaa17a941c373668f157b75665b9
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[ovirt-engine-3.5]: core: Adding context ctor to UpgradeOvirtNodeInternalCommand
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Adding context ctor to UpgradeOvirtNodeInternalCommand
......................................................................
core: Adding context ctor to UpgradeOvirtNodeInternalCommand
I still fail to understand why not add to all commands.
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1120720
Change-Id: I0555fd221f1fd3dfd8c4dbd35e5cc0fc919b3906
Signed-off-by: Alon Bar-Lev <alonbl(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpgradeOvirtNodeInternalCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/UpgradeOvirtNodeInternalCommandTest.java
2 files changed, 6 insertions(+), 5 deletions(-)
Approvals:
Alon Bar-Lev: Verified
Oved Ourfali: Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/31053
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0555fd221f1fd3dfd8c4dbd35e5cc0fc919b3906
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.5
Gerrit-Owner: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months
Change in ovirt-engine[ovirt-engine-3.4]: core: allow read-only for VirtIO-SCSI DirectLUN disks
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: core: allow read-only for VirtIO-SCSI DirectLUN disks
......................................................................
core: allow read-only for VirtIO-SCSI DirectLUN disks
In order to support read-only property for VirtIO-SCSI
DirectLUN disks, the device type for such disks should
be 'disk' (SCSI emulation) instead of 'lun' (SCSI pass-through).
I.e. representation in the domain xml sent to libvirt should
look like [1] instead of [2].
Note that this limitation (enabling pass-through for read-only
VirtIO-SCSI DirectLUN disks) could be removed once 'Support
read only VirtIO-SCSI direct LUNs in QEMU' bug [3] is resolved.
To provide full flexibility, added a new check-box for enabling
pass-through (see screenshot [4]). I.e. the user can choose between
emulated and pass-through ('disk' vs. 'lun'); read-only is
currently supported only for emulated.
[1] <disk type='block' device='disk'>...</disk>
[2] <disk type='block' device='lun'>...</disk>
[3] https://bugzilla.redhat.com/1110396
[4] screenshot: http://i.imgur.com/5mS3xSk.jpg
Change-Id: Ic317722be9ef8978b50352c12bc06ea8c906dcd0
Bug-Url: https://bugzilla.redhat.com/1125373
Signed-off-by: Daniel Erez <derez(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddDiskCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AttachDiskToVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmDiskCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/DiskValidator.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AddDiskToVmCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/validator/DiskValidatorTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/BaseDisk.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/VdcBllMessages.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/HotPlugDiskVDSCommand.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VmInfoBuilder.java
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/CommonApplicationConstants.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/vm/VmDiskPopupWidget.java
M frontend/webadmin/modules/gwt-common/src/main/java/org/ovirt/engine/ui/common/widget/uicommon/popup/vm/VmDiskPopupWidget.ui.xml
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/AbstractDiskModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/EditDiskModel.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/UIConstants.java
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
A packaging/dbscripts/upgrade/03_04_0800_update_sgio_for_readonly_disks.sql
21 files changed, 168 insertions(+), 59 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Daniel Erez: Verified
Allon Mureinik: Looks good to me, but someone else must approve
--
To view, visit http://gerrit.ovirt.org/30905
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic317722be9ef8978b50352c12bc06ea8c906dcd0
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.4
Gerrit-Owner: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
10 years, 4 months