Change in ovirt-engine[master]: core: GetNonEligibilityReasonsOfVolumeForGeoRepSessionQueryT...
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetNonEligibilityReasonsOfVolumeForGeoRepSessionQueryTest generics
......................................................................
core: GetNonEligibilityReasonsOfVolumeForGeoRepSessionQueryTest generics
Replace the cumbersome generic specification with the more readable Java
7 diamond operator.
Change-Id: I8435ab397ab762673744333c19e4e02e1f769b4f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetNonEligibilityReasonsOfVolumeForGeoRepSessionQueryTest.java
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Sahina Bose: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/48946
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8435ab397ab762673744333c19e4e02e1f769b4f
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 1 month
Change in ovirt-engine[master]: core: Test GetGlusterGeoReplicationEligibleVolumesQuery#getE...
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Test GetGlusterGeoReplicationEligibleVolumesQuery#getEligibleVolumes
......................................................................
core: Test GetGlusterGeoReplicationEligibleVolumesQuery#getEligibleVolumes
Enhanced GetGlusterGeoReplicationEligibleVolumesQueryTest so that
getEligibleVolumes is also tested, as it has some non-trivial logic.
This is done in order to facilitate the refactoring of this method.
Change-Id: Ifee0119d1ee0d26cac0543f870e3d7fa44a12672
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GetGlusterGeoReplicationEligibleVolumesQuery.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetGlusterGeoReplicationEligibleVolumesQueryTest.java
2 files changed, 7 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
anmolbabu: Looks good to me, but someone else must approve
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/48945
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifee0119d1ee0d26cac0543f870e3d7fa44a12672
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: anmolbabu <anbabu(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 1 month
Change in ovirt-engine[master]: core: getEligibleVolumes performance
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: getEligibleVolumes performance
......................................................................
core: getEligibleVolumes performance
getEligibleVolumes traverses a list of GlusterVolumeEntitys and
filters it by a different predicate in each pass, resulting in a list
of GlusterVolumeEntitys that pass all the predicates.
This patch improves this method's performance by unifying all the
predicates to a single predicate using Predicate::and and then uses it
to filter the list. This change offers a slight performance
improvement as it saves the need to collect the results into a
different list each iteration.
Change-Id: I18b691366e4588263dcb99fe18d644f751458e69
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GetGlusterGeoReplicationEligibleVolumesQuery.java
1 file changed, 2 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/48953
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I18b691366e4588263dcb99fe18d644f751458e69
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: anmolbabu <anbabu(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 1 month
Change in ovirt-engine[master]: core: getEligibleVolumes map iteration
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: getEligibleVolumes map iteration
......................................................................
core: getEligibleVolumes map iteration
Replace the entrySet() iteration with an iteration over the values(),
since the key is never used, and it just makes the code more complicated
to understand.
Change-Id: I445c92072238776d33cc805346d04fef2a8a5cdc
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GetGlusterGeoReplicationEligibleVolumesQuery.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Sahina Bose: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/48952
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I445c92072238776d33cc805346d04fef2a8a5cdc
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 1 month
Change in ovirt-engine[master]: core: GlusterGeoRepUtil#getSessionSlaveVolumeIds
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GlusterGeoRepUtil#getSessionSlaveVolumeIds
......................................................................
core: GlusterGeoRepUtil#getSessionSlaveVolumeIds
Simplified the method by using the modern Java 8 collect approach
instead of coding the transformation in the method.
Change-Id: I9b092cf47fd7e062bfb6a780f01a930f81f65de4
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/utils/GlusterGeoRepUtil.java
1 file changed, 2 insertions(+), 6 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Sahina Bose: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/48951
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9b092cf47fd7e062bfb6a780f01a930f81f65de4
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 1 month
Change in ovirt-engine[master]: core: GetGlusterGeoReplicationEligibleVolumesQueryTest generics
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetGlusterGeoReplicationEligibleVolumesQueryTest generics
......................................................................
core: GetGlusterGeoReplicationEligibleVolumesQueryTest generics
Used Java 7's diamond generics to improve the code's readability.
Change-Id: I5b237a2860cd7633313daa60334391a5f0a15195
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetGlusterGeoReplicationEligibleVolumesQueryTest.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Sahina Bose: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/48895
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5b237a2860cd7633313daa60334391a5f0a15195
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 1 month
Change in ovirt-engine[master]: core: GetGlusterGeoReplicationEligibleVolumesQueryTest casts
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: GetGlusterGeoReplicationEligibleVolumesQueryTest casts
......................................................................
core: GetGlusterGeoReplicationEligibleVolumesQueryTest casts
Removed redundant cast.
Change-Id: Ie3f842044d667d4f43015ad6eb9db2d81d125d02
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetGlusterGeoReplicationEligibleVolumesQueryTest.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Sahina Bose: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/48894
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie3f842044d667d4f43015ad6eb9db2d81d125d02
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sahina Bose <sabose(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 1 month
Change in ovirt-engine[master]: core: VdsSpmIdMap naming conventions
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: VdsSpmIdMap naming conventions
......................................................................
core: VdsSpmIdMap naming conventions
Renamed vds_spm_id_map to use the proper Java naming convention,
VdsSpmIdMap. Member, parameter and local variable names were amended
accordingly.
Change-Id: Ida163cc4d3ffec991e3e025c651b8aa0f023c212
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVdsSpmIdCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/pm/FenceAgentExecutor.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AddVdsSpmIdCommandTest.java
A backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/VdsSpmIdMap.java
D backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/vds_spm_id_map.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/dbbroker/DbFacade.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VdsSpmIdMapDao.java
M backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/VdsSpmIdMapDaoImpl.java
M backend/manager/modules/dal/src/test/java/org/ovirt/engine/core/dao/VdsSpmIdMapDaoTest.java
M backend/manager/modules/utils/src/test/java/org/ovirt/engine/core/utils/serialization/json/JsonObjectSerializationEntitiesTest.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/IrsProxyData.java
11 files changed, 130 insertions(+), 135 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/49190
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ida163cc4d3ffec991e3e025c651b8aa0f023c212
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 1 month
Change in ovirt-engine[ovirt-engine-3.6.1]: core, restapi: fixed potential NPE and removed duplicity
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core,restapi: fixed potential NPE and removed duplicity
......................................................................
core,restapi: fixed potential NPE and removed duplicity
Change-Id: Ia913e0f2069fa63b07be3f640600c1867406eda7
Signed-off-by: Martin Mucha <mmucha(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/network/VdsNetworkInterface.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendHostNicsResource.java
2 files changed, 2 insertions(+), 6 deletions(-)
Approvals:
Martin Mucha: Verified
Alona Kaplan: Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/49123
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia913e0f2069fa63b07be3f640600c1867406eda7
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.1
Gerrit-Owner: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 1 month
Change in ovirt-engine[ovirt-engine-3.6]: core: when switching macPool assigned to DC, MACs has to be ...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: when switching macPool assigned to DC, MACs has to be moved between pools.
......................................................................
core: when switching macPool assigned to DC, MACs has to be moved between pools.
When new mac pool is different from old mac pool, all mac addresses of
NICs belonging to this DC has to be released from old mac pool and
added to new one.
Change-Id: I1a14c49c3af8e7a4268b40f52bba9767c05120cf
Bug-Url: https://bugzilla.redhat.com/1269846
Signed-off-by: Martin Mucha <mmucha(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/macpoolmanager/MacPoolPerDc.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/UpdateStoragePoolCommand.java
2 files changed, 64 insertions(+), 2 deletions(-)
Approvals:
Martin Mucha: Verified
Alona Kaplan: Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/49124
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1a14c49c3af8e7a4268b40f52bba9767c05120cf
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6
Gerrit-Owner: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
9 years, 1 month