Change in ovirt-engine[master]: webadmin: new cluster->fence agent policy
by awels@redhat.com
Alexander Wels has submitted this change and it was merged.
Change subject: webadmin: new cluster->fence agent policy
......................................................................
webadmin: new cluster->fence agent policy
- Replaced cluster fence agent policy with bootstrap grid
layout, instead of horizontal/vertical panel layout.
- Fixed layout issue with enable fencing check box.
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1236972
Change-Id: Iff3668d6dc1b9bd8be966029a6798edce93cc5e8
Signed-off-by: Alexander Wels <awels(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/cluster/ClusterPopupView.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/cluster/ClusterPopupView.ui.xml
2 files changed, 43 insertions(+), 24 deletions(-)
Approvals:
Alexander Wels: Verified
Jenkins CI: Passed CI tests
Greg Sheremeta: Looks good to me, approved
Oved Ourfali: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/43128
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iff3668d6dc1b9bd8be966029a6798edce93cc5e8
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Einav Cohen <ecohen(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: webadmin: Search bar for Events main tab.
by awels@redhat.com
Alexander Wels has submitted this change and it was merged.
Change subject: webadmin: Search bar for Events main tab.
......................................................................
webadmin: Search bar for Events main tab.
- Fixed issue where the search bar was attached to the wrong
EventListModel and would not update the event main tab properly.
Change-Id: I1ca1da52aa4de015684c4e0ba5dcb87b50643b40
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1238174
Signed-off-by: Alexander Wels <awels(a)redhat.com>
---
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/CommonModel.java
1 file changed, 14 insertions(+), 7 deletions(-)
Approvals:
Alexander Wels: Verified
Jenkins CI: Passed CI tests
Greg Sheremeta: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/43404
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1ca1da52aa4de015684c4e0ba5dcb87b50643b40
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Einav Cohen <ecohen(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: minor cleanup in VmStatsRefresher
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: minor cleanup in VmStatsRefresher
......................................................................
core: minor cleanup in VmStatsRefresher
Rename VMStatsRefresher#perform to 'poll' since this periodic method is
intended for periodic polling.
Change-Id: I795337c1cf0b36c42a76772e731552ca0ae9c206
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/PollVMStatsRefresher.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VMStatsRefresher.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/EventVMStatsRefresher.java
3 files changed, 6 insertions(+), 6 deletions(-)
Approvals:
Omer Frenkel: Looks good to me, approved
Arik Hadas: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/42786
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I795337c1cf0b36c42a76772e731552ca0ae9c206
Gerrit-PatchSet: 13
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: minor cleanup in VdsManager
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: minor cleanup in VdsManager
......................................................................
core: minor cleanup in VdsManager
Rename VdsManager#getRefreshStatistics to isTimeToRefreshStatistics and
change its visibility to package-protected.
In addition the visibility of VdsManager#updateIteration is changed to
private.
Change-Id: Ic7929d267bcf7e3c4d7937ff2a97157436165b57
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/HostMonitoring.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsManager.java
M backend/manager/modules/vdsbroker/src/test/java/org/ovirt/engine/core/vdsbroker/HostMonitoringTest.java
3 files changed, 5 insertions(+), 5 deletions(-)
Approvals:
Omer Frenkel: Looks good to me, approved
Arik Hadas: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/42785
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic7929d267bcf7e3c4d7937ff2a97157436165b57
Gerrit-PatchSet: 13
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: separate iteration count for vms and host monitoring
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: separate iteration count for vms and host monitoring
......................................................................
core: separate iteration count for vms and host monitoring
Host and VMs monitoring are now two different quartz jobs. It does not
makes sense that they will use the same counter to count their
iterations.
This patch adds new counter in VdsManager for counting the host
monitoring iterations. This counter works exactly as the counter in
VMStatsRefresher worked before. In addition the counting of iterations
of VMs monitoring is simplified.
Change-Id: I80e37c501de4f4117400e21c6ceef86911515c89
Signed-off-by: Arik Hadas <ahadas(a)redhat.com>
---
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/PollVMStatsRefresher.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VMStatsRefresher.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsManager.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/EventVMStatsRefresher.java
4 files changed, 28 insertions(+), 19 deletions(-)
Approvals:
Omer Frenkel: Looks good to me, approved
Arik Hadas: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/42784
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I80e37c501de4f4117400e21c6ceef86911515c89
Gerrit-PatchSet: 13
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-hosted-engine-setup[master]: packaging: setup: fixing text message waiting for recovery a...
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: setup: fixing text message waiting for recovery actions
......................................................................
packaging: setup: fixing text message waiting for recovery actions
check_liveness.manualSetupDispatcher can be called in three
different situations:
0. The OS has been installed
1. The engine has been installed
2. Manual fixup actions has been performed on the engine VM
Fixing text message for the last case.
Change-Id: I2b7aa2b77d1efd7051bedc09e19ada8867af0298
Signed-off-by: Simone Tiraboschi <stirabos(a)redhat.com>
---
M src/ovirt_hosted_engine_setup/check_liveliness.py
M src/plugins/ovirt-hosted-engine-setup/engine/add_host.py
M src/plugins/ovirt-hosted-engine-setup/engine/health.py
M src/plugins/ovirt-hosted-engine-setup/vm/runvm.py
4 files changed, 72 insertions(+), 45 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Simone Tiraboschi: Verified
Jenkins CI: Passed CI tests
Yedidyah Bar David: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/43669
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2b7aa2b77d1efd7051bedc09e19ada8867af0298
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-hosted-engine-setup
Gerrit-Branch: master
Gerrit-Owner: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Lev Veyde <lveyde(a)redhat.com>
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in jenkins[master]: vdsm: fix 3.5 repos URL
by dcaroest@redhat.com
David Caro has submitted this change and it was merged.
Change subject: vdsm: fix 3.5 repos URL
......................................................................
vdsm: fix 3.5 repos URL
Change-Id: I3736cabc9dd7d72751d47af415c431dca9f7bc6e
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M jobs/confs/yaml/jobs/vdsm/vdsm_create-rpms.yaml
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Ready for merge
Jenkins CI: Passed CI tests
David Caro: Looks good to me
--
To view, visit https://gerrit.ovirt.org/43658
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3736cabc9dd7d72751d47af415c431dca9f7bc6e
Gerrit-PatchSet: 1
Gerrit-Project: jenkins
Gerrit-Branch: master
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: David Caro <dcaroest(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
9 years, 5 months
Change in ovirt-engine[master]: core: Corrected type in HotSetNumberOfCpusParameters class
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Corrected type in HotSetNumberOfCpusParameters class
......................................................................
core: Corrected type in HotSetNumberOfCpusParameters class
The class name had a type and was called HotSetNumerOfCpusParameters
Change-Id: I415e2ef16127f65a2cc4de2654ee29e59571025b
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/HotSetNumberOfCpusCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmCommand.java
R backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/HotSetNumberOfCpusParameters.java
3 files changed, 9 insertions(+), 9 deletions(-)
Approvals:
Tal Nisan: Verified; Passed CI tests
Roy Golan: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/43650
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I415e2ef16127f65a2cc4de2654ee29e59571025b
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: webadmin: cluster custom scheduling policy
by awels@redhat.com
Alexander Wels has submitted this change and it was merged.
Change subject: webadmin: cluster custom scheduling policy
......................................................................
webadmin: cluster custom scheduling policy
- The custom cluster scheduling policy drop down
was not big enough to hold all locale translations.
This patch makes the drop down auto size to fit all
locales
Change-Id: I0689ea6bff0c7df12214c57153d293d1532b8fd2
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1236949
Signed-off-by: Alexander Wels <awels(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/section/main/view/popup/cluster/ClusterPopupView.java
1 file changed, 3 insertions(+), 1 deletion(-)
Approvals:
Alexander Wels: Verified
Jenkins CI: Passed CI tests
Greg Sheremeta: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/43253
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0689ea6bff0c7df12214c57153d293d1532b8fd2
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Einav Cohen <ecohen(a)redhat.com>
Gerrit-Reviewer: Greg Sheremeta <gshereme(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-hosted-engine-setup[master]: packaging: setup: avoid re-creating SP on additional hosts
by sbonazzo@redhat.com
Sandro Bonazzola has submitted this change and it was merged.
Change subject: packaging: setup: avoid re-creating SP on additional hosts
......................................................................
packaging: setup: avoid re-creating SP on additional hosts
Now hosted-engine disconnect its storage domain form the storage pool
in order to import it into the engine; than it destroy the pool.
Avoid recreating it on additional hosts.
Change-Id: I3561a2ff12e944d3e3521f1a109c7ad44d7180b8
Signed-off-by: Simone Tiraboschi <stirabos(a)redhat.com>
---
M src/plugins/ovirt-hosted-engine-setup/storage/storage.py
1 file changed, 4 insertions(+), 4 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, approved
Simone Tiraboschi: Verified
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/43654
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I3561a2ff12e944d3e3521f1a109c7ad44d7180b8
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-hosted-engine-setup
Gerrit-Branch: master
Gerrit-Owner: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months