Change in ovirt-engine[master]: core: Inline useless constants
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Inline useless constants
......................................................................
core: Inline useless constants
Inlined constants in AddExistingFileStorageDomainCommandTest, which just
repeat the conf. values they represent
Change-Id: I08e924a5f6a05cdfb0c3e437a2f9c0c94951e0de
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/AddExistingFileStorageDomainCommandTest.java
1 file changed, 3 insertions(+), 7 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/43514
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I08e924a5f6a05cdfb0c3e437a2f9c0c94951e0de
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: AttachStorageDomainToPoolCommandTest generics
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AttachStorageDomainToPoolCommandTest generics
......................................................................
core: AttachStorageDomainToPoolCommandTest generics
Used proper Java 7 diamond generics and removed redundant generics
definitions.
Change-Id: I21efb67ea4e5dc1acb12b37afcefd62889ec28c9
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/AttachStorageDomainToPoolCommandTest.java
1 file changed, 2 insertions(+), 3 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/43519
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I21efb67ea4e5dc1acb12b37afcefd62889ec28c9
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: AttachStorageDomainToPoolCommandTest members
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: AttachStorageDomainToPoolCommandTest members
......................................................................
core: AttachStorageDomainToPoolCommandTest members
Made AttachStorageDomainToPoolCommandTest's members private and removed
redundant initilizers.
Change-Id: I432ce03d4fd0359d95262c812e5055c429f741b9
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/AttachStorageDomainToPoolCommandTest.java
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/43518
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I432ce03d4fd0359d95262c812e5055c429f741b9
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: DeactivateStorageDomainCommandTest asserts
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: DeactivateStorageDomainCommandTest asserts
......................................................................
core: DeactivateStorageDomainCommandTest asserts
Use the proper assertEquals instead of assertTrue for better debug
printing.
Change-Id: Ia368cc9d71ed2e06ff03872471e1e17c025daf64
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/DeactivateStorageDomainCommandTest.java
1 file changed, 2 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/43523
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia368cc9d71ed2e06ff03872471e1e17c025daf64
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: DeactivateStorageDomainCommandTest lists
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: DeactivateStorageDomainCommandTest lists
......................................................................
core: DeactivateStorageDomainCommandTest lists
Stop using the confusing ArrayList in
DeactivateStorageDomainCommandTest, and instead use
Collections.emptyList() and Collections.singletonList(Object)
to make the test easier to read, and to reduce the possibility of these
lists being modified mistakenly.
Change-Id: I72c60e44e1daed90113e1e477c75133bee7d7f51
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/DeactivateStorageDomainCommandTest.java
1 file changed, 4 insertions(+), 8 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/43522
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I72c60e44e1daed90113e1e477c75133bee7d7f51
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: Remove unused CommandMocks
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Remove unused CommandMocks
......................................................................
core: Remove unused CommandMocks
Previous patches in this series have removed all the usages of
CommandMocks. This patch finishes the job and removes this now-unused
class.
Change-Id: I563b5618d84b5596234917b130509eaa1debb371
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
D backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/CommandMocks.java
1 file changed, 0 insertions(+), 14 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/43525
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I563b5618d84b5596234917b130509eaa1debb371
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: Inline redundant method
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Inline redundant method
......................................................................
core: Inline redundant method
Removed useless method to generate an empty list in
AttachStorageDomainToPoolCommandTest.
Change-Id: Id08bd87852acf7cc2267d8eeca49b8b240edc4ac
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/AttachStorageDomainToPoolCommandTest.java
1 file changed, 1 insertion(+), 8 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/43517
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id08bd87852acf7cc2267d8eeca49b8b240edc4ac
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: Fix DeactivateStorageDomainCommand mocking
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Fix DeactivateStorageDomainCommand mocking
......................................................................
core: Fix DeactivateStorageDomainCommand mocking
Fix DbFacade and DAO access in DeactivateStorageDomainCommand in order
to fix their mocking in the test.
Change-Id: I89e30d34bd4874a3e3f34334999863e31375ec72
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/DeactivateStorageDomainCommand.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/DeactivateStorageDomainCommandTest.java
2 files changed, 10 insertions(+), 20 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Jenkins CI: Passed CI tests
Allon Mureinik: Verified
--
To view, visit https://gerrit.ovirt.org/43524
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I89e30d34bd4874a3e3f34334999863e31375ec72
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in ovirt-engine[master]: core: VM_POOL_NAME lock on VM pool creation
by ahadas@redhat.com
Arik Hadas has submitted this change and it was merged.
Change subject: core: VM_POOL_NAME lock on VM pool creation
......................................................................
core: VM_POOL_NAME lock on VM pool creation
Added VM_POOL_NAME lock that is taken when a VM pool with a given name
is created. This prevents race condition that allowed to create two VM
pools with the same name.
Change-Id: Icfa9669a03e0b26aee2e51d91e556457d0369cf3
Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1167284
Signed-off-by: Shmuel Melamud <smelamud(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVmPoolWithVmsCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/EngineMessage.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/locks/LockingGroup.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
5 files changed, 30 insertions(+), 1 deletion(-)
Approvals:
Shmuel Leib Melamud: Verified
Arik Hadas: Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/43399
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Icfa9669a03e0b26aee2e51d91e556457d0369cf3
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Omer Frenkel <ofrenkel(a)redhat.com>
Gerrit-Reviewer: Shmuel Leib Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: Shmuel Melamud <smelamud(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months
Change in mom[master]: guest manager: single-thread monitoring
by alitke@redhat.com
Adam Litke has submitted this change and it was merged.
Change subject: guest manager: single-thread monitoring
......................................................................
guest manager: single-thread monitoring
So far MOM used one thread per Guest Monitor.
The two main reasons were
- to minimize interference between VMs
- the lack of a suitable bulk API (especially from libvirt).
However, when running inside VDSM, MOM can leverage
the safety which VDSM provides, and its bulk APIs.
Moreover, libvirt recently gained bulk APIs as well.
This patch changes the internals of Guest Manager to
fully decouple Guest Monitor and threads.
It is still possible to run one thread per Guest Monitor
as before, but it is now possible to mix and match
threads and monitors with complete freedom.
This change paves the road for better and more efficient
integration with VDSM. In that case, we want to be able
to run all the MOM monitoring with just one thread.
Change-Id: I96b96fef0c0c42fd45b76754da9c629865ab1954
Signed-off-by: Francesco Romani <fromani(a)redhat.com>
Reviewed-on: https://gerrit.ovirt.org/37826
Continuous-Integration: Jenkins CI
Reviewed-by: Martin Sivák <msivak(a)redhat.com>
---
M doc/mom-balloon+ksm.conf
M doc/mom-balloon.conf
M mom/GuestManager.py
M mom/__init__.py
4 files changed, 65 insertions(+), 9 deletions(-)
Approvals:
Martin Sivák: Looks good to me, approved
Jenkins CI: Passed CI tests
Francesco Romani: Verified
--
To view, visit https://gerrit.ovirt.org/37826
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I96b96fef0c0c42fd45b76754da9c629865ab1954
Gerrit-PatchSet: 18
Gerrit-Project: mom
Gerrit-Branch: master
Gerrit-Owner: Francesco Romani <fromani(a)redhat.com>
Gerrit-Reviewer: Adam Litke <alitke(a)redhat.com>
Gerrit-Reviewer: Francesco Romani <fromani(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Sivák <msivak(a)redhat.com>
Gerrit-Reviewer: Michal Skrivanek <michal.skrivanek(a)redhat.com>
Gerrit-Reviewer: automation(a)ovirt.org
9 years, 5 months