Change in ovirt-engine[master]: core, webadmin: Remove HTTP session id query parameters
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: core, webadmin: Remove HTTP session id query parameters
......................................................................
core, webadmin: Remove HTTP session id query parameters
As it is never used.
Change-Id: Ie260336eff07996a1e75c7b01afa36ab04afd9fc
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/VdcQueryParametersBase.java
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/server/gwt/GenericApiGWTServiceImpl.java
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/server/gwt/GwtDynamicHostPageServlet.java
M frontend/webadmin/modules/frontend/src/test/java/org/ovirt/engine/ui/frontend/server/gwt/AbstractGwtDynamicHostPageServletTest.java
4 files changed, 0 insertions(+), 20 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Ravi Nori: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Vojtech Szocs: Looks good to me, but someone else must approve
--
To view, visit https://gerrit.ovirt.org/55356
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie260336eff07996a1e75c7b01afa36ab04afd9fc
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Alexander Wels <awels(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Ravi Nori <rnori(a)redhat.com>
Gerrit-Reviewer: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Clean up ImportVm test mocking
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Clean up ImportVm test mocking
......................................................................
core: Clean up ImportVm test mocking
Sorted out the mocking of mac pools so it doesn't have to assign values
to data members in order to facilitate the following refactoring
patches.
Change-Id: Ia4e53c443ec91d5116206ee1bc6eb79b4867e1bb
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ImportVMFromConfigurationCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ImportVmCommandTest.java
2 files changed, 3 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55159
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia4e53c443ec91d5116206ee1bc6eb79b4867e1bb
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Call init() in ImportVm tests
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Call init() in ImportVm tests
......................................................................
core: Call init() in ImportVm tests
postConstruct is an internal part of CommandBase's framework, and
shouldn't be called by the test. init() is the visible equivalent that
should be called.
Change-Id: I086401db52409cf12e609c1177c436e67a1ef5be
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ImportVMFromConfigurationCommandTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ImportVmCommandTest.java
2 files changed, 10 insertions(+), 10 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55158
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I086401db52409cf12e609c1177c436e67a1ef5be
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ImportVmCommandTest mac pools
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVmCommandTest mac pools
......................................................................
core: ImportVmCommandTest mac pools
Stop messing around with mac pools where unrelated to the test, it's
just confusing.
Change-Id: Ib76624a5327e3d6549c57a96f8a70218da61a8af
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ImportVmCommandTest.java
1 file changed, 0 insertions(+), 8 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55157
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib76624a5327e3d6549c57a96f8a70218da61a8af
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ImportVmCommandTest anyMap()
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVmCommandTest anyMap()
......................................................................
core: ImportVmCommandTest anyMap()
Use anyMap() instead of any(Map.class) to improve readability.
Change-Id: I5f2773e3dafcdecd6b9c7540abb1efe21c3b481a
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ImportVmCommandTest.java
1 file changed, 5 insertions(+), 4 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55156
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5f2773e3dafcdecd6b9c7540abb1efe21c3b481a
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ImportVmTemplateCommand's DbFacade.getInstance
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVmTemplateCommand's DbFacade.getInstance
......................................................................
core: ImportVmTemplateCommand's DbFacade.getInstance
Stop using DbFacade.getInstance() and use the DAOs directly instead.
Change-Id: I0680c292f7bc90497143d8253267799e21c08939
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
1 file changed, 5 insertions(+), 6 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55153
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0680c292f7bc90497143d8253267799e21c08939
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Inline MoveOrCopyTemplateCommand#isImagesAlreadyOnTarget
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Inline MoveOrCopyTemplateCommand#isImagesAlreadyOnTarget
......................................................................
core: Inline MoveOrCopyTemplateCommand#isImagesAlreadyOnTarget
MoveOrCopyTemplateCommand#isImagesAlreadyOnTarget does nothing but
delegate to a method of the same name in the parameter class. It does
nothing to improve the code's readability, and in fact hinders it, as
the reader may suspect this method actually performs some check.
This patch removes the aforementioned method in order to reduce the
code's complexity and improve its readability.
Change-Id: Ic580c5c28f85ca91ccd2f7d47b9b57b5156e058f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateFromConfigurationCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
4 files changed, 13 insertions(+), 15 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55104
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic580c5c28f85ca91ccd2f7d47b9b57b5156e058f
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ImportVmTemplateCommand#newDiskIdForDisk
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVmTemplateCommand#newDiskIdForDisk
......................................................................
core: ImportVmTemplateCommand#newDiskIdForDisk
ImportVmTemplateCommand#newDiskIdForDisk was
only used by ImportVmTemplateCommand. This patch pulls it down to its
rightful place.
Change-Id: Ic7dcdeabd860cdf97b5b3ea3af6b9e579807bde2
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
2 files changed, 6 insertions(+), 5 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55152
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic7dcdeabd860cdf97b5b3ea3af6b9e579807bde2
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Fail fast ImportVmTemplateCommand#validate()
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Fail fast ImportVmTemplateCommand#validate()
......................................................................
core: Fail fast ImportVmTemplateCommand#validate()
Cleaned up the ImportVmTemaplateCommand#validate() method to use the
early-return (fail-fast) idiom in order to clean up the code and make it
more readable, instead of dragging the retVal variable throughout the
method.
As part of this refactoring, the setActionMessageParameters() method was
overridden so that validate() doesn't have to handle adding the default
variables. Moreover, since it previously was NOT overridden, it
inherited its implementation from its superclass,
MoveOrCopyTemplateCommand, which caused an undefined behavior.
Change-Id: I335ada3c12b83db2d4a904fdfc30affec4d835c9
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
1 file changed, 81 insertions(+), 93 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55094
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I335ada3c12b83db2d4a904fdfc30affec4d835c9
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ExportVmCommand's DbFacade
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ExportVmCommand's DbFacade
......................................................................
core: ExportVmCommand's DbFacade
Stop using getDbFacade() and use the DAOs directly instead.
Change-Id: I8adc1a27397b5ad98e56208c0cf3ad368b90c3cb
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmCommand.java
1 file changed, 5 insertions(+), 7 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55154
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8adc1a27397b5ad98e56208c0cf3ad368b90c3cb
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months