Change in ovirt-engine[master]: core: Inline MoveOrCopyTemplateCommand#getMoveOrCopyImageOpe...
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Inline MoveOrCopyTemplateCommand#getMoveOrCopyImageOperation()
......................................................................
core: Inline MoveOrCopyTemplateCommand#getMoveOrCopyImageOperation()
As getMoveOrCopyImageOperation() just returns the constant
ImageOperation.Copy, there's no point of having it as a method.
This patch inlines it in order to improve the code's readability.
Change-Id: I8bd3ab3648a93c58677d8214a9e882748b4895e9
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
4 files changed, 9 insertions(+), 10 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55087
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I8bd3ab3648a93c58677d8214a9e882748b4895e9
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Remove MoveVmCommand
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Remove MoveVmCommand
......................................................................
core: Remove MoveVmCommand
oVirt 3.0 had a command to move a VM from one storage domain to another.
oVirt 3.1 introduced the notion of a VM having multiple disks on
multiple storage domains, with the ability to move them independently,
rendering this command meaningless, and it was indeed marked as
deprecated and preserved only in order to not break the REST API's
backwards compatibility. Change
I8953fe1c6c68e5bc95662342c8193fa77a1019d3 removed this broken API call,
and this patch finishes the job be removing the backend code that used
to support it
With the removal of MoveVMCommand,
MoveOrCopyTemplateCommand#getMoveOrCopyImageOperation() will always
return ImageOperation.Copy, so any code referencing ImageOperation.Move
in this hierarchy was also removed.
Change-Id: I2a738a78d9f5f7f3812e3f8443c9a49c3d012daa
Bug-Url: https://bugzilla.redhat.com/1320515
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
D backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MoveVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/AuditLogType.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/VdcActionUtils.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/VdcActionType.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/errors/EngineMessage.java
M backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
M backend/manager/modules/dal/src/main/resources/bundles/AuditLogMessages.properties
M backend/manager/modules/dal/src/main/resources/bundles/ExecutionMessages.properties
M backend/manager/modules/restapi/README.adoc
M backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata.yaml
M frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/LocalizedEnums.java
M frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/LocalizedEnums.properties
M frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/ApplicationConstants.java
M frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
A packaging/dbscripts/upgrade/04_00_0390_delete_move_vm_auditlog.sql
18 files changed, 38 insertions(+), 297 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Eli Mesika: Looks good to me, but someone else must approve
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55086
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I2a738a78d9f5f7f3812e3f8443c9a49c3d012daa
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: construct jsonrpc with identifier name.
by mperina@redhat.com
Martin Peřina has submitted this change and it was merged.
Change subject: construct jsonrpc with identifier name.
......................................................................
construct jsonrpc with identifier name.
this patch help to identifiy host by http connect header,
in order to support multiple access for same ip address,
specially for vdsmfake.
moving to use setter and getter instead of constrctors.
adding ConfigValue in order to control this.
deafualt is false.
update db configuratoin.
this patch depndes on https://gerrit.ovirt.org/#/c/39835/
Bug-Url: https://bugzilla.redhat.com/1317248
Change-Id: Ic423322de3f1e0d1862d147a3b529f5c047d8b02
Signed-off-by: emarcian <emarcian(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/config/ConfigValues.java
M backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/JsonRpcUtils.java
M packaging/dbscripts/upgrade/pre_upgrade/0000_config.sql
3 files changed, 24 insertions(+), 0 deletions(-)
Approvals:
Martin Peřina: Looks good to me, but someone else must approve
Eli Mesika: Looks good to me, approved
Jenkins CI: Passed CI tests
Eldad Marciano: Verified
--
To view, visit https://gerrit.ovirt.org/39888
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic423322de3f1e0d1862d147a3b529f5c047d8b02
Gerrit-PatchSet: 24
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Eldad Marciano <emarcian(a)redhat.com>
Gerrit-Reviewer: Eldad Marciano <emarcian(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Peřina <mperina(a)redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczewski(a)gmail.com>
Gerrit-Reviewer: Roy Golan <rgolan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: restapi: Add documentation section for changes in V3
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Add documentation section for changes in V3
......................................................................
restapi: Add documentation section for changes in V3
This patch adds to the README.adoc file of the API a new section
intended to contain the changes made to version 3 of the API.
Change-Id: I42f2b5f3058f27c4465c4a9b8f6525739e46240c
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/README.adoc
1 file changed, 8 insertions(+), 3 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55162
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I42f2b5f3058f27c4465c4a9b8f6525739e46240c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: restapi: Remove unused constants
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Remove unused constants
......................................................................
restapi: Remove unused constants
Change-Id: Iaf81e308610fc406f9c3c64d7b9fcf72a140c0df
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendResource.java
1 file changed, 0 insertions(+), 2 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55355
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iaf81e308610fc406f9c3c64d7b9fcf72a140c0df
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: restapi: Remove unused logger
by juan.hernandez@redhat.com
Juan Hernandez has submitted this change and it was merged.
Change subject: restapi: Remove unused logger
......................................................................
restapi: Remove unused logger
Change-Id: Ic8d2b8336643476c05063cea9cdd0c145db44a48
Signed-off-by: Juan Hernandez <juan.hernandez(a)redhat.com>
---
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/BackendApplication.java
1 file changed, 0 insertions(+), 5 deletions(-)
Approvals:
Juan Hernandez: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55359
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic8d2b8336643476c05063cea9cdd0c145db44a48
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Ori Liel <oliel(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in otopi[master]: dialog: human: Allow automatically accepting defaults
by didi@redhat.com
Yedidyah Bar David has submitted this change and it was merged.
Change subject: dialog: human: Allow automatically accepting defaults
......................................................................
dialog: human: Allow automatically accepting defaults
Change-Id: Ica0ff19d929c5168d4d6452be0c883d8e963b678
Related-To: https://bugzilla.redhat.com/1270719
Signed-off-by: Yedidyah Bar David <didi(a)redhat.com>
---
M src/otopi/constants.py
M src/plugins/otopi/dialog/human.py
2 files changed, 19 insertions(+), 0 deletions(-)
Approvals:
Sandro Bonazzola: Looks good to me, but someone else must approve
Simone Tiraboschi: Looks good to me, but someone else must approve
Jenkins CI: Passed CI tests
Yedidyah Bar David: Verified; Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/55479
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ica0ff19d929c5168d4d6452be0c883d8e963b678
Gerrit-PatchSet: 1
Gerrit-Project: otopi
Gerrit-Branch: master
Gerrit-Owner: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Simone Tiraboschi <stirabos(a)redhat.com>
Gerrit-Reviewer: Yedidyah Bar David <didi(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: removed misleading comment
by alkaplan@redhat.com
Alona Kaplan has submitted this change and it was merged.
Change subject: core: removed misleading comment
......................................................................
core: removed misleading comment
Change-Id: Ib3e462ea00dd927f1f2e6e6b2924b80795f2f052
Signed-off-by: Martin Mucha <mmucha(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/network/host/HostSetupNetworkPoller.java
1 file changed, 0 insertions(+), 1 deletion(-)
Approvals:
Alona Kaplan: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55483
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib3e462ea00dd927f1f2e6e6b2924b80795f2f052
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Use DiskStorageType.isInternal in DetachDiskFromVmCommand
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Use DiskStorageType.isInternal in DetachDiskFromVmCommand
......................................................................
core: Use DiskStorageType.isInternal in DetachDiskFromVmCommand
Change-Id: I9c514782cb284f50167c3512be025a022b10fc55
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/DetachDiskFromVmCommand.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55418
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I9c514782cb284f50167c3512be025a022b10fc55
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Simplify validate part of DetachDiskFromVmCommand with...
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Simplify validate part of DetachDiskFromVmCommand with early return
......................................................................
core: Simplify validate part of DetachDiskFromVmCommand with early return
Change-Id: I4ffd889a55fc7848e22048222fccf8973fe7f75b
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/DetachDiskFromVmCommand.java
1 file changed, 21 insertions(+), 24 deletions(-)
Approvals:
Tal Nisan: Verified; Passed CI tests
Allon Mureinik: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/55420
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I4ffd889a55fc7848e22048222fccf8973fe7f75b
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months