Change in ovirt-engine[master]: core: ExportVmTemplateCommand#checkIfDisksExist
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ExportVmTemplateCommand#checkIfDisksExist
......................................................................
core: ExportVmTemplateCommand#checkIfDisksExist
MoveOrCopyTemplateCommand#checkIfDisksExist was only used by
ExportVmTemplateCommand. This patch pulls it down to its rightful place.
Change-Id: Iecd9bae1c16b010a49c58073e7bbca16920e9cbe
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
2 files changed, 31 insertions(+), 32 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55100
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Iecd9bae1c16b010a49c58073e7bbca16920e9cbe
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: engine: Remove MoveVmParameters
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: engine: Remove MoveVmParameters
......................................................................
engine: Remove MoveVmParameters
MoveVmParameters just extended MoveOrCopyParameters and didn't add
any other data members or methods.
As such, it's just useless, and should be removed.
Change-Id: I67b238cbe8a9a2fae9c3e3b0f4577bad4796b82c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmCommand.java
D backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/MoveVmParameters.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendTemplateResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/BackendVmResource.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendTemplateResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/BackendVmResourceTest.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmListModel.java
7 files changed, 15 insertions(+), 31 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55111
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I67b238cbe8a9a2fae9c3e3b0f4577bad4796b82c
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Juan Hernandez <juan.hernandez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Pull down MoverOrCopyTemplateCommand#validateMacAddress
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Pull down MoverOrCopyTemplateCommand#validateMacAddress
......................................................................
core: Pull down MoverOrCopyTemplateCommand#validateMacAddress
This method is only used by ImportVmTemplateCommand, so that's where
it should be defined.
Change-Id: I437c31a5edca0cc729eb1eee06f329ef2701a303
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
2 files changed, 44 insertions(+), 47 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55093
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I437c31a5edca0cc729eb1eee06f329ef2701a303
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ImportVmTemplateCommand audit log
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVmTemplateCommand audit log
......................................................................
core: ImportVmTemplateCommand audit log
Fixed audit log type in case the command reaches the END_FAILURE
status.
Change-Id: I09524c9434a85008c44635e0073f859d3a497024
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
1 file changed, 3 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55174
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I09524c9434a85008c44635e0073f859d3a497024
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ExportVmTemplateCommand audit log
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ExportVmTemplateCommand audit log
......................................................................
core: ExportVmTemplateCommand audit log
Fixed audit log type in case the command reaches the END_FAILURE
status.
Change-Id: Id1b486f4f5d557fe1056ae8624da63751cec9a88
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmTemplateCommand.java
1 file changed, 3 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55173
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id1b486f4f5d557fe1056ae8624da63751cec9a88
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Pull down MoverOrCopyTemplateCommand#setImagesWithStor...
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Pull down MoverOrCopyTemplateCommand#setImagesWithStoragePoolId
......................................................................
core: Pull down MoverOrCopyTemplateCommand#setImagesWithStoragePoolId
This method is only used by ImportVmTemplateFromConfigurationCommand, so
that's where it should be defined.
Change-Id: I793794207a27e503a08970e53c3fea06a92451f0
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateFromConfigurationCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
2 files changed, 6 insertions(+), 6 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55092
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I793794207a27e503a08970e53c3fea06a92451f0
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Make MoveOrCopyTemplateCommand abstract
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Make MoveOrCopyTemplateCommand abstract
......................................................................
core: Make MoveOrCopyTemplateCommand abstract
As a step to remove this unused (and useless) command, this patch
makes it abstract and removes the methods that are overriden by all the
classes that extend it.
The test was also removed (as this class can no longer be instantiated),
as well as audit log constants that are no longer used anywhere in the
codebase one the respective methods this patch cleans up were removed.
Change-Id: Id6267cb8f13e0f395b8737862dbe86768f4941ab
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
D backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommandTest.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/AuditLogType.java
M backend/manager/modules/dal/src/main/resources/bundles/AuditLogMessages.properties
A packaging/dbscripts/upgrade/04_00_0400_delete_copy_template_auditlog.sql
5 files changed, 10 insertions(+), 259 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Eli Mesika: Looks good to me, but someone else must approve
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55091
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id6267cb8f13e0f395b8737862dbe86768f4941ab
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Eli Mesika <emesika(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Remove VdcActionType#MoveOrCopyVmTemplate
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Remove VdcActionType#MoveOrCopyVmTemplate
......................................................................
core: Remove VdcActionType#MoveOrCopyVmTemplate
oVirt 3.0 had a command to copy a VM Template from one storage domain
to another.
oVirt 3.1 introduced the notion of a VM Template having multiple disks
on multiple storage domains, with the ability to copy them independently,
rendering this command meaningless, and it is indeed not used in the
codebase, and hasn't been for a while.
This patch removes the constant representing it and all the tooling
around it (ExecutionMessages constant, LocalizedEnums translations,
etc.). Subsequent patches will remove the actual code for the
MoveOrCopyTemplateCommand, once the classes that extend it will be
cleaned up.
Change-Id: I64ae7eba3834e5b3347d740c81763d6308ccdc86
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/VdcActionUtils.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/VdcActionType.java
M backend/manager/modules/dal/src/main/resources/bundles/ExecutionMessages.properties
M frontend/webadmin/modules/uicompat/src/main/java/org/ovirt/engine/ui/uicompat/LocalizedEnums.java
M frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/LocalizedEnums.properties
M packaging/setup/plugins/ovirt-engine-setup/ovirt-engine/upgrade/async_tasks_map.py
6 files changed, 2 insertions(+), 12 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55090
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I64ae7eba3834e5b3347d740c81763d6308ccdc86
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ExportVMCommand#getAuditLogTypeValue()
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ExportVMCommand#getAuditLogTypeValue()
......................................................................
core: ExportVMCommand#getAuditLogTypeValue()
Use default instead of END_FAILURE to signify this switch-case covers
all the possible values getActionState() might return, as per the
project's convention.
Change-Id: Ia01d68eb28ef89daf680e41a423492fb7b26ed86
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmCommand.java
1 file changed, 1 insertion(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55089
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ia01d68eb28ef89daf680e41a423492fb7b26ed86
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: MoveOrCopyTemplateCommand early return
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: MoveOrCopyTemplateCommand early return
......................................................................
core: MoveOrCopyTemplateCommand early return
Used the early return (fail fast) pattern in the validate() method to
improve the code's readability.
Change-Id: I0c5e6b4215e51cec929d23efe7ba2ff239086efb
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
1 file changed, 17 insertions(+), 19 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55088
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0c5e6b4215e51cec929d23efe7ba2ff239086efb
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months