Change in ovirt-engine[master]: core: Inline MoveOrCopyTemplateCommand#validate()
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Inline MoveOrCopyTemplateCommand#validate()
......................................................................
core: Inline MoveOrCopyTemplateCommand#validate()
The only place that used MoveOrCopyTemplateCommand#validate() is
ExportVmTemplateCommand#validate(), which calls super.validate(). This
patch inlines the relevant checks there and removes the redundant method
from MoveOrCopyTemplateCommand.
This change also allows us to remove the duplicate check of
"getVmTemplate() == null".
Change-Id: I7af044fd8fd78fb9aa1a81ba821ad12c56b5771f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
2 files changed, 40 insertions(+), 52 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55097
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7af044fd8fd78fb9aa1a81ba821ad12c56b5771f
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Fail fast ExportVmTemplateCommand#validate()
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Fail fast ExportVmTemplateCommand#validate()
......................................................................
core: Fail fast ExportVmTemplateCommand#validate()
Cleaned up the ExportVmTemaplateCommand#validate() method to use the
early-return (fail-fast) idiom in order to clean up the code and make it
more readable, instead of dragging the retVal variable throughout the
method.
Change-Id: I73ad6ae1b52461bc4afbfcd7a6263da9148e966a
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmTemplateCommand.java
1 file changed, 15 insertions(+), 15 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55096
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I73ad6ae1b52461bc4afbfcd7a6263da9148e966a
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: RM MoveOrCopyTemplateCommand#setActionMessageParameters
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: RM MoveOrCopyTemplateCommand#setActionMessageParameters
......................................................................
core: RM MoveOrCopyTemplateCommand#setActionMessageParameters
As all of MoveOrCopyTemplateCommand's subclasses override the
setActionMessageParameters() method, there's no need to have an
implementation in this abstract class.
Change-Id: Ibc553465666540ead510ffe5d6671bafc7f5dde4
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
1 file changed, 0 insertions(+), 6 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55095
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibc553465666540ead510ffe5d6671bafc7f5dde4
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ImportVmCommandTest collections
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVmCommandTest collections
......................................................................
core: ImportVmCommandTest collections
User Collections.singletonList instead of Arrays.asList to boost
performance.
Change-Id: I80fcdf171c3fcdd87fc5a1d962133c20269abb48
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/ImportVmCommandTest.java
1 file changed, 2 insertions(+), 2 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55155
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I80fcdf171c3fcdd87fc5a1d962133c20269abb48
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: org.ovirt.engine.core.bll.exportimport pkg
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: org.ovirt.engine.core.bll.exportimport pkg
......................................................................
core: org.ovirt.engine.core.bll.exportimport pkg
Create a package for export and import commands, and move all the
relevant classes there.
Change-Id: Ib39a2bad2b8005b07b28c78e0f6a87d68574f50a
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommandBase.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/CommandsFactory.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VmCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/CancelConvertVmCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ConvertOvaCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ConvertVmCallback.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ConvertVmCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ExportVmCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ExportVmTemplateCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/GetAllFromExportDomainQuery.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/GetTemplatesFromExportDomainQuery.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/GetVmsFromExportDomainQuery.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ImportUtils.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ImportVmCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ImportVmCommandBase.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ImportVmFromConfigurationCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ImportVmFromExternalProviderCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ImportVmFromOvaCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ImportVmTemplateCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/ImportVmTemplateFromConfigurationCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/MoveOrCopyTemplateCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/RemoveVmFromImportExportCommand.java
R backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/exportimport/RemoveVmTemplateFromImportExportCommand.java
R backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/exportimport/ImportVMFromConfigurationCommandTest.java
R backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/exportimport/ImportVmCommandTest.java
R backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/exportimport/ImportVmFromExternalProviderCommandTest.java
R backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/exportimport/ImportVmTemplateCommandTest.java
27 files changed, 77 insertions(+), 46 deletions(-)
Approvals:
Allon Mureinik: Verified; Passed CI tests
Idan Shaby: Looks good to me, but someone else must approve
Arik Hadas: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/55160
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib39a2bad2b8005b07b28c78e0f6a87d68574f50a
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Arik Hadas <ahadas(a)redhat.com>
Gerrit-Reviewer: Idan Shaby <ishaby(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ImportVmTemplateFromConfigurationCommand#validateUnreg...
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVmTemplateFromConfigurationCommand#validateUnregisteredEntity
......................................................................
core: ImportVmTemplateFromConfigurationCommand#validateUnregisteredEntity
MoveOrCopyTemplateCommand#validateUnregisteredEntity was only used by
ImportVmTemplateFromConfigurationCommand. This patch pulls the method
down to its rightful place.
Change-Id: I29618390acbb96f4a091e3512714b1bada44d45f
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateFromConfigurationCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
2 files changed, 26 insertions(+), 26 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55099
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I29618390acbb96f4a091e3512714b1bada44d45f
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ImportVmTemplateCommand source domain methods
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVmTemplateCommand source domain methods
......................................................................
core: ImportVmTemplateCommand source domain methods
MoveOrCopyTemplateCommand's sourceDomain, sourceDomainId and their
relevant getters and setters are only used by ImportVmTemplateCommand.
This patch pulls them down to their rightful location.
Change-Id: I446729ae4c43fb4523e2c9bfed05e8a61582a552
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
2 files changed, 13 insertions(+), 13 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55098
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I446729ae4c43fb4523e2c9bfed05e8a61582a552
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Inline MoveOrCopyTemplateCommand#getImagesActionType
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Inline MoveOrCopyTemplateCommand#getImagesActionType
......................................................................
core: Inline MoveOrCopyTemplateCommand#getImagesActionType
As MoveOrCopyTemplateCommand#getImagesActionType now returns a constant
VdcActionType.CopyImageGroup, there's no reason to have it as a method.
This patch inlines this method and replaces it with its implementation
in order to clean up the code and make it easier to read.
Change-Id: I7fd646d87a46ba9c0b141c8df36b161e1b9ee132
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
3 files changed, 4 insertions(+), 8 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55103
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7fd646d87a46ba9c0b141c8df36b161e1b9ee132
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: Remove MoveOrCopyTemplateCommand#getImages()
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: Remove MoveOrCopyTemplateCommand#getImages()
......................................................................
core: Remove MoveOrCopyTemplateCommand#getImages()
MoveOrCopyTemplateCommand#getImages() was used by
ImportVmTemplateCommand and ImportVmTemplateFromConfigurationCommand.
However, both these commands override it, so there's no reason to have a
dummy implementation in MoveOrCopyTemplateCommand.
This patch removes this useless implementation.
Change-Id: I691e4dc0a9e7943941c9dab52e2a8ed3fe2235b8
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmTemplateCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
2 files changed, 0 insertions(+), 6 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55102
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I691e4dc0a9e7943941c9dab52e2a8ed3fe2235b8
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months
Change in ovirt-engine[master]: core: ExportVmTemplateCommand#createDiskDummiesForSpaceValid...
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ExportVmTemplateCommand#createDiskDummiesForSpaceValidations
......................................................................
core: ExportVmTemplateCommand#createDiskDummiesForSpaceValidations
MoveOrCopyTemplateCommand#createDiskDummiesForSpaceValidations was
only used by ExportVmTemplateCommand. This patch pulls it down to its
rightful place.
Change-Id: I352a078c0d612291a42d3bebebbe3820e7aa49d6
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/ExportVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/export/MoveOrCopyTemplateCommand.java
2 files changed, 15 insertions(+), 15 deletions(-)
Approvals:
Tal Nisan: Looks good to me, approved
Allon Mureinik: Verified; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55101
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I352a078c0d612291a42d3bebebbe3820e7aa49d6
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 9 months