Change in ovirt-engine[master]: core: Extract disk existence check to disk validator
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Extract disk existence check to disk validator
......................................................................
core: Extract disk existence check to disk validator
Change-Id: If70a0edc1fd566347275627101ad28a98953fa60
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/AbstractDiskVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/storage/DiskValidator.java
2 files changed, 12 insertions(+), 1 deletion(-)
Approvals:
Tal Nisan: Verified; Passed CI tests
Allon Mureinik: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/55756
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: If70a0edc1fd566347275627101ad28a98953fa60
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[master]: core: Pull down method in AbstractDiskVmCommand
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Pull down method in AbstractDiskVmCommand
......................................................................
core: Pull down method in AbstractDiskVmCommand
The method isVmNotLocked is only used in AddDiskCommand and thus pulled
down, the null check was removed since the VM cannot be null when the
method is invoked
Change-Id: I592050a458f7c4af9856c674c2dc28a9751a7933
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/AbstractDiskVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/AddDiskCommand.java
2 files changed, 2 insertions(+), 9 deletions(-)
Approvals:
Tal Nisan: Verified; Passed CI tests
Allon Mureinik: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/55755
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I592050a458f7c4af9856c674c2dc28a9751a7933
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[master]: core: Extract check for floating disk in AddDiskCommand
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Extract check for floating disk in AddDiskCommand
......................................................................
core: Extract check for floating disk in AddDiskCommand
The check whether a disk is floating (i.e. will not be attached to a VM)
is repeated 3 times within the class and was extracted to a method for
better readability
The method isVmExist() was inlined as well as the terminology there is
confusing since the method checks whether the VM exists only in case of a
non floating disk
Change-Id: Ib836b82389f45de2b206fbf67e1ea8e7e36935c8
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/AddDiskCommand.java
1 file changed, 5 insertions(+), 7 deletions(-)
Approvals:
Tal Nisan: Verified; Passed CI tests
Allon Mureinik: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/55754
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib836b82389f45de2b206fbf67e1ea8e7e36935c8
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[master]: core: Add VM existance validator to VmValidator
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Add VM existance validator to VmValidator
......................................................................
core: Add VM existance validator to VmValidator
The logic used in AbstractDiskVmCommand for checking the existance of a
VM was extracted to an external validator and usages in subclasses were
changed to use the validator
Change-Id: I342a64574c066301a2d1045e7a37de5312dac089
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/AbstractDiskVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/AddDiskCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/AttachDiskToVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/DetachDiskFromVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/HotPlugDiskToVmCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/disk/UpdateVmDiskCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/VmValidator.java
7 files changed, 19 insertions(+), 15 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55753
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I342a64574c066301a2d1045e7a37de5312dac089
Gerrit-PatchSet: 11
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[master]: core: Make VmValidator validate single VMs
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Make VmValidator validate single VMs
......................................................................
core: Make VmValidator validate single VMs
As all methods in VmValidator are validating a single VM, the support for
multiple VMs is overkill and adds unnecessary complexity to every
validation that has to be added to this class.
This patch make VmValidator test single VMs, for future multiple VM
validations there's the MultipleVmsValdator class
Change-Id: I84db7fcc79893f8b88d3dd0016adc514e5008869
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/VmValidator.java
1 file changed, 51 insertions(+), 82 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55712
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I84db7fcc79893f8b88d3dd0016adc514e5008869
Gerrit-PatchSet: 8
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[master]: core: Remove vm passthrough nics validation for multiple VMs
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: Remove vm passthrough nics validation for multiple VMs
......................................................................
core: Remove vm passthrough nics validation for multiple VMs
This test is testing a case which is never used, all validations
throughout the code base are done on a single VM thus the test is redundant
and can be removed
Change-Id: I0ac05f20d4a6e1e820a3d5cbf483836d7955292c
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/validator/VmValidatorTest.java
1 file changed, 0 insertions(+), 31 deletions(-)
Approvals:
Tal Nisan: Verified
Jenkins CI: Passed CI tests
Allon Mureinik: Looks good to me, approved
--
To view, visit https://gerrit.ovirt.org/55711
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I0ac05f20d4a6e1e820a3d5cbf483836d7955292c
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[master]: core: extract vmNotHavingPluggedDiskSnapshots from VmValidator
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: core: extract vmNotHavingPluggedDiskSnapshots from VmValidator
......................................................................
core: extract vmNotHavingPluggedDiskSnapshots from VmValidator
As vmNotHavingPluggedDiskSnapshots is the only method in VmValidator used
to validate a collection of VMs it was exctract to a new validator class
named MultipleVmsValdator which will handle validations on multiple VMs
Change-Id: I451d4c56dcf63a310b70d79159aab6a9adc79b52
Signed-off-by: Tal Nisan <tnisan(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MaintenanceNumberOfVdssCommand.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MigrateVmCommand.java
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/MultipleVmsValidator.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/validator/VmValidator.java
4 files changed, 61 insertions(+), 39 deletions(-)
Approvals:
Tal Nisan: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55710
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I451d4c56dcf63a310b70d79159aab6a9adc79b52
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months
Change in ovirt-engine[ovirt-engine-3.6.5]: build: post ovirt-engine-3.6.5.3
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: build: post ovirt-engine-3.6.5.3
......................................................................
build: post ovirt-engine-3.6.5.3
Change-Id: Ic2bbb261e63010399e6371c83dccfd9fb0236baf
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M automation/build-artifacts.sh
M backend/manager/dependencies/common/pom.xml
M backend/manager/dependencies/pom.xml
M backend/manager/dependencies/tools/pom.xml
M backend/manager/extensions-tool/pom.xml
M backend/manager/modules/aaa/pom.xml
M backend/manager/modules/auth-plugin/pom.xml
M backend/manager/modules/bll/pom.xml
M backend/manager/modules/branding/pom.xml
M backend/manager/modules/builtin-extensions/pom.xml
M backend/manager/modules/common/pom.xml
M backend/manager/modules/compat/pom.xml
M backend/manager/modules/dal/pom.xml
M backend/manager/modules/docs/pom.xml
M backend/manager/modules/extensions-api-root/extensions-api/pom.xml
M backend/manager/modules/extensions-api-root/pom.xml
M backend/manager/modules/extensions-manager/pom.xml
M backend/manager/modules/logger/pom.xml
M backend/manager/modules/pom.xml
M backend/manager/modules/restapi/interface/common/jaxrs/pom.xml
M backend/manager/modules/restapi/interface/common/pom.xml
M backend/manager/modules/restapi/interface/definition/pom.xml
M backend/manager/modules/restapi/interface/pom.xml
M backend/manager/modules/restapi/jaxrs/pom.xml
M backend/manager/modules/restapi/pom.xml
M backend/manager/modules/restapi/types/pom.xml
M backend/manager/modules/restapi/webapp/pom.xml
M backend/manager/modules/root/pom.xml
M backend/manager/modules/scheduler/pom.xml
M backend/manager/modules/searchbackend/pom.xml
M backend/manager/modules/services/pom.xml
M backend/manager/modules/utils/pom.xml
M backend/manager/modules/uutils/pom.xml
M backend/manager/modules/vdsbroker/pom.xml
M backend/manager/modules/welcome/pom.xml
M backend/manager/pom.xml
M backend/manager/tools/pom.xml
M backend/pom.xml
M build-tools-root/checkstyles/pom.xml
M build-tools-root/jboss-modules-maven-plugin/pom.xml
M build-tools-root/ovirt-checkstyle-extension/pom.xml
M build-tools-root/pom.xml
M build/validations/pom.xml
M ear/pom.xml
M frontend/pom.xml
M frontend/webadmin/modules/frontend-symbols/pom.xml
M frontend/webadmin/modules/frontend/pom.xml
M frontend/webadmin/modules/gwt-common/pom.xml
M frontend/webadmin/modules/gwt-extension/pom.xml
M frontend/webadmin/modules/pom.xml
M frontend/webadmin/modules/uicommonweb/pom.xml
M frontend/webadmin/modules/uicompat/pom.xml
M frontend/webadmin/modules/userportal-gwtp/pom.xml
M frontend/webadmin/modules/webadmin/pom.xml
M frontend/webadmin/pom.xml
M mavenmake/pom.xml
M pom.xml
M version.mak
58 files changed, 65 insertions(+), 62 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55963
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic2bbb261e63010399e6371c83dccfd9fb0236baf
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.5
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Anton Marchukov <amarchuk(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
8 years, 8 months
Change in ovirt-engine[ovirt-engine-3.6.5]: build: ovirt-engine-3.6.5.3
by tnisan@redhat.com
Tal Nisan has submitted this change and it was merged.
Change subject: build: ovirt-engine-3.6.5.3
......................................................................
build: ovirt-engine-3.6.5.3
Change-Id: I1ca05be1d2c9d24f2f6e602d85004c645c9e90e4
Signed-off-by: Sandro Bonazzola <sbonazzo(a)redhat.com>
---
M automation/build-artifacts.sh
M backend/manager/dependencies/common/pom.xml
M backend/manager/dependencies/pom.xml
M backend/manager/dependencies/tools/pom.xml
M backend/manager/extensions-tool/pom.xml
M backend/manager/modules/aaa/pom.xml
M backend/manager/modules/auth-plugin/pom.xml
M backend/manager/modules/bll/pom.xml
M backend/manager/modules/branding/pom.xml
M backend/manager/modules/builtin-extensions/pom.xml
M backend/manager/modules/common/pom.xml
M backend/manager/modules/compat/pom.xml
M backend/manager/modules/dal/pom.xml
M backend/manager/modules/docs/pom.xml
M backend/manager/modules/extensions-api-root/extensions-api/pom.xml
M backend/manager/modules/extensions-api-root/pom.xml
M backend/manager/modules/extensions-manager/pom.xml
M backend/manager/modules/logger/pom.xml
M backend/manager/modules/pom.xml
M backend/manager/modules/restapi/interface/common/jaxrs/pom.xml
M backend/manager/modules/restapi/interface/common/pom.xml
M backend/manager/modules/restapi/interface/definition/pom.xml
M backend/manager/modules/restapi/interface/pom.xml
M backend/manager/modules/restapi/jaxrs/pom.xml
M backend/manager/modules/restapi/pom.xml
M backend/manager/modules/restapi/types/pom.xml
M backend/manager/modules/restapi/webapp/pom.xml
M backend/manager/modules/root/pom.xml
M backend/manager/modules/scheduler/pom.xml
M backend/manager/modules/searchbackend/pom.xml
M backend/manager/modules/services/pom.xml
M backend/manager/modules/utils/pom.xml
M backend/manager/modules/uutils/pom.xml
M backend/manager/modules/vdsbroker/pom.xml
M backend/manager/modules/welcome/pom.xml
M backend/manager/pom.xml
M backend/manager/tools/pom.xml
M backend/pom.xml
M build-tools-root/checkstyles/pom.xml
M build-tools-root/jboss-modules-maven-plugin/pom.xml
M build-tools-root/ovirt-checkstyle-extension/pom.xml
M build-tools-root/pom.xml
M build/validations/pom.xml
M ear/pom.xml
M frontend/pom.xml
M frontend/webadmin/modules/frontend-symbols/pom.xml
M frontend/webadmin/modules/frontend/pom.xml
M frontend/webadmin/modules/gwt-common/pom.xml
M frontend/webadmin/modules/gwt-extension/pom.xml
M frontend/webadmin/modules/pom.xml
M frontend/webadmin/modules/uicommonweb/pom.xml
M frontend/webadmin/modules/uicompat/pom.xml
M frontend/webadmin/modules/userportal-gwtp/pom.xml
M frontend/webadmin/modules/webadmin/pom.xml
M frontend/webadmin/pom.xml
M mavenmake/pom.xml
M ovirt-engine.spec.in
M pom.xml
M version.mak
59 files changed, 64 insertions(+), 64 deletions(-)
Approvals:
Sandro Bonazzola: Verified; Looks good to me, approved
Jenkins CI: Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55961
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I1ca05be1d2c9d24f2f6e602d85004c645c9e90e4
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: ovirt-engine-3.6.5
Gerrit-Owner: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Anton Marchukov <amarchuk(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Sandro Bonazzola <sbonazzo(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
8 years, 8 months
Change in ovirt-engine[master]: engine: create base class for network provider proxies: Base...
by alkaplan@redhat.com
Alona Kaplan has submitted this change and it was merged.
Change subject: engine: create base class for network provider proxies: BaseNetworkProviderProxy
......................................................................
engine: create base class for network provider proxies: BaseNetworkProviderProxy
This patch creates a base class for external network provider proxy.
It moves the base functionality from OpenstackNetworkProviderProxy
to BaseNetworkProviderProxy, letting OpenstackNetworkProviderProxy
handle only the very openstack neutron related items.
Change-Id: I7b0252b15323d1013611134a69f85ad215265771
Bug-Url: https://bugzilla.redhat.com/1314375
Signed-off-by: mirecki <mmirecki(a)redhat.com>
---
A backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/provider/network/openstack/BaseNetworkProviderProxy.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/provider/network/openstack/OpenstackNetworkProviderProxy.java
2 files changed, 422 insertions(+), 334 deletions(-)
Approvals:
Marcin Mirecki: Verified
Alona Kaplan: Looks good to me, approved; Passed CI tests
--
To view, visit https://gerrit.ovirt.org/55430
To unsubscribe, visit https://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I7b0252b15323d1013611134a69f85ad215265771
Gerrit-PatchSet: 5
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Marcin Mirecki <mmirecki(a)redhat.com>
Gerrit-Reviewer: Alona Kaplan <alkaplan(a)redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Marcin Mirecki <mmirecki(a)redhat.com>
Gerrit-Reviewer: Martin Mucha <mmucha(a)redhat.com>
Gerrit-Reviewer: gerrit-hooks <automation(a)ovirt.org>
8 years, 8 months