Change in ovirt-engine[master]: core: ImportVm cleanup: CDA_afterCloneVm signature
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVm cleanup: CDA_afterCloneVm signature
......................................................................
core: ImportVm cleanup: CDA_afterCloneVm signature
Stop passing canDoActionMessages to canDoAction_afterCloneVm, as it is
available as a data member, and does not contribute anything as a
parameter.
Change-Id: I83c7a8cde592cd8f69943b90d1ed17e3797e856b
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmCommand.java
1 file changed, 3 insertions(+), 4 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/10007
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I83c7a8cde592cd8f69943b90d1ed17e3797e856b
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: core: ImportVm cleanup: canDoAction_afterCloneVm
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVm cleanup: canDoAction_afterCloneVm
......................................................................
core: ImportVm cleanup: canDoAction_afterCloneVm
A slight cleanup to canDoAction_afterCloneVm so it uses the early
return pattern, which is (a bit) more readable.
Change-Id: I5c1eba4ca3e39b4b3ed2142e9e0a964bda7e6a5c
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmCommand.java
1 file changed, 52 insertions(+), 59 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9622
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I5c1eba4ca3e39b4b3ed2142e9e0a964bda7e6a5c
Gerrit-PatchSet: 14
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: core: ImportVm cleanup: CDA_beforeCloneVm sig.
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVm cleanup: CDA_beforeCloneVm sig.
......................................................................
core: ImportVm cleanup: CDA_beforeCloneVm sig.
Stop passing canDoAction to canDoAction_beforeCloneVm, as it is
available as a data member, and does not contribute anything as a
parameter.
Change-Id: I31ff56cd187510ed48c3be66a82b09337e2588bf
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmCommand.java
1 file changed, 3 insertions(+), 2 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/10006
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I31ff56cd187510ed48c3be66a82b09337e2588bf
Gerrit-PatchSet: 7
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: core: ImportVm cleanup: canDoAction_beforeCloneVM
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: ImportVm cleanup: canDoAction_beforeCloneVM
......................................................................
core: ImportVm cleanup: canDoAction_beforeCloneVM
A slight cleanup to canDoAction_beforeCloneVM so it uses the early
return pattern, which is (a bit) more readable.
Change-Id: Ifc6c0916948a1951ff30a4ca25aa113923e0643d
Signed-off-by: Allon Mureinik <amureini(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmCommand.java
1 file changed, 83 insertions(+), 90 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9621
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ifc6c0916948a1951ff30a4ca25aa113923e0643d
Gerrit-PatchSet: 14
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Ayal Baron <abaron(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipchuk(a)redhat.com>
Gerrit-Reviewer: Tal Nisan <tnisan(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: webadmin: Provide entity specific properties to UI plugins
by oourfali@redhat.com
Oved Ourfali has submitted this change and it was merged.
Change subject: webadmin: Provide entity specific properties to UI plugins
......................................................................
webadmin: Provide entity specific properties to UI plugins
Before this patch, UI plugins would receive following base
entity object representation (same for all entity types):
{ 'entityId': '[BusinessEntityGuidAsString]' }
After this patch, UI plugins will receive the same as above
('entityId' renamed to 'id'), plus some additional entity
specific properties:
'name' for Cluster, DataCenter, Host, Storage, Template,
VirtualMachine
More properties can be added later on, as necessary. Note
that this is just a temporary solution, as we plan to use
generated Engine REST API types on the frontend side.
Change-Id: I937640bdddc8b888f517323d0be6b18796e81a05
Signed-off-by: Vojtech Szocs <vszocs(a)redhat.com>
---
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/plugin/PluginEventHandler.java
M frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/plugin/api/PluginUiFunctions.java
D frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/plugin/entity/BaseEntity.java
A frontend/webadmin/modules/webadmin/src/main/java/org/ovirt/engine/ui/webadmin/plugin/entity/EntityObject.java
4 files changed, 104 insertions(+), 54 deletions(-)
Approvals:
Oved Ourfali: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/10158
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I937640bdddc8b888f517323d0be6b18796e81a05
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vojtech Szocs <vszocs(a)redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourfali(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: core: removed unused methods
by lhornyak@redhat.com
Laszlo Hornyak has submitted this change and it was merged.
Change subject: core: removed unused methods
......................................................................
core: removed unused methods
Utility methods isVdsExist and isVdsExistForPendingOvirt are no longer
used, they are deleted.
Change-Id: Ibcbbb708f36312db05169f09e514decc076d6265
Signed-off-by: Laszlo Hornyak <lhornyak(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VdsHandler.java
1 file changed, 0 insertions(+), 54 deletions(-)
Approvals:
Laszlo Hornyak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9707
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibcbbb708f36312db05169f09e514decc076d6265
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
12 years, 1 month
Change in ovirt-engine[master]: core: remove unused private method from AddVdsCommand
by lhornyak@redhat.com
Laszlo Hornyak has submitted this change and it was merged.
Change subject: core: remove unused private method from AddVdsCommand
......................................................................
core: remove unused private method from AddVdsCommand
validateHostUniqueNameAndAddress was not used.
Change-Id: I849faae971693c05be218309bc1f8dd76aafd315
Signed-off-by: Laszlo Hornyak <lhornyak(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AddVdsCommand.java
1 file changed, 0 insertions(+), 12 deletions(-)
Approvals:
Laszlo Hornyak: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/9388
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I849faae971693c05be218309bc1f8dd76aafd315
Gerrit-PatchSet: 6
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alonbl(a)redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchaplik(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Michael Kublin <mkublin(a)redhat.com>
Gerrit-Reviewer: Sharad Mishra <snmishra(a)linux.vnet.ibm.com>
Gerrit-Reviewer: Yair Zaslavsky <yzaslavs(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: core:cleanup: VmDiskOperatinParameterBase typo fix
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core:cleanup: VmDiskOperatinParameterBase typo fix
......................................................................
core:cleanup: VmDiskOperatinParameterBase typo fix
Fixed typo in class name:
VmDiskOperatinParameterBase -->VmDiskOperationParameterBase.
Change-Id: I98e7915119353c789605c9597bf3482e766ee19c
Signed-off-by: Vered Volansky <vvolansk(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/AbstractDiskVmCommand.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/AddDiskParameters.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/AttachDettachVmDiskParameters.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/HotPlugDiskToVmParameters.java
M backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/UpdateVmDiskParameters.java
R backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/action/VmDiskOperationParameterBase.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/disks/DiskListModel.java
M frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmDiskListModel.java
8 files changed, 13 insertions(+), 13 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/10186
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: I98e7915119353c789605c9597bf3482e766ee19c
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Vered Volansky <vvolansk(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: core: fix javadoc in ImagesHandler
by amureini@redhat.com
Allon Mureinik has submitted this change and it was merged.
Change subject: core: fix javadoc in ImagesHandler
......................................................................
core: fix javadoc in ImagesHandler
Change-Id: Ie3973632d6d47dc3257e0bb7a38a1712c61c87ef
Signed-off-by: Alissa Bonas <abonas(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImagesHandler.java
1 file changed, 1 insertion(+), 5 deletions(-)
Approvals:
Allon Mureinik: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/10147
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ie3973632d6d47dc3257e0bb7a38a1712c61c87ef
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Alissa Bonas <abonas(a)redhat.com>
Gerrit-Reviewer: Allon Mureinik <amureini(a)redhat.com>
Gerrit-Reviewer: Daniel Erez <derez(a)redhat.com>
Gerrit-Reviewer: Liron Aravot <laravot(a)redhat.com>
Gerrit-Reviewer: Vered Volansky <vvolansk(a)redhat.com>
12 years, 1 month
Change in ovirt-engine[master]: engine, restapi: Move IdQueryParameters to a common package
by masayag@redhat.com
Moti Asayag has submitted this change and it was merged.
Change subject: engine, restapi: Move IdQueryParameters to a common package
......................................................................
engine, restapi: Move IdQueryParameters to a common package
IdQueryParameters class could be reused beyond the scope of the
gluster package, therefore it is entitled to be under more common
package.
Change-Id: Ib9b919adbfa65169ec4f33a53d13493521d8fd9e
Signed-off-by: Moti Asayag <masayag(a)redhat.com>
---
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GetGlusterBrickByIdQuery.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GetGlusterVolumeBricksQuery.java
M backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GetGlusterVolumeByIdQuery.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetGlusterBrickByIdQueryTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetGlusterVolumeBricksQueryTest.java
M backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/gluster/GetGlusterVolumeByIdQueryTest.java
R backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/queries/IdQueryParameters.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/gluster/BackendGlusterBrickResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/gluster/BackendGlusterBricksResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/gluster/BackendGlusterVolumeResource.java
M backend/manager/modules/restapi/jaxrs/src/main/java/org/ovirt/engine/api/restapi/resource/gluster/BackendGlusterVolumesResource.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/gluster/BackendGlusterBrickResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/gluster/BackendGlusterBricksResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/gluster/BackendGlusterVolumeResourceTest.java
M backend/manager/modules/restapi/jaxrs/src/test/java/org/ovirt/engine/api/restapi/resource/gluster/BackendGlusterVolumesResourceTest.java
15 files changed, 19 insertions(+), 21 deletions(-)
Approvals:
Moti Asayag: Verified; Looks good to me, approved
--
To view, visit http://gerrit.ovirt.org/10163
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Ib9b919adbfa65169ec4f33a53d13493521d8fd9e
Gerrit-PatchSet: 4
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpastern(a)redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkolesni(a)redhat.com>
Gerrit-Reviewer: Moti Asayag <masayag(a)redhat.com>
Gerrit-Reviewer: Shireesh Anjal <sanjal(a)redhat.com>
12 years, 1 month